mono-basic-source_4.0.1-2_all.deb


Advertisement

Description

mono-basic-source - mono-basic source code

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mono-basic-source_4.0.1-2_all.deb
Package name mono-basic-source
Package version 4.0.1
Package release 2
Package architecture all
Package type deb
Category universe/devel
Homepage http://www.mono-project.com/Visual_Basic
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.61 MB
Installed size 1.62 MB
Mono is a platform for running and developing applications based on the
ECMA/ISO Standards. Mono is an open source effort led by Novell.
Mono provides a complete CLR (Common Language Runtime) including compiler and
runtime, which can produce and execute CIL (Common Intermediate Language)
bytecode (aka assemblies), and a class library.
This package contains an archive of the source code used to build the
mono-basic packages in Debian.

Alternatives

Package Version Architecture Repository
mono-basic-source_4.0.1-2_all.deb 4.0.1 all Ubuntu Universe
mono-basic-source - - -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mono-basic-source_4.0.1-2_all.deb
Source Package mono-basic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mono-basic-source deb package:
    # sudo apt-get install mono-basic-source

Files

Path
/usr/share/doc/mono-basic-source/changelog.Debian.gz
/usr/share/doc/mono-basic-source/copyright
/usr/src/mono-basic-source.tar.xz

Changelog

2018-10-28 - Alexandre Viau <aviau@debian.org>
mono-basic (4.0.1-2) unstable; urgency=medium
* Team upload.
* d/watch: point to download.mono-project.com
* d/copyright: use https for Upstream-Source
* d/copyright: modernize format link
* d/control: Vcs-[Git|Browser]: point to salsa
* d/watch: add repacksuffix
* create mono-basic-source package (Closes: #912009)
* bump compat level to 11
* d/changelog: remove trailing whitespaces
* d/control: priority extra -> optional
2015-09-09 - Jo Shields <jo.shields@xamarin.com>
mono-basic (4.0.1-1) unstable; urgency=medium
* [a0b2835] Imported Upstream version 4.0.1
* [66ccc6c] Bump Debhelper compat level to 7
* [026ba69] We only support VB10 now, so delete old
packages & shift dependencies around to match
2014-09-25 - Jo Shields <jo.shields@xamarin.com>
mono-basic (3.8-1) unstable; urgency=medium
* [2d9eb22] Imported Upstream version 3.8
* [d58dc67] Delete resources file in clean rule, to prevent FTBFS
2013-07-09 - Jo Shields <directhex@apebox.org>
mono-basic (3.0~pre20130627.4dcc70f-1) unstable; urgency=low
* [a3bcf78] Imported Upstream version 3.0~git20130424.f5a46b1
* [c57b8a8] Imported Upstream version 3.0~pre20130424b.f338540
* [3b7d846] Imported Upstream version 3.0~pre20130425.a74642a
* [94018a3] Imported Upstream version 3.0~pre20130627.4dcc70f
* [6d60a32] Bump ABI to 2.99, for versioning. We can't use 3.0 here, as
this is as pre-3.0 git snapshot, and this would encode a requirement
on 3.0 final
* [3faddfd] Bump build dependency to Mono 3.0, since we need .NET 4.5
support
* [8f6d231] Add VB2012 (.NET 4.5, VB11) packaging data
* [305bbcb] Refresh debian/copyright with DEP5
* [71da9ff] Modify dependencies of mono-vbnc to include all references
in vbnc.exe.rsp - these are default compiler flags so if they're not
installed, the compiler won't work unless you pass /nostdlib (Closes:
#715480)
* [b9f1d12] Make VB11 pull in VB10 runtime library, due to weird
internal version resolution issues.
2012-01-21 - Jo Shields <directhex@apebox.org>
mono-basic (2.10-2) unstable; urgency=low
* [d90cbc9] Update debian/rules for DH8-compatible "--with cli"
2011-04-09 - Jo Shields <directhex@apebox.org>
mono-basic (2.10-1) experimental; urgency=low
* [813399b] Imported Upstream version 2.10
* [c85d8e8] Stop converting the archive format in get-orig-source rule
* [a8c2507] Use Debian source format 3.0 (quilt)
* [9803c81] Bump Standards to version 3.9.1
* [8c6c640] Convert packaging to DebHelper 7
* [b0a16ff] Bump API version to 2.10, so packages built against mono-
vbnc require 2.10 minimum
* [694e4a4] Ensure we don't run the test suite, since it bails out on
a clean system
* [75b5b78] Since we're building a 4.0 library now, update
debian/install to handle 4.0 libs, not 2.0 libs
* [4e41d8c] Ensure we run the cli-common commands, by including
cli.make in debian/rules
* [0965d04] Split new libraries out into correctly named packages
* [c8c5cd8] Update Vcs-* fields - this package hasn't been in SVN for
ages
* [2772f00] Build-depend on cli-common 0.8, due to 4.0 libraries
* [7c89842] Add a manual dependency on libmono-microsoft-
visualbasic10.0-cil, because mono-vbnc doesn't technically reference
the assembly (it merely explodes in its absence)
* [3fae244] Make use of --exclude-moduleref capability of cli-common-
dev 0.8, to avoid bailing out due to optional Windows-only
P/Invokes.
2010-09-10 - Jo Shields <directhex@apebox.org>
mono-basic (2.6.2-2) unstable; urgency=low
* Upload to Debian Unstable
2010-04-12 - Jo Shields <directhex@apebox.org>
mono-basic (2.6.2-1) experimental; urgency=low
* New upstream release
* debian/control:
+ No-change bump to Standards 3.8.4
* debian/rules:
+ Policy-compliant get-orig-source download location (i.e. ./)

See Also

Package Description
mono-complete_5.18.0.240+dfsg-2ubuntu2_amd64.deb complete Mono runtime, development tools and all libraries
mono-csharp-shell_5.18.0.240+dfsg-2ubuntu2_all.deb interactive C# shell
mono-devel_5.18.0.240+dfsg-2ubuntu2_all.deb Mono development tools
mono-fastcgi-server4_4.2-2.1_all.deb ASP.NET 4.0 backend for FastCGI webservers
mono-fastcgi-server_4.2-2.1_all.deb ASP.NET backend for FastCGI webservers - default version
mono-fpm-server_4.2-2.1_all.deb ASP.NET backend for FastCGI Process Manager
mono-gac_5.18.0.240+dfsg-2ubuntu2_all.deb Mono GAC tool
mono-jay_5.18.0.240+dfsg-2ubuntu2_amd64.deb LALR(1) parser generator oriented to Java/CLI
mono-mcs_5.18.0.240+dfsg-2ubuntu2_all.deb Mono C# 2.0 / 3.0 / 4.0 / 5.0 compiler for CLI 2.0 / 4.0 / 4.5
mono-profiler_4.2-3_all.deb Mono profiler
mono-reference-assemblies-2.0_3.12.1+dfsg-2_all.deb Mono runtime - compiler compatibility for .NET 2.0
mono-reference-assemblies-3.5_3.12.1+dfsg-2_all.deb Mono runtime - compiler compatibility for .NET 3.5
mono-reference-assemblies-4.0_3.12.1+dfsg-2_all.deb Mono runtime - compiler compatibility for .NET 4.0
mono-runtime-boehm_5.18.0.240+dfsg-2ubuntu2_amd64.deb Mono runtime - Boehm
mono-runtime-common_5.18.0.240+dfsg-2ubuntu2_amd64.deb Mono runtime - common files
Advertisement
Advertisement