mongodb-clients_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_amd64.deb


Advertisement

Description

mongodb-clients - object/document-oriented database (client apps)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mongodb-clients_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_amd64.deb
Package name mongodb-clients
Package version 3.6.9+really3.6.8+90~g8e540c0b6d
Package release 0ubuntu2
Package architecture amd64
Package type deb
Category universe/database
Homepage https://www.mongodb.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.83 MB
Installed size 70.21 MB
MongoDB is a high-performance, open source, schema-free
document-oriented data store that's easy to deploy, manage
and use. It's network accessible, written in C++ and offers
the following features:
* Collection oriented storage - easy storage of object-style data
* Full index support, including on inner objects
* Query profiling
* Replication and fail-over support
* Efficient storage of binary data including large objects (e.g. videos)
* Auto-sharding for cloud-level scalability
High performance, scalability, and reasonable depth of
functionality are the goals for the project.
This package contains the standard administrative shell (mongo) and other
utilities for administration or analysis of performance of the server.

Alternatives

Package Version Architecture Repository
mongodb-clients - - -

Requires

Name Value
libboost-filesystem1.67.0 -
libboost-iostreams1.67.0 -
libboost-program-options1.67.0 -
libboost-system1.67.0 -
libc6 >= 2.15
libgcc1 >= 1:3.4
libgoogle-perftools4 -
libpcrecpp0v5 >= 7.7
libsnappy1v5 -
libssl1.1 >= 1.1.0
libstdc++6 >= 6
libstemmer0d >= 0+svn527
libyaml-cpp0.6 >= 0.6.2
zlib1g >= 1:1.2.0

Replaces

Name Value
mongodb <= 1:1.4.2-2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mongodb-clients_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_amd64.deb
Source Package mongodb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mongodb-clients deb package:
    # sudo apt-get install mongodb-clients

Files

Path
/usr/bin/mongo
/usr/bin/mongoperf
/usr/share/doc/mongodb-clients/NEWS.Debian.gz
/usr/share/doc/mongodb-clients/changelog.Debian.gz
/usr/share/doc/mongodb-clients/copyright
/usr/share/man/man1/mongo.1.gz
/usr/share/man/man1/mongoperf.1.gz

Changelog

2018-12-11 - Christopher James Halse Rogers <raof@ubuntu.com>
mongodb (1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2) disco; urgency=medium
* No change rebuild against libyaml-cpp0.6
2018-11-26 - Dimitri John Ledkov <xnox@ubuntu.com>
mongodb (1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu1) disco; urgency=medium
* New, slightly older, upstream release, whilst the reviews are pending.
2018-09-24 - Dimitri John Ledkov <xnox@ubuntu.com>
mongodb (1:3.6.8-0ubuntu3+ppa1) disco; urgency=medium
* New upstream release
* Cherrypick patch to disable new gcc 8.2 warnings
* Add python-regex build dependency
* Add missing tls13 counter
* Refresh skip-dns lookups patch
2018-07-17 - Matthias Klose <doko@ubuntu.com>
mongodb (1:3.6.3-0ubuntu2) cosmic; urgency=medium
* No-change rebuild for boost soname change.
2018-04-11 - Robie Basak <robie.basak@ubuntu.com>
mongodb (1:3.6.3-0ubuntu1) bionic; urgency=medium
* New upstream release (LP: #1761807).
* d/watch: update.
* d/upstream/signing-key.asc: update.
* Drop d/p/CVE-2016-6494.patch: no longer needed as fixed upstream by
use of open(2) with S_IRUSR | S_IWUSR.
* Drop d/p/asio-openssl-1.1-support.patch: this backport is no longer
required as upstream successfully builds directly against OpenSSL
1.1 now.
* d/p/fix-ftbfs-with-gcc-7.patch: refresh to remove fuzz.
* d/copyright: update.
* d/control: build dependency changes:
- Add new dependencies required for a successful build
(libmongoc-dev, python-cheetah, python-pkg-resources,
python-requests, python-typing).
- Drop python (not required directly).
* d/p/SERVER-34117-skip-dns-tests.patch: disable some tests that require
network access.
* d/p/strip-test-binaries.patch: strip test binaries to reduce build size to
within Launchpad's limit.
2018-04-11 - Gianfranco Costamagna <locutusofborg@debian.org>
mongodb (1:3.4.14-3ubuntu2) bionic; urgency=medium
* Update breaks+replaces to the correct version (LP: #1762915)
2018-04-10 - Gianfranco Costamagna <locutusofborg@debian.org>
mongodb (1:3.4.14-3ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Rework Breaks+Replaces for the bionic version, this can be dropped
once bionic is out.
2018-03-23 - Apollon Oikonomopoulos <apoikos@debian.org>
mongodb (1:3.4.14-3) unstable; urgency=medium
* d/control: correct mongodb-server-core Breaks/Replaces (Closes: #893893)
2018-03-23 - Apollon Oikonomopoulos <apoikos@debian.org>
mongodb (1:3.4.14-2) unstable; urgency=medium
* Fix altivec-related FTBFS on ppc64el
2018-03-22 - Apollon Oikonomopoulos <apoikos@debian.org>
mongodb (1:3.4.14-1) unstable; urgency=medium
* New upstream stable release (Closes: #882643)
* Drop/Refresh patches
+ Drop patches for architectures no longer built
- 0001-Create-kfreebsd-like-linux-in-most-respects.patch
- 0002-kfreebsd-has-dev-urandom.patch
- 0012-support-gnu.patch
- use-mmapv1-on-i386
+ Drop obsolete/merged patches
- fix-boost-1.62-build.patch
- fix-gcc-6-ftbfs.patch
- use-std::regex.patch
- fix-build-with-openssl-1.1.patch
- fix-mozjs-38-segfaults.patch
- arm64-48bit-va-compat.patch
- scons-3.0-compat.patch
+ Refresh fix-ftbfs-with-gcc-7.patch
* Ship the mongod and mongos binaries in mongodb-server-core. This allows
the use of special-purpose Mongo instances without the need for a
system-wide setup (Closes: #893621). Thanks to Robie Basak!
* Upload to unstable, merging all experimental development history
* Switch Vcs-* URLs to salsa.d.o
* Bump Standards-Version to 4.1.3; no changes needed
* Bump dh compat to 11
+ Use dh_missing instead of dh_install --list-missing
+ Use dh_installsystemd instead of dh_systemd_enable
* d/rules: do not pass --parallel to dh, this is now done by default
* d/watch: switch URL to https://
* d/mongodb.conf: rename oplog to diaglog (Closes: #892955)

See Also

Package Description
mongodb-dev_1.1.3-3_all.deb MongoDB C++ Driver (transitional package)
mongodb-server-core_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_amd64.deb object/document-oriented database (server binaries package)
mongodb-server_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_all.deb object/document-oriented database (managed server package)
mongodb_3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2_amd64.deb object/document-oriented database (metapackage)
mongoose_5.4.0+dfsg-1_amd64.deb graph partitioning tool that can quickly compute edge cuts (executable)
mongrel2-core_1.12.0-2_amd64.deb programming language agnostic web server (binaries)
mongrel2-run_1.12.0-2_all.deb programming language agnostic web server
monit_5.25.2-3_amd64.deb utility for monitoring and managing daemons or similar programs
monitoring-plugins-basic_2.2-5_amd64.deb Plugins for nagios compatible monitoring systems (basic)
monitoring-plugins-btrfs_11-1_all.deb btrfs plugin for nagios compatible monitoring systems
monitoring-plugins-common_2.2-5_amd64.deb Common files for plugins for nagios compatible monitoring
monitoring-plugins-standard_2.2-5_amd64.deb Plugins for nagios compatible monitoring systems (standard)
monitoring-plugins_2.2-5_all.deb Plugins for nagios compatible monitoring systems (metapackage)
monitorix_3.10.1-1_all.deb lightweight system monitoring tool
monkeysign-doc_2.2.4ubuntu1_all.deb OpenPGP key signing and exchange for humans (documentation)
Advertisement
Advertisement