mini-dinstall_0.6.31ubuntu1_all.deb


Advertisement

Description

mini-dinstall - daemon for updating Debian packages in a repository

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename mini-dinstall_0.6.31ubuntu1_all.deb
Package name mini-dinstall
Package version 0.6.31ubuntu1
Package release -
Package architecture all
Package type deb
Category universe/devel
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 33.30 KB
Installed size 162.00 KB
This program implements a miniature version of the "dinstall" program
which installs packages in the Debian archive.  It doesn't require a
PostgreSQL database, and is very easy to set up, maintain, and use.
mini-dinstall can be run via cron, or as a daemon.
This package is expressly designed for personal apt repositories, and
the like.  In this vein, it contains fewer sanity checks; for
example, it will happily install a lower version of a package.  You
can also generally just 'rm' files from the repository, and
mini-dinstall won't care.  In fact, (when run as a daemon) it will
automatically detect that the directory changed, and update the
Packages file.

Alternatives

Package Version Architecture Repository
mini-dinstall_0.6.31ubuntu1_all.deb 0.6.31ubuntu1 all Ubuntu Universe
mini-dinstall - - -

Requires

Name Value
apt-utils -
python-apt >= 0.7.93
python-lzma -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package mini-dinstall_0.6.31ubuntu1_all.deb
Source Package mini-dinstall

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mini-dinstall deb package:
    # sudo apt-get install mini-dinstall

Files

Path
/usr/bin/mini-dinstall
/usr/lib/python2.7/dist-packages/mini_dinstall-0.0.0.egg-info
/usr/lib/python2.7/dist-packages/minidinstall/ChangeFile.py
/usr/lib/python2.7/dist-packages/minidinstall/DebianSigVerifier.py
/usr/lib/python2.7/dist-packages/minidinstall/Dnotify.py
/usr/lib/python2.7/dist-packages/minidinstall/DpkgControl.py
/usr/lib/python2.7/dist-packages/minidinstall/DpkgDatalist.py
/usr/lib/python2.7/dist-packages/minidinstall/GPGSigVerifier.py
/usr/lib/python2.7/dist-packages/minidinstall/OrderedDict.py
/usr/lib/python2.7/dist-packages/minidinstall/SafeWriteFile.py
/usr/lib/python2.7/dist-packages/minidinstall/SignedFile.py
/usr/lib/python2.7/dist-packages/minidinstall/__init__.py
/usr/lib/python2.7/dist-packages/minidinstall/mail.py
/usr/lib/python2.7/dist-packages/minidinstall/misc.py
/usr/lib/python2.7/dist-packages/minidinstall/tweet.py
/usr/lib/python2.7/dist-packages/minidinstall/version.py
/usr/share/doc/mini-dinstall/AUTHORS
/usr/share/doc/mini-dinstall/NEWS.Debian.gz
/usr/share/doc/mini-dinstall/README
/usr/share/doc/mini-dinstall/TODO
/usr/share/doc/mini-dinstall/changelog.gz
/usr/share/doc/mini-dinstall/copyright
/usr/share/doc/mini-dinstall/examples/mini-dinstall.conf.gz
/usr/share/doc/mini-dinstall/examples/mini-dinstall.conf.walters
/usr/share/doc/mini-dinstall/examples/sign-release.sh
/usr/share/man/man1/mini-dinstall.1.gz

Changelog

2017-10-28 - Bhavani Shankar <bhavi@ubuntu.com>
mini-dinstall (0.6.31ubuntu1) bionic; urgency=medium
* Merge from Debian unstable.  Remaining changes:
- minidinstall/version.py: set current version.
- debian/control: modify Suggests to ubuntu-keyring
- Change all occurrences of /usr/share/keyrings/debian-keyring.gpg to
/usr/share/keyrings/ubuntu-archive-keyring.gpg.
- minidinstall/DebianSigVerifier.py: Remove debian-keyring.pgp.
2017-09-05 - Guido Günther <agx@sigxcpu.org>
mini-dinstall (0.6.31) unstable; urgency=medium
[ Unit 193 ]
* [acad13c] Add xz support for package files.
* [e78b016] Allow re-installing same version packages. (Closes: #680782)
* [7b759e5] Remove bzip2 compressed package files.
* [c660ff0] Remove gzip compressed package files.
* [a208f0d] Generate Contents files when using flat archive type.
* [c3615cb] Only use sha256 hashes, dropping sha1 and md5.
* [78fa964] Fix manpage formatting, describe backport_release and
experimental_release.
* [ce6a7ab] Add configurable support for by-hash, on by default.
* [159f01d] Properly handle .buildinfo files.
* [36078e2] Add a new option 'expire_release_files' to enable 'Valid-Until'
with a life of 4 weeks.
* [8f59711] Enable the 'Signed-By' feature by setting GPG IDs in 'keyids'
* [8e1a34e] Account for '.ddeb' dbgsym extension in debpackage regex.
[ Heinrich Schuchardt ]
* [aad441a] Correct the documentation for option experimental_release.
The default value is 0 (not None). (Closes: #820580)
* [cddf838] Add option backport_release to the configuration file.
If this option is set mini-dinstall writes
"NotAutomatic: yes" and "ButAutomaticUpgrades: yes"
to the Release file. (Closes: #820582)
[ Krytarik Raido ]
* [26c7a76] Reduce code duplication in ArchiveDir.
[ Guido Günther ]
* [0867275] Add gbp.conf
2014-11-15 - Bhavani Shankar <bhavi@ubuntu.com>
mini-dinstall (0.6.30ubuntu1) vivid; urgency=medium
* Merge from Debian unstable.  Remaining changes:
- minidinstall/version.py: set current version.
- debian/control: modify Suggests to ubuntu-keyring
- Change all occurrences of /usr/share/keyrings/debian-keyring.gpg to
/usr/share/keyrings/ubuntu-archive-keyring.gpg.
- minidinstall/DebianSigVerifier.py: Remove debian-keyring.pgp.
2014-08-25 - Christoph Goehre <christoph.goehre@gmx.de>
mini-dinstall (0.6.30) unstable; urgency=low
* [885f9fc] lintian: fix vcs-field-not-canonical
* [61d551a] bump up Standards-Version to 3.9.5
* [dbdacea] transition from python-support to dh_python2
* [dbf811a] switch from cdbs to dh
* [4ccc409] increase debhelper compat level to 9
2011-12-17 - Mahyuddin Susanto <udienz@ubuntu.com>
mini-dinstall (0.6.29ubuntu1) precise; urgency=low
* Merge from debian testing. (LP: #905671) Remaining changes:
- minidinstall/version.py: set current version.
- debian/control: modify Suggests to ubuntu-keyring
- Change all occurrences of /usr/share/keyrings/debian-keyring.gpg to
/usr/share/keyrings/ubuntu-archive-keyring.gpg.
- minidinstall/DebianSigVerifier.py: Remove debian-keyring.pgp.
* mini-dinstall: Dropped applied in Debian.
2011-10-06 - Christoph Goehre <christoph.goehre@gmx.de>
mini-dinstall (0.6.29) unstable; urgency=low
[ Christoph Goehre ]
* [d4fa57e] logging.StreamHandler use sys.stderr as default output
(Closes: #613992, #644419)
* [91d0786] add Date and Message-ID header fields in email from mini-dinstall
* [d7f3643] bump up Standards-Version to 3.9.2
* [b659d79] DM-Upload-Allowed is superfluous since I'm DD
[ Sven Hartge ]
* [b27e3ab] add support for new InRelease file
[ Christoph Goehre ]
2011-05-30 - Mackenzie Morgan <maco.m@ubuntu.com>
mini-dinstall (0.6.28.1ubuntu3) oneiric; urgency=low
* DebianSigVerifier.py: (LP: 3417)
Remove debian-keyring.pgp, since that change was lost in merge
2011-02-18 - Sameer Morar <smorar@gmail.com>
mini-dinstall (0.6.28.1ubuntu2) natty; urgency=low
* mini-dinstall: Fix error using logging.StreamHandler (LP: #721413)

See Also

Package Description
mini-httpd-run_1.0_all.deb Small HTTP server (Runit integration)
mini-httpd_1.30-0.2_amd64.deb Small HTTP server
minia_1.6906-2_amd64.deb short-read biological sequence assembler
miniasm_0.3+dfsg-1_amd64.deb ultrafast de novo assembler for long noisy DNA sequencing reads
minica_1.0-1build1_amd64.deb super micro binary to issue new CAs
minicom_2.7.1-1build1_amd64.deb Friendly menu driven serial communication program
minicoredumper-utils_2.0.1-1_amd64.deb minicoredumper utilities
minicoredumper_2.0.1-1_amd64.deb generate minimal and customized core dump files on Linux
minidisc-utils_0.9.16-2_amd64.deb Command line utilities for MiniDisc access
minidjvu_0.8.svn.2010.05.06+dfsg-6_amd64.deb Monochrome DjVu multipage encoder, single page encoder/decoder
minidlna_1.2.1+dfsg-1build1_amd64.deb lightweight DLNA/UPnP-AV server targeted at embedded systems
minify_2.3.8-1_amd64.deb CLI implementation of the Go minify library package
minilzip_1.11-3_amd64.deb minified, lossless data compressor based on the LZMA algorithm
minimac4_1.0.0-2_amd64.deb Fast Imputation Based on State Space Reduction HMM
minimap2_2.15+dfsg-1_amd64.deb versatile pairwise aligner for genomic and spliced nucleotide sequences
Advertisement
Advertisement