kgraphviewer-dev_2.1.90-0ubuntu3_amd64.deb


Advertisement

Description

kgraphviewer-dev - GraphViz dot graph viewer - devel files

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename kgraphviewer-dev_2.1.90-0ubuntu3_amd64.deb
Package name kgraphviewer-dev
Package version 2.1.90
Package release 0ubuntu3
Package architecture amd64
Package type deb
Category universe/devel
Homepage http://extragear.kde.org/apps/kgraphviewer/
License -
Maintainer Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Download size 21.41 KB
Installed size 97.00 KB
KGraphViewer is a GraphViz dot graph viewer. The graphviz program
suite is a free software set of layout engines for graphs. They are commonly
used in scientific domains and particularly in computer science. But until
now there was a lack of a GUI to look at the graphs. Programs provided with
GraphViz are: I feel, out of date X11, or Tcl/Tk applications with few
Functionalities. KGraphViewer is aimed at replacing these tools with a modern
user-friendly GUI will all the power of a well integrated KDE application.

Alternatives

Package Version Architecture Repository
kgraphviewer-dev_2.1.90-0ubuntu3_i386.deb 2.1.90 i386 Ubuntu Universe
kgraphviewer-dev - - -

Requires

Name Value
kgraphviewer = 4:2.1.90-0ubuntu3
libc6 >= 2.4
libkdecore5 >= 4:4.4.95
libkdeui5 >= 4:4.3.4
libkgraphviewer2 -
libkparts4 >= 4:4.5.85
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libstdc++6 >= 5

Download

Type URL
Mirror archive.ubuntu.com
Binary Package kgraphviewer-dev_2.1.90-0ubuntu3_amd64.deb
Source Package kgraphviewer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install kgraphviewer-dev deb package:
    # sudo apt-get install kgraphviewer-dev

Files

Path
/usr/include/kgraphviewer/dotgraphview.h
/usr/include/kgraphviewer/kgraphviewer_export.h
/usr/include/kgraphviewer/kgraphviewer_interface.h
/usr/lib/libkgraphviewer.so
/usr/lib/kde4/kgraphviewerpart.so
/usr/share/doc/kgraphviewer-dev/changelog.Debian.gz
/usr/share/doc/kgraphviewer-dev/copyright

Changelog

2018-04-03 - Balint Reczey <rbalint@ubuntu.com>
kgraphviewer (4:2.1.90-0ubuntu3) bionic; urgency=high
* No change rebuild to pick up -fPIE compiler default
2015-08-14 - Harald Sitter <sitter@kde.org>
kgraphviewer (4:2.1.90-0ubuntu2) wily; urgency=medium
* Change build dependency libboost1.55-dev to libboost-dev to facilitate
gcc5 transition.
2014-06-26 - Scarlett Clark <scarlett@scarlettgatelyclark.com>
kgraphviewer (4:2.1.90-0ubuntu1) utopic; urgency=medium
* New upstream release 
2012-05-29 - Scott Kitterman <scott@kitterman.com>
kgraphviewer (4:2.1.1-0ubuntu2) quantal; urgency=low
* Build with boost1.49
2011-08-05 - Scott Kitterman <scott@kitterman.com>
kgraphviewer (4:2.1.1-0ubuntu1) oneiric; urgency=low
* New upstream release
- Remove debian/patches/doctype_version.patch (incorporated upstream)
* Build with boost1.46
* Update debian/rules to match current KDE package best practices
2010-10-16 - Scott Kitterman <scott@kitterman.com>
kgraphviewer (4:2.0.2-kde4.4.0-0ubuntu4) natty; urgency=low
* Build with boost1.42
2010-08-09 - Michael Bienia <geser@ubuntu.com>
kgraphviewer (4:2.0.2-kde4.4.0-0ubuntu3) maverick; urgency=low
* Bump the doctype version to 4.2 in all index.docbook (fixes FTBFS). 
2010-05-23 - Andreas Wenning <awen@awen.dk>
kgraphviewer (4:2.0.2-kde4.4.0-0ubuntu2) maverick; urgency=low
* Rebuild for new graphviz package name changes.
* debian/control: Add graphviz to depends. (LP: #432356)
2010-02-12 - Alessandro Ghersi <alessandro-ghersi@kubuntu.org>
kgraphviewer (4:2.0.2-kde4.4.0-0ubuntu1) lucid; urgency=low
* New upstream release
- Bump compat to 7
- Bump build-depends and Standards-version
- Source format 3.0
- Build againsta libphonon-dev
- Drop cdbs
- Build with dh --with kde in rules
- Add pkg-kde-tools to build-depends
- Drop debian/patches went to upstream
- Add ${misc:Depends} to depends
2009-12-17 - Michał Zając <michal.zajac@gmail.com>
kgraphviewer (4:2.0.2-kde4.3.0-0ubuntu4) lucid; urgency=low
* Build with boost 1.40.

See Also

Package Description
kgraphviewer_2.1.90-0ubuntu3_amd64.deb GraphViz dot graph viewer
khal-doc_0.9.10-1_all.deb Standards based CLI and terminal calendar program - documentation
khal_0.9.10-1_all.deb Standards based CLI and terminal calendar program
khangman_18.12.3-0ubuntu1_amd64.deb Hangman word puzzle
khard_0.13.0-1_amd64.deb address book for the Linux console
khelpcenter_18.12.3-0ubuntu1_amd64.deb KDE documentation viewer
khmer-common_2.1.2+dfsg-6_all.deb common files for the khmer project tools
khmer_2.1.2+dfsg-6_amd64.deb in-memory DNA sequence kmer counting, filtering & graph traversal
khmerconverter_1.4-1.2_all.deb converts between legacy Khmer encodings and Unicode
khotkeys-data_5.15.4-0ubuntu1_all.deb configure input actions settings
khotkeys-dev_5.15.4-0ubuntu1_amd64.deb configure input actions settings
khotkeys_5.15.4-0ubuntu1_amd64.deb configure input actions settings
khronos-api_4.6+git20180514-1_all.deb Khronos XML API Registry
kicad-common_5.0.2+dfsg1-1_all.deb Old common files used by kicad - Transitional Package
kicad-demos_5.0.2+dfsg1-1_all.deb Demo projects for kicad
Advertisement
Advertisement