freeciv-client-qt_2.6.0-2_amd64.deb


Advertisement

Description

freeciv-client-qt - Civilization turn based strategy game (Qt client)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename freeciv-client-qt_2.6.0-2_amd64.deb
Package name freeciv-client-qt
Package version 2.6.0
Package release 2
Package architecture amd64
Package type deb
Category universe/games
Homepage http://www.freeciv.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.05 MB
Installed size 3.45 MB
Freeciv is a free clone of the turn based strategy game Civilization.
In this game, each player becomes leader of a civilisation, fighting to
obtain the ultimate goal: the extinction of all other civilisations.
This is the Qt version of Freeciv.

Alternatives

Package Version Architecture Repository
freeciv-client-qt_2.6.0-2_i386.deb 2.6.0 i386 Ubuntu Universe
freeciv-client-qt - - -

Requires

Name Value
freeciv-data = 2.6.0-2
libbz2-1.0 -
libc6 >= 2.29
libcurl3-gnutls >= 7.16.2
libgcc1 >= 1:3.0
liblzma5 >= 5.1.1alpha+20120614
libqt5core5a >= 5.11.0~rc1
libqt5gui5 >= 5.7.0
libqt5gui5-gles >= 5.7.0
libqt5widgets5 >= 5.11.0~rc1
libsdl2-2.0-0 >= 2.0.9
libsdl2-mixer-2.0-0 >= 2.0.2
libstdc++6 >= 5.2
zlib1g >= 1:1.1.4

Replaces

Name Value
freeciv-data << 2.5.6-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package freeciv-client-qt_2.6.0-2_amd64.deb
Source Package freeciv

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install freeciv-client-qt deb package:
    # sudo apt-get install freeciv-client-qt

Files

Path
/usr/games/freeciv-qt
/usr/share/applications/freeciv-qt.desktop
/usr/share/doc/freeciv-client-qt
/usr/share/man/man6/freeciv-qt.6.gz
/usr/share/metainfo/freeciv-qt.appdata.xml

Changelog

2019-03-02 - Markus Koschany <apo@debian.org>
freeciv (2.6.0-2) unstable; urgency=medium
* Update themes_sdl_use_system_fonts.patch and support the gui-sdl2 theme too.
Thanks to Lars Kruse for the report. (Closes: #923563)
* Declare compliance with Debian Policy 4.3.0.
* Use canonical VCS URI.
2018-07-30 - Markus Koschany <apo@debian.org>
freeciv (2.6.0-1) unstable; urgency=medium
* New upstream version 2.6.0.
- Freeciv now supports changing the limits in the citizen manager. This is
client-specific but the GTK 3 client is the new default.
(Closes: #659644)
- Freeciv will remember the last connected server to. The option is
disabled by default though. (Closes: #410558)
* Declare compliance with Debian Policy 4.1.5.
* freeciv metapackage: The recommended client is GTK 3 now.
* d/rules: Remove --enable-sys-lua option because this one is the default now.
* Switch from SDL1 to SDL2 build-dependencies. All clients use SDL2 now.
* Use new --disable-freeciv-manual option.
* Add freeciv-client-gtk2-appdata.patch and fix incorrect appdata file.
2018-03-26 - Markus Koschany <apo@debian.org>
freeciv (2.5.11-1) unstable; urgency=medium
* New upstream version 2.5.11.
2018-01-22 - Markus Koschany <apo@debian.org>
freeciv (2.5.10-1) unstable; urgency=medium
* New upstream version 2.5.10.
* Use compat level 11.
* Declare compliance with Debian Policy 4.1.3.
2017-08-19 - Markus Koschany <apo@debian.org>
freeciv (2.5.9-1) unstable; urgency=medium
* New upstream version 2.5.9.
2017-08-17 - Markus Koschany <apo@debian.org>
freeciv (2.5.8-1) unstable; urgency=medium
* New upstream version 2.5.8.
* Declare compliance with Debian Policy 4.0.1.
* Refresh themes_sdl_use_system_fonts.patch.
* Install appdata files into metainfo directory.
2017-06-23 - Markus Koschany <apo@debian.org>
freeciv (2.5.7-2) unstable; urgency=medium
* Upload to unstable.
* Declare compliance with Debian Policy 4.0.0.
* Use https for Format field.
2017-05-13 - Markus Koschany <apo@debian.org>
freeciv (2.5.7-1) experimental; urgency=medium
* New upstream version 2.5.7.
* Drop deprecated menu files.
* Don't convert icons to xpm images anymore and drop imagemagick from B-D.
* Update watch file. gna.org is closing soon.
2016-12-20 - Markus Koschany <apo@debian.org>
freeciv (2.5.6-2) unstable; urgency=medium
* Install the appdata files into the individual freeciv client packages.
Thanks to Laurent Bigonville for the report and patch. (Closes: #848720)
* Remove dh-autoreconf from Build-Depends because compat level 10 uses it by
default.
2016-11-19 - Markus Koschany <apo@debian.org>
freeciv (2.5.6-1) unstable; urgency=medium
* New upstream version 2.5.6.

See Also

Package Description
freeciv-client-sdl_2.6.0-2_amd64.deb Civilization turn based strategy game (SDL client)
freeciv-data_2.6.0-2_all.deb Civilization turn based strategy game (data)
freeciv-server_2.6.0-2_amd64.deb Civilization turn based strategy game (server files)
freeciv-sound-standard_2.6.0-2_all.deb Civilization turn based strategy game (standard sound pack)
freeciv_2.6.0-2_all.deb Civilization turn based strategy game
freecol_0.11.6+dfsg2-2_all.deb open source remake of the old Colonization
freecontact_1.0.21-7_amd64.deb fast protein contact predictor
freediameter-extensions_1.2.1-7_amd64.deb Extensions for the Diameter protocol
freediameter_1.2.1-7_all.deb Implementation of the freeDiameter protocol - metapackage
freediameterd_1.2.1-7_amd64.deb Daemon for the Diameter protocol
freediams-doc-en_0.9.4-2_all.deb FreeDiams English documentation
freediams-doc-fr_0.9.4-2_all.deb FreeDiams French documentation
freediams_0.9.4-2_amd64.deb pharmaceutical drug prescription and interaction manager
freedict-tools_0.5.0~beta.4-1_all.deb Development files for the FreeDict dictionary packages
freedink-data_1.08.20190120-1_all.deb adventure and role-playing game (assets)
Advertisement
Advertisement