python3-django-openstack-auth_15.1.0-0ubuntu1.1_all.deb


Advertisement

Description

python3-django-openstack-auth - Django authentication backend for Openstack - Python 3

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Proposed Main i386
Package filename python3-django-openstack-auth_15.1.0-0ubuntu1.1_all.deb
Package name python3-django-openstack-auth
Package version 15.1.0
Package release 0ubuntu1.1
Package architecture all
Package type deb
Category python
Homepage https://launchpad.net/horizon
License -
Maintainer Chuck Short <zulcss@ubuntu.com>
Download size 43.39 KB
Installed size 325.00 KB
Django authentication backend for use with the OpenStack Keystone Identity
backend. This Python module is used by Horizon (the Openstack Dashport web
GUI) to auth against Keystone.
This package provides the Python 3 module.

Alternatives

Package Version Architecture Repository
python3-django-openstack-auth_15.1.0-0ubuntu1.1_all.deb 15.1.0 all Ubuntu Proposed Main
python3-django-openstack-auth_15.0.0-0ubuntu1_all.deb 15.0.0 all Ubuntu Main
python3-django-openstack-auth_15.0.0-0ubuntu1_all.deb 15.0.0 all Ubuntu Main
python3-django-openstack-auth - - -

Requires

Name Value
python3-babel >= 2.3.4
python3-ceilometerclient >= 2.5.0
python3-cinderclient >= 1:4.0.0
python3-django >= 1.11
python3-django-babel >= 0.6.2
python3-django-compressor >= 2.0
python3-django-debreach >= 1.4.2
python3-django-pyscss >= 2.0.2
python3-futurist >= 1.2.0
python3-glanceclient >= 1:2.8.0
python3-heatclient >= 1.10.0
python3-iso8601 >= 0.1.11
python3-keystoneauth1 >= 3.4.0
python3-keystoneclient >= 1:3.15.0
python3-memcache -
python3-netaddr >= 0.7.18
python3-neutronclient >= 1:6.7.0
python3-novaclient >= 2:9.1.0
python3-oslo.concurrency >= 3.26.0
python3-oslo.config >= 1:5.2.0
python3-oslo.i18n >= 3.15.3
python3-oslo.policy >= 1.30.0
python3-oslo.serialization >= 2.18.0
python3-oslo.utils >= 3.33.0
python3-osprofiler >= 2.3.0
python3-pbr >= 2.0.0
python3-pint >= 0.5
python3-pymongo >= 3.0.2
python3-pyscss >= 1.3.4
python3-requests >= 2.14.2
python3-six >= 1.10.0
python3-swiftclient >= 1:3.2.0
python3-tz >= 2013.6
python3-yaml >= 3.12
python3:any -

Provides

Name Value
python3-openstack-auth -

Replaces

Name Value
python3-openstack-auth << 3:13.0.0~b2-0ubuntu2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-django-openstack-auth_15.1.0-0ubuntu1.1_all.deb
Source Package horizon

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://archive.ubuntu.com/ubuntu/ disco-proposed main
  2. Update the package index:
    # sudo apt-get update
  3. Install python3-django-openstack-auth deb package:
    # sudo apt-get install python3-django-openstack-auth

Changelog

2019-07-31 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.1.0-0ubuntu1.1) disco; urgency=medium
* No change rebuild to pick up xstatic orig tarball.
2019-07-29 - Sahid Orentino Ferdjaoui <sahid.ferdjaoui@canonical.com>
horizon (3:15.1.0-0ubuntu1) disco; urgency=medium
[ Corey Bryant ]
* d/gbp.conf: Create stable/stein branch.
[ Sahid Orentino Ferdjaoui ]
* New stable point release for OpenStack Stein (LP: #1837905).
* d/p/set-min-version-of-python-cinderclient-to-4.0.0.patch: Dropped.
Fixed in upstream 15.1.0.
2019-04-12 - James Page <james.page@ubuntu.com>
horizon (3:15.0.0-0ubuntu1) disco; urgency=medium
* New upstream release for OpenStack Stein.
2019-04-09 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~rc2-0ubuntu2) disco; urgency=medium
* d/p/set-min-version-of-python-cinderclient-to-4.0.0.patch: Ensure
python3-cinderclient is >= 4.0.0, as this is required for create/update
of volumes from the horizon dashboard (LP: #1824017).
2019-04-05 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~rc2-0ubuntu1) disco; urgency=medium
* New upstream release candidate for OpenStack Stein.
* d/p/drop-devicename-creating-server-with-image-boot-to-volume.patch:
Dropped. Included in new upstream release candidate.
2019-04-01 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~rc1-0ubuntu2) disco; urgency=medium
[ Corey Bryant ]
* Revert commited quilt patches.
* Re-import orig tarball to fix broken svg files.
[ Karl Williams ]
* d/theme/ubuntu/_styles.scss: Fixing white bar on top of login
page (LP: #1818770).
[ Sahid Orentino Ferdjaoui]
* d/theme/ubuntu/img: Replacing the corrupted PNG image
image-background-pattern.png (LP: #1821896)
[ Eric Desrochers ]
* d/p/drop-devicename-creating-server-with-image-boot-to-volume.patch:
When creating a server using an image boot source to new volume,
horizon specified device_name 'vda'. If for instance we use an image
with disk_bus type scsi, horizon will name the device_name as 'vda'
when it should be 'sda'. As per BDMv2 documentation, it's best to not
specify device_name. (LP: #1822129)
2019-03-22 - James Page <james.page@ubuntu.com>
horizon (3:15.0.0~rc1-0ubuntu1) disco; urgency=medium
* New upstream release candidate for OpenStack Stein.
2019-03-13 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~b2-0ubuntu1) disco; urgency=medium
* d/watch: Scope to 15.x series.
* New upstream milestone for OpenStack Stein.
* d/control: Align (Build-)Depends with upstream.
* d/p/ubuntu_settings.patch: Rebased.
2019-01-31 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~b2~git2019013121.d11ab7b28-0ubuntu1) disco; urgency=medium
* New upstream snapshot for OpenStack Stein.
* d/p/ubuntu_settings.patch: Rebased.
2018-11-27 - Corey Bryant <corey.bryant@canonical.com>
horizon (3:15.0.0~b1~git2018112014.c4515d1bf-0ubuntu2) disco; urgency=medium
* d/openstack-dashboard.postinst: Ensure that if memcached is installed it is
restarted in post-install script after collecting/compressing static assets,
enabling refresh of memcached static assets after upgrade (LP: #1802226).

See Also

Package Description
python3-eventlet_0.24.1-0ubuntu3.1_all.deb concurrent networking library - Python 3.x
python3-google-compute-engine_20190801-0ubuntu1~19.04.0_all.deb Python library for Google Compute Engine interaction (Python 3)
python3-keystone_15.0.0-0ubuntu1.2_all.deb OpenStack identity service - Python 3 library
snapd_2.41+19.04_i386.deb Daemon and tooling that enable snap packages
ubuntu-core-snapd-units_2.41+19.04_all.deb transitional dummy package
Advertisement
Advertisement