libminiupnpc17_2.1-1build1_i386.deb


Advertisement

Description

libminiupnpc17 - UPnP IGD client lightweight library

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Main i386
Package filename libminiupnpc17_2.1-1build1_i386.deb
Package name libminiupnpc17
Package version 2.1
Package release 1build1
Package architecture i386
Package type deb
Category libs
Homepage http://miniupnp.free.fr/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 26.62 KB
Installed size 84.00 KB
The UPnP protocol is supported by most home adsl/cable routers and Microsoft
Windows 2K/XP. The aim of the MiniUPnP project is to bring a free software
solution to support the "Internet Gateway Device" part of the protocol. The
MediaServer/MediaRenderer UPnP protocol is also becoming very popular.
Miniupnpc aims at the simplest library possible, with the smallest footprint
and no dependencies to other libraries such as XML parsers or HTTP
implementations. All the code is pure ANSI C. Compiled on a x86 PC, the
miniupnp client library have less than 15KB code size. For instance, the upnpc
sample program is around 20KB. The miniupnp daemon is much smaller than any
other IGD daemon and is ideal for using on low memory device for this reason.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libminiupnpc17_2.1-1build1_amd64.deb 2.1 amd64 Ubuntu Main
libminiupnpc17 - - -

Requires

Name Value
libc6 >= 2.15

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libminiupnpc17_2.1-1build1_i386.deb
Source Package miniupnpc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libminiupnpc17 deb package:
    # sudo apt-get install libminiupnpc17

Files

Path
/usr/lib/i386-linux-gnu/libminiupnpc.so.17
/usr/share/doc/libminiupnpc17/changelog.Debian.gz
/usr/share/doc/libminiupnpc17/copyright

Changelog

2018-10-31 - Matthias Klose <doko@ubuntu.com>
miniupnpc (2.1-1build1) disco; urgency=medium
* No-change rebuild to build for python3.7 as the default.
2018-05-23 - Yangfl <mmyangfl@gmail.com>
miniupnpc (2.1-1) unstable; urgency=medium
* New upstream release.
* debian/watch: Check for PGP signature.
* debian/watch: Only watch for release versions.
2018-05-04 - Yangfl <mmyangfl@gmail.com>
miniupnpc (2.0.20180410-2) unstable; urgency=medium
* Uploading to unstable.
* Move minissdpd dep level from Recommends to Suggests (Closes: #897064).
2018-04-22 - Thomas Goirand <zigo@debian.org>
miniupnpc (2.0.20180410-1) experimental; urgency=medium
[ Yangfl ]
* New upstream release.
* Bump Standards-Version to 4.1.4.
* Uploading to Experimental.
[ Thomas Goirand ]
* Fix runtime depends of the -dev lib to version 17 of the runtime lib.
2018-03-26 - Thomas Goirand <zigo@debian.org>
miniupnpc (2.0.20180222-1) unstable; urgency=medium
[ Yangfl ]
* New upstream release
- Add pkg-config file (Closes: #664240)
* Mark Breaks miniupnpc (<< 2.0) for libminiupnpc-dev (Closes: #890649)
* Fix FTBFS on non-Linux (Closes: #891696)
* Update VCS fields to point to Salsa
[ Thomas Goirand ]
* Removed man page patch.
2018-02-12 - Thomas Goirand <zigo@debian.org>
miniupnpc (2.0.20171212-3) unstable; urgency=medium
* Uploading to unstable (after ACK from the release team).
2018-01-22 - Thomas Goirand <zigo@debian.org>
miniupnpc (2.0.20171212-2) experimental; urgency=medium
[ Yangfl ]
* New upstream release. (Closes: #804045)
* Include help2man template. (Closes: #776642)
* Bumped Standards-Version.
* Switch to Python 3.
[ Thomas Goirand ]
* Uploading to Experimental.
2017-05-19 - Thomas Goirand <zigo@debian.org>
miniupnpc (1.9.20140610-4) unstable; urgency=high
* Now uses a better patch from upstream for the buffer overflow issue.
2017-05-18 - Thomas Goirand <zigo@debian.org>
miniupnpc (1.9.20140610-3) unstable; urgency=high
* Add More_accurate_checking_while_writing_buffer_in_simpleUPnPcommand2.patch
which fixes a buffer overflow.
* CVE-2017-8798: integer signedness error. Applied upstream patch.
(Closes: #862273).
* Define define _DEFAULT_SOURCE do avoid FTBFS.
2015-10-25 - Salvatore Bonaccorso <carnil@debian.org>
miniupnpc (1.9.20140610-2.1) unstable; urgency=high
* Non-maintainer upload.
* Add CVE-2015-6031.patch patch.
CVE-2015-6031: Buffer overflow vulnerability in XML parser
functionality. (Closes: #802650)

See Also

Package Description
libmiral-dev_2.4.0.1.1.1-0ubuntu3_i386.deb Developer files for the Mir ABI-stable abstraction layer
libmiral3_2.4.0.1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - ABI preserving abstraction layer
libmirclient-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - development headers
libmirclient9_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - client library
libmircommon-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - development headers
libmircommon7_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - shared library
libmircookie-dev_1.1.1-0ubuntu3_i386.deb Produce and verify spoof-resistant timestamps - development headers
libmircookie2_1.1.1-0ubuntu3_i386.deb Produce and verify spoof-resistant timestamps - runtime library
libmircore-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - development headers
libmircore1_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - shared library
libmirplatform-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - development headers
libmirplatform16_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - platform library
libmirprotobuf3_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - RPC definitions
libmirrenderer-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - Renderer development files
libmirserver-dev_1.1.1-0ubuntu3_i386.deb Display server for Ubuntu - development headers
Advertisement
Advertisement