libstring-shellquote-perl_1.04-1_all.deb


Advertisement

Description

libstring-shellquote-perl - module to quote strings for passing through the shell

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Main amd64
Package filename libstring-shellquote-perl_1.04-1_all.deb
Package name libstring-shellquote-perl
Package version 1.04
Package release 1
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/String-ShellQuote
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 11.71 KB
Installed size 32.00 KB
The String::ShellQuote module contains some functions which are useful for
quoting strings which are going to pass through the shell or a shell-like
object, plus a command-line interface to it. It is useful for doing robust
tool programming, particularly when dealing with files whose names contain
white space or shell globbing characters.

Alternatives

Package Version Architecture Repository
libstring-shellquote-perl_1.04-1_all.deb 1.04 all Ubuntu Main
libstring-shellquote-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libstring-shellquote-perl_1.04-1_all.deb
Source Package libstring-shellquote-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libstring-shellquote-perl deb package:
    # sudo apt-get install libstring-shellquote-perl

Files

Path
/usr/bin/shell-quote
/usr/share/doc/libstring-shellquote-perl/changelog.Debian.gz
/usr/share/doc/libstring-shellquote-perl/copyright
/usr/share/man/man1/shell-quote.1p.gz
/usr/share/man/man3/String::ShellQuote.3pm.gz
/usr/share/perl5/String/ShellQuote.pm

Changelog

2017-08-04 - gregor herrmann <gregoa@debian.org>
libstring-shellquote-perl (1.04-1) unstable; urgency=medium
* Take over for the Debian Perl Group; Closes: #862646 -- RFA/ITA
* debian/control: Added: Vcs-Git field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Changed:
Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Roderick Schertler
<roderick@argon.org>).
* Replace (build-)dependency on ancient version of perl with a dependency on
perl without a version (as permitted by Debian Policy 3.8.3).
* debian/watch: use metacpan-based URL.
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 4.0.0.
* Switch to source format "3.0 (quilt)".
* debian/rules: use dh(1). And don't install README anymore.
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Improve short/long description.
* Add /me to Uploaders.
* New upstream release. Closes: #673364, #699518
2016-02-20 - Andy Simpkins <rattusrattus@debian.org>
libstring-shellquote-perl (1.03-1.2) unstable; urgency=medium
* Non-maintainer upload.
* changed from debhelper compatability level 3 to 9:
closes: #800302
- changed (control) Build-Depends: debhelper (>= 9)
- added (control) Depends: ${misc:Depends}
- removed (rules) export DH_COMPAT=3
- added new (compat) file
- replaced (rules) (depricated) dh_clean -k
with dh_prep
* resolved lintian warnings:
- changed (copyright) FSF address
- updated (control) ancient-standards-version 3.6.1 to 3.9.6
2015-08-26 - gregor herrmann <gregoa@debian.org>
libstring-shellquote-perl (1.03-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix "FTBFS with perl 5.22 in experimental (MakeMaker changes)":
use DESTDIR in debian/rules.
(Closes: #795631)
2005-05-03 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.03-1) unstable; urgency=low
* New upstream release (only change is addition of shell-quote script).
2003-04-08 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.02-1) unstable; urgency=low
* New upstream release.
* Change section to "perl".
* Bump Standards-Version to 3.6.1 (no changes).
2001-07-31 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.00-4) unstable; urgency=low
* Don't install extraneous empty directories.
2001-04-09 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.00-3) unstable; urgency=low
* Update to policy 3.5.2 (closes: #91196, #91561).
* Update to latest Perl policy.
1999-07-14 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.00-2) unstable; urgency=low
* Simple updates for 3.0.0 standards.
* Simple updates for new Perl policy.
1998-12-28 - Roderick Schertler <roderick@argon.org>
libstring-shellquote-perl (1.00-1) unstable; urgency=low
* Initial version.

See Also

Package Description
libstrongswan-extra-plugins_5.7.1-1ubuntu2_amd64.deb strongSwan utility and crypto library (extra plugins)
libstrongswan-standard-plugins_5.7.1-1ubuntu2_amd64.deb strongSwan utility and crypto library (standard plugins)
libstrongswan_5.7.1-1ubuntu2_amd64.deb strongSwan utility and crypto library
libstruct-dumb-perl_0.09-1_all.deb module to create simple lightweight record-like structures
libsub-exporter-perl_0.987-1_all.deb sophisticated exporter for custom-built routines
libsub-exporter-progressive-perl_0.001013-1_all.deb module for using Sub::Exporter only if needed
libsub-identify-perl_0.14-1build1_amd64.deb module to retrieve names of code references
libsub-install-perl_0.928-1_all.deb module for installing subroutines into packages easily
libsub-name-perl_0.21-1build2_amd64.deb module for assigning a new name to referenced sub
libsub-quote-perl_2.005001-1_all.deb helper modules for subroutines
libsubunit-dev_1.3.0-1_amd64.deb Unit testing protocol - Development headers and static library for libsubunit
libsubunit0_1.3.0-1_amd64.deb Unit testing protocol - C/C++ shared library
libsuitesparse-dev_5.4.0+dfsg-1_amd64.deb libraries for sparse matrices computations (development files)
libsuitesparse-doc_5.4.0+dfsg-1_all.deb libraries for sparse matrices computations (documentation)
libsuitesparseconfig5_5.4.0+dfsg-1_amd64.deb configuration routines for all SuiteSparse modules
Advertisement
Advertisement