libedit2_3.1-20181209-1_amd64.deb


Advertisement

Description

libedit2 - BSD editline and history libraries

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Main amd64
Package filename libedit2_3.1-20181209-1_amd64.deb
Package name libedit2
Package version 3.1
Package release 20181209-1
Package architecture amd64
Package type deb
Category libs
Homepage https://www.thrysoee.dk/editline/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 83.87 KB
Installed size 246.00 KB
Command line editor library provides generic line editing,
history, and tokenization functions.
It slightly resembles GNU readline.

Alternatives

Package Version Architecture Repository
libedit2_3.1-20181209-1_i386.deb 3.1 i386 Ubuntu Main
libedit2 - - -

Requires

Name Value
libbsd0 >= 0.0
libc6 >= 2.14
libtinfo6 >= 6

Replaces

Name Value
libedit-dev << 3.1-20180525-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libedit2_3.1-20181209-1_amd64.deb
Source Package libedit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libedit2 deb package:
    # sudo apt-get install libedit2

Files

Path
/usr/lib/x86_64-linux-gnu/libedit.so.2
/usr/lib/x86_64-linux-gnu/libedit.so.2.0.59
/usr/share/doc/libedit2/TODO.Debian
/usr/share/doc/libedit2/changelog.Debian.gz
/usr/share/doc/libedit2/copyright
/usr/share/lintian/overrides/libedit2
/usr/share/man/man5/editrc.5edit.gz
/usr/share/man/man7/editline.7edit.gz

Changelog

2018-12-12 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20181209-1) unstable; urgency=medium
[ Guillem Jover ]
* Remove doubled heading spaces from Copyright field in debian/copyright.
* Move examples installation from dh_installdocs override into an .examples
debhelper fragment file, and remove the now unnecessary override.
* Add a comment to debian/rules to remove the dh_compress override on
debhelper compatibility level 12.
[ Sylvestre Ledru ]
* New upstream release
* Two new symbols:
- rl_echo_signal_char
- rl_reset_after_signal
2018-10-27 - Guillem Jover <guillem@debian.org>
libedit (3.1-20180525-2~exp1) experimental; urgency=medium
[ Guillem Jover ]
* Fix libbsd.patch so that the library is detected and used early in
configure before checking for symbols provided by it, to avoid ending
up using the embedded code copies. (Closes: #893934)
* Wrap fields in debian/control.
* Bump debhelper compatibility level to 11.
- Remove old dpkg-dev Build-Depends, satisfied in oldstable, and
superseded by debhelper's dependency.
- Remove autoreconf addon, now enabled by default, and dh-autoreconf
from Build-Depends.
- Remove debian/tmp from libedit-dev.manpages file.
* Switch to an automatic debug symbols package.
* Remove custom compression options from debian/source/options.
* Stop passing unknown --disable-maintainer-mode and obsolete --enable-widec
options to configure.
* Move packages from priority standard to optional.
* Append a -0 to each present symbol in the .symbols file, so that the
versions are properly compared, given that the upstream part contains
a dash, otherwise dpkg-dev tools get confused as they strip the version
revision for the comparison. (Closes: #911341)
* Remove redundant or obsolete information from debian/copyright file.
* Switch debian/copyright to the machine readable format 1.0.
* Set Rules-Requires-Root to no.
* Bump Standards-Version to 4.2.1.
* Bump minimum version in .shlibs file.
* Sort pathnames in debhelper fragment files.
* Add a new patch to use system's wcsdup() function if available.
* Use https for upstream homepage.
* Move Apple time machine file cleanup to the dh_clean override.
* Improve man page handling:
- Move the bulk of the logic to the upstream Makefile.am, and remove it
from the debian/rules.
- Change the sections within the man pages and the references to Xedit.
* Install editrc(5edit) and editline(7edit) man pages in libedit2.
(Closes: #877309)
* Improve termcap usage:
- Switch to (build-)depending on «libncurses-dev | libtinfo-dev» instead
of the deprecated libncurses5-dev.
- Add a patch to prefer linking against libtermcap instead of ncurses.
The code really wants a termcap compatible interface, and not the
main ncurses library.
* Switch to debian/watch format version 4.
2018-05-30 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20180525-1) unstable; urgency=medium
* New upstream release
- New symbols:
append_history
rl_did_startup_hook
rl_resize_terminal
* Standards-Version updated 4.1.3
* Package moved on salsa
* libedit2-dbg moved to extra
* Ship examples/ in libedit-dev
2017-06-20 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20170329-1) unstable; urgency=medium
* New upstream release
* Standards-Version updated 4.0.0
2017-01-18 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20160903-3) unstable; urgency=medium
* Fix the wrong links to the manpage (Closes: #851700)
2016-11-21 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20160903-2) unstable; urgency=medium
* Add libncurses5-dev as a dependency of libedit-dev (Closes: #844573)
Now officially required by upstream
* Fix the vcs fields
2016-11-09 - Sylvestre Ledru <sylvestre@debian.org>
libedit (3.1-20160903-1) unstable; urgency=medium
* Upload to unstable

See Also

Package Description
libefiboot-dev_37-2_amd64.deb Development headers for libefiboot
libefiboot1_37-2_amd64.deb Library to manage UEFI variables
libefivar-dev_37-2_amd64.deb Development headers for libefivar
libefivar1_37-2_amd64.deb Library to manage UEFI variables
libegl-mesa0_19.0.2-1ubuntu1_amd64.deb free implementation of the EGL API -- Mesa vendor library
libegl1-mesa-dev_19.0.2-1ubuntu1_amd64.deb free implementation of the EGL API -- development files
libegl1-mesa_19.0.2-1ubuntu1_amd64.deb transitional dummy package
libegl1_1.1.1-0ubuntu1_amd64.deb Vendor neutral GL dispatch library -- EGL support
libelf-dev_0.176-1_amd64.deb libelf1 development libraries and header files
libelf1_0.176-1_amd64.deb library to read and write ELF files
libemail-date-format-perl_1.005-1_all.deb Module to generate RFC-2822-valid date strings
libemail-valid-perl_1.202-1_all.deb Perl module for checking the validity of Internet email addresses
libenchant-dev_1.6.0-11.1build1_amd64.deb Wrapper library for various spell checker engines (development)
libenchant-voikko_1.6.0-11.1build1_amd64.deb Voikko spell-checker libenchant plugin
libenchant1c2a_1.6.0-11.1build1_amd64.deb Wrapper library for various spell checker engines (runtime libs)
Advertisement
Advertisement