libberkeleydb-perl_0.55-2_amd64.deb


Advertisement

Description

libberkeleydb-perl - use Berkeley DB databases from Perl

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Main amd64
Package filename libberkeleydb-perl_0.55-2_amd64.deb
Package name libberkeleydb-perl
Package version 0.55
Package release 2
Package architecture amd64
Package type deb
Category perl
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 111.50 KB
Installed size 391.00 KB
Provides BerkeleyDB::Hash, BerkeleyDB::Btree etc. classes that allow
access to Berkeley DB databases as if they were normal Perl hash
tables.
Supports all the features of Berkeley DB such as sharing cache and
lock memory between processes, logging and transactions.

Alternatives

Package Version Architecture Repository
libberkeleydb-perl_0.55-2_i386.deb 0.55 i386 Ubuntu Main
libberkeleydb-perl - - -

Requires

Name Value
libc6 >= 2.14
libdb5.3 -
perl >= 5.28.1-4
perlapi-5.28.1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libberkeleydb-perl_0.55-2_amd64.deb
Source Package libberkeleydb-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libberkeleydb-perl deb package:
    # sudo apt-get install libberkeleydb-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.28/BerkeleyDB.pm
/usr/lib/x86_64-linux-gnu/perl5/5.28/BerkeleyDB.pod
/usr/lib/x86_64-linux-gnu/perl5/5.28/BerkeleyDB/Btree.pm
/usr/lib/x86_64-linux-gnu/perl5/5.28/BerkeleyDB/Hash.pm
/usr/lib/x86_64-linux-gnu/perl5/5.28/auto/BerkeleyDB/BerkeleyDB.so
/usr/share/doc/libberkeleydb-perl/changelog.Debian.gz
/usr/share/doc/libberkeleydb-perl/copyright
/usr/share/man/man3/BerkeleyDB.3pm.gz

Changelog

2019-02-10 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.55-2) unstable; urgency=medium
* Set Multi-Arch: same.
2015-03-08 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.55-1) unstable; urgency=medium
* New upstream release.
2014-06-01 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.54-2) unstable; urgency=medium
* Do not hardcode /usr/lib/perl5 in debian/rules.
2013-12-30 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.54-1) unstable; urgency=medium
* New upstream release.
2013-08-25 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.53-1) unstable; urgency=low
* New upstream release.
* Use dh_md5sums. (Closes: #719206)
2012-05-14 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.51-1) unstable; urgency=low
* Support dpkg-buildflags.
* Fix hardened builds. (Closes: #661381)
2011-11-27 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.49-1) unstable; urgency=low
* New upstream release.
* Depend on libdb-dev.
2011-06-26 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.48-1) unstable; urgency=medium
* New upstream release.
2011-02-07 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.43-1) unstable; urgency=low
* New upstream release.
* Switched to libdb 5.1.
2010-04-23 - Marco d'Itri <md@linux.it>
libberkeleydb-perl (0.42-1) unstable; urgency=low
* New upstream release.
* Switched to libdb 5.0.

See Also

Package Description
libbind-dev_9.11.5.P1+dfsg-1ubuntu2_amd64.deb Static Libraries and Headers used by BIND
libbind-export-dev_9.11.5.P1+dfsg-1ubuntu2_amd64.deb Development files for the exported BIND libraries
libbind9-161_9.11.5.P1+dfsg-1ubuntu2_amd64.deb BIND9 Shared Library used by BIND
libbinutils_2.32-7ubuntu4_amd64.deb GNU binary utilities (private shared library)
libbison-dev_3.3.2.dfsg-1_amd64.deb YACC-compatible parser generator - development library
libblas-dev_3.8.0-2_amd64.deb Basic Linear Algebra Subroutines 3, static library
libblas3_3.8.0-2_amd64.deb Basic Linear Algebra Reference implementations, shared library
libblkid-dev_2.33.1-0.1ubuntu2_amd64.deb block device ID library - headers and static libraries
libblkid1_2.33.1-0.1ubuntu2_amd64.deb block device ID library
libblockdev-crypto-dev_2.20-7_amd64.deb Crypto plugin for libblockdev - development
libblockdev-crypto2_2.20-7_amd64.deb Crypto plugin for libblockdev
libblockdev-dev_2.20-7_amd64.deb Library for manipulating block devices - development
libblockdev-dm-dev_2.20-7_amd64.deb Device Mapper plugin for libblockdev - development
libblockdev-dm2_2.20-7_amd64.deb Device Mapper plugin for libblockdev
libblockdev-fs-dev_2.20-7_amd64.deb file system plugin for libblockdev - development
Advertisement
Advertisement