libreoffice_6.1.2-0ubuntu1.1_amd64.deb


Advertisement

Description

libreoffice - office productivity suite (metapackage)

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Updates Universe amd64
Package name libreoffice
Package version 6.1.2
Package release 0ubuntu1.1
Package architecture amd64
Package type deb
Installed size 108 B
Download size 12.02 KB
Official Mirror archive.ubuntu.com
LibreOffice is a full-featured office productivity suite that provides
a near drop-in replacement for Microsoft(R) Office.
This metapackage installs all components of libreoffice:
* libreoffice-writer: Word processor
* libreoffice-calc: Spreadsheet
* libreoffice-impress: Presentation
* libreoffice-draw: Drawing
* libreoffice-base: Database
* libreoffice-math: Equation editor
It also recommends additional packages (e.g. fonts) in order to match an
upstream LibreOffice install as closely as possible.
You can extend the functionality of LibreOffice by installing these
packages:
* hunspell-*/myspell-*: Hunspell/Myspell dictionaries
for use with LibreOffice
* libreoffice-l10n-*: UI interface translation
* libreoffice-help-*: User help
* mythes-*: Thesauri for the use with LibreOffice
* hyphen-*: Hyphenation patterns for LibreOffice
* libreoffice-gtk(2|3): Gtk UI Plugin, GNOME File Picker support
* libreoffice-gnome: GIO backend
* unixodbc: ODBC database support
* cups-bsd: Allows LibreOffice to detect your CUPS printer queues
automatically
* libsane: Use your sane-supported scanner with LibreOffice
* libxrender1: Speed up display by using Xrender library
* libgl1: OpenGL support
* openclipart-libreoffice: Open Clip Art Gallery with LibreOffice index
files
* firefox-esr | thunderbird | firefox:
Mozilla profile with Certificates needed for XML Security...
* openjdk-9-jre | openjdk-8-jre | openjdk-7-jre | java6-runtime:
Java Runtime Environment for use with LibreOffice
* pstoedit / imagemagick / ghostscript: helper tools for EPS
* gstreamer0.10-plugins-*: GStreamer plugins for use with LibreOffices
media backend
* libpaper-utils: papersize detection support via paperconf
* bluez: Bluetooth support for Impress (slideshow remote control)

Alternatives

Package Version Architecture Repository
libreoffice_6.1.3-0ubuntu0.18.10.1_amd64.deb 6.1.3 amd64 Ubuntu Proposed Universe
libreoffice_6.1.3-0ubuntu0.18.10.1_i386.deb 6.1.3 i386 Ubuntu Proposed Universe
libreoffice_6.1.2-0ubuntu1.1_i386.deb 6.1.2 i386 Ubuntu Updates Universe
libreoffice_6.1.2-0ubuntu1_i386.deb 6.1.2 i386 Ubuntu Universe
libreoffice_6.1.2-0ubuntu1_amd64.deb 6.1.2 amd64 Ubuntu Universe
libreoffice - - -

Requires

Name Value
libreoffice impress
libreoffice writer
libreoffice calc
libreoffice base
libreoffice draw
libreoffice math
libreoffice-avmedia-backend gstreamer
libreoffice-core = 1:6.1.2-0ubuntu1.1
libreoffice-report-builder bin
python3-uno >= 4.4.0~beta2

Conflicts

Name Value
libreoffice-dev <= 1:5.0.3~rc1-2
libreoffice-dev-doc <= 1:5.0.3~rc1-2

Download

Type URL
Binary Package libreoffice_6.1.2-0ubuntu1.1_amd64.deb
Source Package libreoffice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libreoffice deb package:
    # sudo apt-get install libreoffice

Changelog

2018-11-03 - Simon Quigley <tsimonq2@ubuntu.com>
libreoffice (1:6.1.2-0ubuntu1.1) cosmic; urgency=medium
* Make LibreOffice under the LXQt desktop environment use the Breeze theme
as the default (LP: #1799001).
* Backport a patch from upstream which fixes testcases with OpenJDK 11
(LP: #1796361).
2018-10-02 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.2-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1795580)
* Drop upstreamed patches:
- debian/patches/apparmor-fixes.diff
- debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff
2018-09-20 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.2-1) unstable; urgency=medium
* New upstream release
2018-09-20 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.1-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1792894)
2018-09-10 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1-1) unstable; urgency=medium
* New upstream release
* debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff: add from
libreoffice-6-1 branch: fixes possible infinite loop in gtk3_kde5
filepicker (closes: #906987)
2018-08-31 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1~rc1-2) unstable; urgency=medium
* debian/patches/apparmor-fixes.diff: add patch from master to
allow printing to file
* debian/patches/do-not-reset-permissions-on-save.diff: as name says,
from libreoffice-6-1 branch (closes: #907476)
* debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
(closes: #907397)
* debian/control.in:
- add Replaces: for above
- bump ure Dependency in -core to (>= 6.1.1~) (closes: #907650)
2018-08-24 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1~rc1-1) unstable; urgency=medium
* New upstream release candidate
* debian/patches/apparmor-kde.diff: backport AppArmor KDE fixes from
master
* debian/control.in:
- *really* recommend apparmor (>= 2.13)
2018-08-31 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.0-0ubuntu2) cosmic; urgency=medium
[ Olivier Tilloy ]
* debian/tests/control: do not depend on libreoffice-sdbc-firebird on s390x
(LP: #1790165)
[ Rene Engelhard ]
* debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
(closes: #907397) (LP: #1789202)
* debian/control.in: add Replaces: for above
2018-08-28 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.0-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1786207, LP: #1789240)
* debian/patches/apparmor-fixes.diff: remove patch as this requires apparmor
2.13, which is not in ubuntu cosmic
* debian/control.in: relax apparmor recommend
2018-08-12 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.0-1) unstable; urgency=medium
* Libreoffice 6.1.0 final (identical to rc3)
* debian/patches/apparmor-fixes.diff: add patch from libreoffice-6-1
branch to fix saving of documents in apparmor enforce mode
(closes: #905442)
* debian/patches/apparmor-cleanups.diff: use dri-enumerate abstraction of
apparmor; add from https://gerrit.libreoffice.org/#/c/58589
* debian/control.in:
- recommend apparmor (>= 2.13) for above
- make -common also depend on -style-colibre, since it apparently also
is needed to have LO draw iit's check/radiobuttons correctly
(closes: #904598, #905408, #905819)

See Also

Package Description
libsfasan3-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb AddressSanitizer -- a fast memory error detector (soft float ABI)
libsfasan3-dbg-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb AddressSanitizer -- a fast memory error detector (soft float ABI debug symbols)
libsfgcc-6-dev-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb GCC support library (soft float ABI development files)
libsfgfortran-6-dev-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Runtime library for GNU Fortran applications (soft float ABI development files)
libsfgfortran3-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Runtime library for GNU Fortran applications (soft float ABI)
libsfgfortran3-dbg-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Runtime library for GNU Fortran applications (hard float ABI debug symbols)
libsfgphobos-6-dev-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Phobos D standard library (soft float ABI development files)
libsfgphobos68-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Phobos D standard library (runtime library)
libsfgphobos68-dbg-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Phobos D standard library (debug symbols)
libsfobjc-6-dev-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb Runtime library for GNU Objective-C applications (soft float development files)
libsfstdc++-6-dev-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb GNU Standard C++ Library v3 (development files) (armhf)
libsfstdc++6-6-dbg-armhf-cross_6.5.0-2ubuntu1~18.10cross1_all.deb GNU Standard C++ Library v3 (debugging files)
libsnmp-perl_5.7.3+dfsg-1.8ubuntu3.18.10.1_amd64.deb SNMP (Simple Network Management Protocol) Perl5 support
libstd-rust-1.30_1.30.0+dfsg1+llvm-2ubuntu1~18.10.1_amd64.deb Rust standard libraries
libstd-rust-dev_1.30.0+dfsg1+llvm-2ubuntu1~18.10.1_amd64.deb Rust standard libraries - development files
Advertisement
Advertisement