python3-all-dev_3.6.7-1~18.10_i386.deb


Advertisement

Description

python3-all-dev - package depending on all supported Python 3 development packages

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Updates Main i386
Package name python3-all-dev
Package version 3.6.7
Package release 1~18.10
Package architecture i386
Package type deb
Installed size 6 B
Download size 1.10 KB
Official Mirror archive.ubuntu.com
The package currently depends on python3.6-dev and python3.7-dev, in the
future, dependencies on jython (Python for a JVM) and ironpython (Python
for Mono) may be added.
This package is a dependency package used as a build dependency for other
packages to avoid hardcoded dependencies on specific Python 3 development
packages.

Alternatives

Package Version Architecture Repository
python3-all-dev_3.6.7-1~18.10_amd64.deb 3.6.7 amd64 Ubuntu Updates Main
python3-all-dev_3.6.6-1_i386.deb 3.6.6 i386 Ubuntu Main
python3-all-dev_3.6.6-1_amd64.deb 3.6.6 amd64 Ubuntu Main
python3-all-dev - - -

Requires

Name Value
libpython3-all-dev = 3.6.7-1~18.10
python3 = 3.6.7-1~18.10
python3-all = 3.6.7-1~18.10
python3-dev = 3.6.7-1~18.10
python3.6-dev -
python3.7-dev -

Download

Type URL
Binary Package python3-all-dev_3.6.7-1~18.10_i386.deb
Source Package python3-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-all-dev deb package:
    # sudo apt-get install python3-all-dev

Changelog

2018-10-25 - Matthias Klose <doko@ubuntu.com>
python3-defaults (3.6.7-1~18.10) cosmic-proposed; urgency=medium
* SRU: LP: #1799206.
2018-10-21 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.7-1) unstable; urgency=high
* Really ship the policy in the python3 package, and update from the last
version found in the python package. Closes: #910113.
* Bump version to 3.6.7.
2018-06-27 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.6-1) unstable; urgency=medium
[ Matthias Klose ]
* Fix the idle desktop file. Closes: #901096.
* Install the policy files in the python3 package. Closes: #901486.
* python3-minimal: Pre-Depend on python3.6-minimal. Closes: #901001.
* Bump version to 3.6.6.
[ Scott Kitterman ]
* Remove myself from uploaders
2018-06-07 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-5) experimental; urgency=medium
* Fix typo in the defaults file. Closes: #900937, #900949.
2018-06-06 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-4) experimental; urgency=medium
* Update Vcs attributes.
* Add Python 3.7 to the list of supported Python3 versions.
2018-04-10 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-3) unstable; urgency=medium
* Update valgrind support file. LP: #1513364.
* debian/control.in (Michael Vogt):
- add Cnf-Visible-Pkgname hint to ensure command-not-found recommends
installing "python3" instead of "python3-minimal" when it is missing.
2018-04-02 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-2) unstable; urgency=medium
* Distinguish between python3.6 and python3-stdlib-extensions versions.
Closes: #894168.
* python3-venv: Depend on python3-distutils.
2018-03-31 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-1) unstable; urgency=medium
[ Matthias Klose ]
* Bump version to 3.6.5.
[ Michael Vogt ]
* debian/control.in: LP: #1752415
- add "XB-Cnf-Extra-Commands: python" to ensure command-not-found
outputs the python3 package when searching for "python"
- add XB-Cnf-Priority-Bonus to ensure python3 is listed on the
top when typing "python"
2018-03-25 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5~rc1-1) unstable; urgency=medium
* Bump version to 3.6.5~rc1.
* Remove dh-python dependency from python3.
* Add dh-python and python3-distutils dependencies to python3-all and
python3-dev.
2017-12-29 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.4-1) unstable; urgency=medium
* Bump version to 3.6.4.
* 2to3: Depend on python3-lib2to3 and provide the 2to3 launcher.

See Also

Package Description
python3-all_3.6.7-1~18.10_i386.deb package depending on all supported Python 3 runtime versions
python3-apport_2.20.10-0ubuntu13.1_all.deb Python 3 library for Apport crash report handling
python3-commandnotfound_18.10.0~pre2_all.deb Python 3 bindings for command-not-found
python3-dev_3.6.7-1~18.10_i386.deb header files and a static library for Python (default)
python3-distupgrade_18.10.11.2_all.deb manage release upgrades
python3-distutils_3.6.7-1~18.10_all.deb distutils package for Python 3.x
python3-doc_3.6.7-1~18.10_all.deb documentation for the high-level object-oriented language Python 3
python3-examples_3.6.7-1~18.10_all.deb examples for the Python language (default version)
python3-gdbm_3.6.7-1~18.10_i386.deb GNU dbm database support for Python 3.x
python3-lib2to3_3.6.7-1~18.10_all.deb Interactive high-level object-oriented language (2to3, version 3.6)
python3-minimal_3.6.7-1~18.10_i386.deb minimal subset of the Python language (default python3 version)
python3-novaagent_2.1.18-0ubuntu1~18.10.0_all.deb Python 3 module for Rackspace Public Cloud Guest Agent
python3-paramiko_2.4.1-0ubuntu3.2_all.deb Make ssh v2 connections (Python 3)
python3-problem-report_2.20.10-0ubuntu13.1_all.deb Python 3 library to handle problem reports
python3-requests_2.18.4-2ubuntu0.18.10.1_all.deb elegant and simple HTTP library for Python3, built for human beings
Advertisement
Advertisement