libsynctex2_2018.20180824.48463-1ubuntu0.1_i386.deb


Advertisement

Description

libsynctex2 - TeX Live: SyncTeX parser library

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Updates Main i386
Package name libsynctex2
Package version 2018.20180824.48463
Package release 1ubuntu0.1
Package architecture i386
Package type deb
Installed size 191 B
Download size 56.20 KB
Official Mirror archive.ubuntu.com
Library for SyncTeX parsing support.

Alternatives

Package Version Architecture Repository
libsynctex2_2018.20180824.48463-1ubuntu0.1_amd64.deb 2018.20180824.48463 amd64 Ubuntu Updates Main
libsynctex2_2018.20180824.48463-1_i386.deb 2018.20180824.48463 i386 Ubuntu Main
libsynctex2_2018.20180824.48463-1_amd64.deb 2018.20180824.48463 amd64 Ubuntu Main
libsynctex2 - - -

Requires

Name Value
libc6 >= 2.4
zlib1g >= 1:1.2.3.4

Download

Type URL
Binary Package libsynctex2_2018.20180824.48463-1ubuntu0.1_i386.deb
Source Package texlive-bin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsynctex2 deb package:
    # sudo apt-get install libsynctex2

Files

Path
/usr/lib/i386-linux-gnu/libsynctex.so.2
/usr/lib/i386-linux-gnu/libsynctex.so.2.0.0
/usr/share/doc/libsynctex2/README.txt.gz
/usr/share/doc/libsynctex2/changelog.Debian.gz
/usr/share/doc/libsynctex2/copyright
/usr/share/doc/libsynctex2/synctex_parser_readme.txt.gz

Changelog

2018-10-22 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
texlive-bin (2018.20180824.48463-1ubuntu0.1) cosmic-security; urgency=medium
* SECURITY UPDATE: Arbitrary code execution
- debian/patches/CVE-2018-17407.patch: fix in
texk/dvipsk/writet1.c, texk/web2c/luatexdir/font/writet1.w,
texk/web2c/pdftexdir/writet1.c.
- CVE-2018-17407
2018-08-24 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180824.48463-1) unstable; urgency=medium
* New upstream version 2018.20180824.48463
* remove upstream included patches
2018-07-10 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180710.48169-1) unstable; urgency=medium
* New upstream checkout 2018.20180710.48169
* update patches, remove upstream ones
2018-06-25 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180416.47457-5) unstable; urgency=medium
* Fix t4ht being completely broken due to %%~ expansion to 
SELFAUTOPARENT (Closes: #902334)
2018-05-29 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180416.47457-4) unstable; urgency=medium
[ Norbert Preining ]
* cherry-picking fixed from upstream svn
- upstream-svn47712-dvidvi-error-reporting
- upstream-svn47723-dvidvi-cmd-line-error-reporting
better error reporting for dvidvi as well as gcc warning fixes
- upstream-svn47721-mendex30
- upstream-svn47722-mendex-rename-readme
mendex update to 3.0, switch default encoding to utf8
-	introduce the \expanded primitive:
upstream-svn47741-expanded-primitive-pdftex
upstream-svn47742-pdftex-expanded-test-fixes
upstream-svn47745-eptex-expanded
- upstream-svn47776-ptexenc-doc-fixes
fix links to upstream projects
- upstream-svn47799-dvipdfmx-try-suffix
let xdvipdfmx check .dvi and .xdv extensions like other progs
[ Hilmar Preusse ]
* Minor fixes for disdvi.1 (Closes: #899341), dt2dv.1 (Closes: #900043)
and gftodvi.1 (Closes: #900245)
Thanks to Bjarni Ingi Gislason.
2018-05-07 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180416.47457-3) unstable; urgency=medium
* cherry-picking fixes from upstream svn:
- upstream-svn47469-dvipdfm-x-Fix-a-bug-which-causes-a-segfault-with-1-2
xetex segfaults with uncommon png formats 
https://sourceforge.net/p/xetex/bugs/151/
- upstream-svn47476-m-tx-0.63a
update m-tx to 0.63a which fixes FTBFS on hurd (Closes: #896518)
- upstream-svn47477-ptexdir-fix-a-regression-for-discontinuous-kinsoku-t
ptex regression fix
- upstream-svn47506-typo
typo in the changelog name
-	upstream-svn47625-recover-to-give-tounicode-entries-for-ligatures
search didn't work for ligatures
https://tex.stackexchange.com/questions/430054/failing-search-for-words-with-ligatures-after-update
- upstream-svn47626-ptexdir-More-strict-check-kanji-token
inconsisten behavior of p-engines
* add information about SDE in tex.man and etex.man (Closes: #897627)
* use pkg-config as fallback for freetype configuration (Closes: #892446)
2018-04-21 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180416.47457-2) unstable; urgency=medium
* synctex fixes
- install synctex_version.h
* include upstream bug fix for m-tx (Closes: #896077)
* bump libsynctex soname to 2 (Closes: #895980)
- follow upstream in using synctex_parser_api_level
2018-04-16 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180416.47457-1) unstable; urgency=medium
* New upstream version: Sources of TeX Live 2018: 2018.20180416.47457
* Upload to unstable
2018-04-04 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180404.47274-1) experimental; urgency=medium
* New upstream version 2018.20180404.47274
2018-03-13 - Norbert Preining <preining@debian.org>
texlive-bin (2018.20180313.46939-1) experimental; urgency=medium
* New upstream version 2018.20180313.46939
* update patches

See Also

Package Description
libsystemd-dev_239-7ubuntu10.4_i386.deb systemd utility library - development files
libsystemd0_239-7ubuntu10.4_i386.deb systemd utility library
libtexlua52-dev_2018.20180824.48463-1ubuntu0.1_i386.deb Tex Live: Lua 5.2, modified for use with LuaTeX (development part)
libtexlua52_2018.20180824.48463-1ubuntu0.1_i386.deb TeX Live: Lua 5.2, modified for use with LuaTeX
libtexlua53-dev_2018.20180824.48463-1ubuntu0.1_i386.deb Tex Live: Lua 5.3, modified for use with LuaTeX (development part)
libtexlua53_2018.20180824.48463-1ubuntu0.1_i386.deb TeX Live: Lua 5.3, modified for use with LuaTeX
libtexluajit-dev_2018.20180824.48463-1ubuntu0.1_i386.deb Tex Live: LuaJIT, modified for use with LuaJITTeX (development part)
libtexluajit2_2018.20180824.48463-1ubuntu0.1_i386.deb TeX Live: LuaJIT, modified for use with LuaJITTeX
libtotem-dev_3.26.2-1ubuntu2_i386.deb Main library for the Totem media player - development files
libtotem0_3.26.2-1ubuntu2_i386.deb Main library for the Totem media player
libudev-dev_239-7ubuntu10.4_i386.deb libudev development files
libudev1_239-7ubuntu10.4_i386.deb libudev shared library
libupower-glib-dev_0.99.8-2ubuntu0.1_i386.deb abstraction for power management - development files
libupower-glib3_0.99.8-2ubuntu0.1_i386.deb abstraction for power management - shared library
libuwac0-0_2.0.0~git20180411.1.7a7b1802+dfsg1-2ubuntu0.1_i386.deb Using wayland as a client library
Advertisement
Advertisement