gir1.2-lokdocview-0.1_6.1.2-0ubuntu1.1_i386.deb


Advertisement

Description

gir1.2-lokdocview-0.1 - GTK3 widget wrapping LibreOffice functionality - introspection

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Updates Main i386
Package name gir1.2-lokdocview-0.1
Package version 6.1.2
Package release 0ubuntu1.1
Package architecture i386
Package type deb
Installed size 21 B
Download size 4.53 KB
Official Mirror archive.ubuntu.com
LOKDocView is the GTK3 widget that wraps the libreoffice functionality and
exposes a simple API for applications to use this widget.
This package contains the Introspection data.

Alternatives

Package Version Architecture Repository
gir1.2-lokdocview-0.1_6.1.2-0ubuntu1.1_amd64.deb 6.1.2 amd64 Ubuntu Updates Main
gir1.2-lokdocview-0.1_6.1.2-0ubuntu1_i386.deb 6.1.2 i386 Ubuntu Main
gir1.2-lokdocview-0.1_6.1.2-0ubuntu1_amd64.deb 6.1.2 amd64 Ubuntu Main
gir1.2-lokdocview-0.1 - - -

Requires

Name Value
gir1.2-gdkpixbuf-2.0 -
gir1.2-glib-2.0 >= 1.32
gir1.2-gtk-3.0 >= 3.18.0
liblibreofficekitgtk = 1:6.1.2-0ubuntu1.1
libreoffice-core = 1:6.1.2-0ubuntu1.1

Download

Type URL
Binary Package gir1.2-lokdocview-0.1_6.1.2-0ubuntu1.1_i386.deb
Source Package libreoffice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-lokdocview-0.1 deb package:
    # sudo apt-get install gir1.2-lokdocview-0.1

Changelog

2018-11-03 - Simon Quigley <tsimonq2@ubuntu.com>
libreoffice (1:6.1.2-0ubuntu1.1) cosmic; urgency=medium
* Make LibreOffice under the LXQt desktop environment use the Breeze theme
as the default (LP: #1799001).
* Backport a patch from upstream which fixes testcases with OpenJDK 11
(LP: #1796361).
2018-10-02 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.2-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1795580)
* Drop upstreamed patches:
- debian/patches/apparmor-fixes.diff
- debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff
2018-09-20 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.2-1) unstable; urgency=medium
* New upstream release
2018-09-20 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.1-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1792894)
2018-09-10 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1-1) unstable; urgency=medium
* New upstream release
* debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff: add from
libreoffice-6-1 branch: fixes possible infinite loop in gtk3_kde5
filepicker (closes: #906987)
2018-08-31 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1~rc1-2) unstable; urgency=medium
* debian/patches/apparmor-fixes.diff: add patch from master to
allow printing to file
* debian/patches/do-not-reset-permissions-on-save.diff: as name says,
from libreoffice-6-1 branch (closes: #907476)
* debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
(closes: #907397)
* debian/control.in:
- add Replaces: for above
- bump ure Dependency in -core to (>= 6.1.1~) (closes: #907650)
2018-08-24 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.1~rc1-1) unstable; urgency=medium
* New upstream release candidate
* debian/patches/apparmor-kde.diff: backport AppArmor KDE fixes from
master
* debian/control.in:
- *really* recommend apparmor (>= 2.13)
2018-08-31 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.0-0ubuntu2) cosmic; urgency=medium
[ Olivier Tilloy ]
* debian/tests/control: do not depend on libreoffice-sdbc-firebird on s390x
(LP: #1790165)
[ Rene Engelhard ]
* debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
(closes: #907397) (LP: #1789202)
* debian/control.in: add Replaces: for above
2018-08-28 - Olivier Tilloy <olivier.tilloy@canonical.com>
libreoffice (1:6.1.0-0ubuntu1) cosmic; urgency=medium
* New upstream release (LP: #1786207, LP: #1789240)
* debian/patches/apparmor-fixes.diff: remove patch as this requires apparmor
2.13, which is not in ubuntu cosmic
* debian/control.in: relax apparmor recommend
2018-08-12 - Rene Engelhard <rene@debian.org>
libreoffice (1:6.1.0-1) unstable; urgency=medium
* Libreoffice 6.1.0 final (identical to rc3)
* debian/patches/apparmor-fixes.diff: add patch from libreoffice-6-1
branch to fix saving of documents in apparmor enforce mode
(closes: #905442)
* debian/patches/apparmor-cleanups.diff: use dri-enumerate abstraction of
apparmor; add from https://gerrit.libreoffice.org/#/c/58589
* debian/control.in:
- recommend apparmor (>= 2.13) for above
- make -common also depend on -style-colibre, since it apparently also
is needed to have LO draw iit's check/radiobuttons correctly
(closes: #904598, #905408, #905819)

See Also

Package Description
gir1.2-mutter-3_3.30.2-1~ubuntu18.10.1_i386.deb GObject introspection data for Mutter
gir1.2-nm-1.0_1.12.4-1ubuntu1.1_i386.deb GObject introspection data for the libnm library
gir1.2-poppler-0.18_0.68.0-0ubuntu1.2_i386.deb GObject introspection data for poppler-glib
gir1.2-totem-1.0_3.26.2-1ubuntu2_i386.deb GObject introspection data for Totem media player
gir1.2-upowerglib-1.0_0.99.8-2ubuntu0.1_i386.deb GObject introspection data for upower
gir1.2-webkit2-4.0_2.22.4-0ubuntu0.18.10.1_i386.deb Web content engine library for GTK+ - GObject introspection data
git-doc_2.19.1-1ubuntu1.1_all.deb fast, scalable, distributed revision control system (documentation)
git-man_2.19.1-1ubuntu1.1_all.deb fast, scalable, distributed revision control system (manual pages)
git_2.19.1-1ubuntu1.1_i386.deb fast, scalable, distributed revision control system
gkbd-capplet_3.26.0-3ubuntu0.18.10.1_i386.deb GNOME control center tools for libgnomekbd
glance-api_17.0.0-0ubuntu4.1_all.deb OpenStack Image Registry and Delivery Service - API
glance-common_17.0.0-0ubuntu4.1_all.deb OpenStack Image Registry and Delivery Service - Common
glance-registry_17.0.0-0ubuntu4.1_all.deb OpenStack Image Registry and Delivery Service - Registry
glance_17.0.0-0ubuntu4.1_all.deb OpenStack Image Registry and Delivery Service - Daemons
gnome-control-center-data_3.30.2-1ubuntu0.18.10.1_all.deb configuration applets for GNOME - data files
Advertisement
Advertisement