barbican-doc_7.0.0-0ubuntu3_all.deb


Advertisement

Description

barbican-doc - OpenStack Key Management Service - doc

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Updates Main i386
Package name barbican-doc
Package version 7.0.0
Package release 0ubuntu3
Package architecture all
Package type deb
Installed size 4.23 KB
Download size 1.07 MB
Official Mirror archive.ubuntu.com
The Barbican project provides services for secure storage, provisioning and
management of sensitive client secret information such as encryption keys. It
is aims at being useful for all environments, including large ephemeral
Clouds.
This package contains the documentation.

Alternatives

Package Version Architecture Repository
barbican-doc_7.0.0-0ubuntu3_all.deb 7.0.0 all Ubuntu Updates Main
barbican-doc_7.0.0-0ubuntu2_all.deb 7.0.0 all Ubuntu Main
barbican-doc_7.0.0-0ubuntu2_all.deb 7.0.0 all Ubuntu Main
barbican-doc - - -

Requires

Name Value
libjs-sphinxdoc >= 1.0

Download

Type URL
Binary Package barbican-doc_7.0.0-0ubuntu3_all.deb
Source Package barbican

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install barbican-doc deb package:
    # sudo apt-get install barbican-doc

Changelog

2018-10-25 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0-0ubuntu3) cosmic; urgency=medium
* d/p/encode-b64payload.patch: Cherry-pick from upstream review
(https://review.openstack.org/#/c/613324/) to ensure base64
payloads are correctly encoded in Python 3 (LP: #1799746).
2018-10-11 - James Page <james.page@ubuntu.com>
barbican (1:7.0.0-0ubuntu2) cosmic; urgency=medium
* d/p/0001-Enable-AppRole-authentication-support-for-Vault.patch:
Add support for Vault AppRole authentication (LP: #1796851).
* d/p/0002-Enable-KV-mountpoint-configuration-for-Vault.patch:
Add support for configuration of the KV mountpoint to use in Vault
(LP: #1797148).
* d/control: Bump minimum python{3}-castellan version to 0.19.0-0ubuntu2~
to pickup associated Vault fixes in lower layers.
2018-08-30 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0-0ubuntu1) cosmic; urgency=medium
* New upstream release for OpenStack Rocky.
2018-08-30 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0~rc1-0ubuntu3) cosmic; urgency=medium
* d/barbican-api.apache2, d/barbican-common.apache2: Move back to barbican-api
package where apache2 dependencies are installed.
2018-08-27 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0~rc1-0ubuntu2) cosmic; urgency=medium
* Additional support for Python 3:
- d/control, d/barbican-*: Move common files to barbican-common. Only have
python(3)-barbican depend on barbican-common. Other packages that used to
depend on barbican-common now depend on python-barbican | python3-barbican.
- d/control: Drop python(3)-barbican conflicts on each other.
- d/python(3)-barbican.postinst: Ensure alternatives priority is 300
for Py2 and 200 for Py3.
- d/tests/control: Run Py3 tests first due to alternatives priority.
2018-08-14 - James Page <james.page@ubuntu.com>
barbican (1:7.0.0~rc1-0ubuntu1) cosmic; urgency=medium
* New upstream release candidate for OpenStack Rocky.
* d/rules: Drop usr/etc from python{3}-barbican packages.
2018-08-07 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0~b3-0ubuntu1) cosmic; urgency=medium
* New upstream milestone for OpenStack Rocky.
* d/control: Align (Build-)Depends with upstream.
2018-07-06 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0~b2-0ubuntu2) cosmic; urgency=medium
* Add support for Python 3:
- d/control: Add Py3 BDs and python3-barbican package.
- d/control: Support Py2 first and Py3 as alternative.
- d/control: Move all python deps to python(3)-barbican Depends.
- d/control: Make python(3)-barbican conflict against each other.
- d/rules: Add Py3 support.
- d/rules: Use pkgos-dh_auto_install as this helps name binaries for
update-alternatives.
- d/rules: Run tests with pkgos-dh_auto_test.
- d/python-barbican.install: Drop, not needed.
- d/barbican-common.install: Drop usr/bin/* as pkgos-dh_auto_install handles
install of those files.
- d/python(3)-barbican.post*, d/python(3)-barbican.prerm: Add update-alternatives
to enable correct shebangs for Python binaries.
- d/tests/*: Enable Py3 tests for barbican daemons and add shebang tests.
- d/tests/barbican-daemons: Use curl to test API.
2018-06-13 - Corey Bryant <corey.bryant@canonical.com>
barbican (1:7.0.0~b2-0ubuntu1) cosmic; urgency=medium
* New upstream milestone for OpenStack Rocky.
* d/control: Align (Build-)Depends with upstream.
* d/p/ldap3-to-ldap.patch: Rebased.
* d/rules: Run tests with stestr.
* d/control: Set min BD version for python-pykmip dep to 0.8.0
(https://storyboard.openstack.org/#!/story/2002559).

See Also

Package Description
barbican-keystone-listener_7.0.0-0ubuntu3_all.deb OpenStack Key Management Service - Keystone Listener
barbican-worker_7.0.0-0ubuntu3_all.deb OpenStack Key Management Service - Worker Node
ca-certificates_20180409_all.deb Common CA certificates
cinder-api_13.0.0-0ubuntu4_all.deb Cinder storage service - API server
cinder-backup_13.0.0-0ubuntu4_all.deb Cinder storage service - Scheduler server
cinder-common_13.0.0-0ubuntu4_all.deb Cinder storage service - common files
cinder-scheduler_13.0.0-0ubuntu4_all.deb Cinder storage service - Scheduler server
cinder-volume_13.0.0-0ubuntu4_all.deb Cinder storage service - Volume server
command-not-found-data_18.10.0~pre2_i386.deb Set of data files for command-not-found
command-not-found_18.10.0~pre2_all.deb Suggest installation of packages in interactive bash sessions
cups-bsd_2.2.8-5ubuntu1.1_i386.deb Common UNIX Printing System(tm) - BSD commands
cups-client_2.2.8-5ubuntu1.1_i386.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_2.2.8-5ubuntu1.1_all.deb Common UNIX Printing System(tm) - common files
cups-core-drivers_2.2.8-5ubuntu1.1_i386.deb Common UNIX Printing System(tm) - driverless printing
cups-daemon_2.2.8-5ubuntu1.1_i386.deb Common UNIX Printing System(tm) - daemon
Advertisement
Advertisement