fish_2.7.1-3build1_amd64.deb


Advertisement

Description

fish - friendly interactive shell

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Universe amd64
Package filename fish_2.7.1-3build1_amd64.deb
Package name fish
Package version 2.7.1
Package release 3build1
Package architecture amd64
Package type deb
Category universe/shells
Homepage http://fishshell.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 577.64 KB
Installed size 3.65 MB
Fish is a shell geared towards interactive use.  Its features are focused on
user friendliness and discoverability.  The language syntax is simple but
incompatible with other shell languages.

Alternatives

Package Version Architecture Repository
fish_2.7.1-3build1_i386.deb 2.7.1 i386 Ubuntu Universe
fish - - -

Requires

Name Value
bc -
dpkg >= 1.17.14
fish-common = 2.7.1-3build1
libc6 >= 2.15
libpcre2-32-0 >= 10.31
libstdc++6 >= 5.2
libtinfo6 >= 6
lynx -
man-db -
python3 -
www-browser -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package fish_2.7.1-3build1_amd64.deb
Source Package fish

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fish deb package:
    # sudo apt-get install fish

Files

Path
/usr/bin/fish
/usr/bin/fish_indent
/usr/bin/fish_key_reader
/usr/share/doc/fish/NEWS.Debian.gz
/usr/share/doc/fish/changelog.Debian.gz
/usr/share/doc/fish/copyright
/usr/share/lintian/overrides/fish
/usr/share/menu/fish

Changelog

2018-05-03 - Matthias Klose <doko@ubuntu.com>
fish (2.7.1-3build1) cosmic; urgency=medium
* No-change rebuild for ncurses soname changes.
2018-02-17 - Tristan Seligmann <mithrandi@debian.org>
fish (2.7.1-3) unstable; urgency=medium
* Disable the test suite again until the failures are resolved.
2018-01-17 - Tristan Seligmann <mithrandi@debian.org>
fish (2.7.1-2) unstable; urgency=medium
* Replace $(PWD) with $(CURDIR) in Makefile.am (closes: #887524)
(hopefully!)
2018-01-11 - Tristan Seligmann <mithrandi@debian.org>
fish (2.7.1-1) unstable; urgency=medium
* Move to salsa.debian.org.
* New upstream release.
* Bump Standards-Version to 4.1.3 (no changes).
* Update to dh compat 11.
* Fix maintscript syntax.
* Run test suite.
* Add autopkgtests.
* Drop pointless Recommends: python in fish-common.
2017-12-17 - Tristan Seligmann <mithrandi@debian.org>
fish (2.7.0-1) unstable; urgency=medium
* New upstream release.
* Drop debian/patches/reproducible-doc-toc (equivalent changes included
upstream).
* Depend on python3 for completions support (closes: #882996).
2017-11-13 - Tristan Seligmann <mithrandi@debian.org>
fish (2.6.0-2) unstable; urgency=medium
* Drop patches/reproducible-doxyfile as this is no longer needed (and
also wrong, as it was was refreshed incorrectly at some point).
* Show commands run during the build (closes: #881251); thanks to Sven
Joachim for the patch.
2017-07-14 - Tristan Seligmann <mithrandi@debian.org>
fish (2.6.0-1) unstable; urgency=medium
* New upstream release.
- ifconfig completion no longer changes cwd (closes: #859314).
- Refresh quilt patches.
* Depend on man-db as the completion system uses apropos
(closes: #857630).
* Drop fish-dbg and migrate to automatic -dbgsym packages.
* Bump Standards-Version to 4.0.0 (no changes).
2016-12-11 - Tristan Seligmann <mithrandi@debian.org>
fish (2.4.0-1) unstable; urgency=medium
* New upstream release.
2016-07-07 - Tristan Seligmann <mithrandi@debian.org>
fish (2.3.1-1) unstable; urgency=medium
* New upstream release.
* Switch debian/watch over to GitHub and check PGP signature
(closes: #829760).
2016-05-22 - Tristan Seligmann <mithrandi@debian.org>
fish (2.3.0-1) unstable; urgency=medium
* New upstream release.
- Refresh patches.
- Drop history-permissions-871a208.patch (was taken from upstream).
* Bump Standards-Version to 3.9.8 (no changes).
* Update Vcs-* to use https.

See Also

Package Description
fishpoke_0.1.7-1_all.deb client for the Fishpoll server
fishpolld_0.1.7-1_all.deb daemon that allows remote script's execution when triggered from the network
fitgcp_0.0.20150429-2_amd64.deb fitting genome coverage distributions with mixture models
fitscut_1.4.4-4build4_amd64.deb Extract cutouts from FITS image format files
fitsh_0.9.2-1_amd64.deb Software package for astronomical image processing
fitspng_1.3-2_amd64.deb FITS to PNG converter
fitsverify_4.18-2_amd64.deb FITS File Format-Verification Tool
fityk_1.3.1-3_amd64.deb general-purpose nonlinear curve fitting and data analysis
fiu-utils_0.96-4_amd64.deb userspace fault injection framework (utilities)
five-or-more_3.30.0-1_amd64.deb make color lines of five or more length
fixincludes_8.2.0-7ubuntu1_amd64.deb Fix non-ANSI header files
fizmo-common_0.7.10-2_all.deb Provides localization data from all default fizmo-related
fizmo-console_0.7.13-2_amd64.deb Console-based Z-machine interpreter for Infocom/Inform games
fizmo-ncursesw_0.7.14-2_amd64.deb Ncurses-based Z-machine interpreter for Infocom/Inform games
fizmo-sdl2_0.8.5-2_amd64.deb SDL2-based Z-machine interpreter for Infocom/Inform games
Advertisement
Advertisement