liblockfile1_1.14-1.1_i386.deb


Advertisement

Description

liblockfile1 - NFS-safe locking library

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Main i386
Package name liblockfile1
Package version 1.14
Package release 1.1
Package architecture i386
Package type deb
Installed size 33 B
Download size 6.98 KB
Official Mirror archive.ubuntu.com
Liblockfile is a shared library with NFS-safe locking functions.

Alternatives

Package Version Architecture Repository
liblockfile1_1.14-1.1_amd64.deb 1.14 amd64 Ubuntu Main
liblockfile1 - - -

Requires

Name Value
libc6 >= 2.4
liblockfile-bin >= 1.14-1.1

Download

Type URL
Binary Package liblockfile1_1.14-1.1_i386.deb
Source Package liblockfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblockfile1 deb package:
    # sudo apt-get install liblockfile1

Files

Path
/usr/lib/i386-linux-gnu/liblockfile.so.1
/usr/lib/i386-linux-gnu/liblockfile.so.1.0
/usr/share/doc/liblockfile1/changelog.Debian.gz
/usr/share/doc/liblockfile1/copyright

Changelog

2017-12-03 - Mattia Rizzolo <mattia@debian.org>
liblockfile (1.14-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control:
+ Drop obsolete Pre-Depends on multiarch-support.  (Closes: #867224)
+ Drop duplicate Priority definitions.
+ Mark liblockfile-dev as Multi-Arch:same.
+ Add dependency on ${misc:Depends} to liblockfile-dev.
+ Add Homepage field.
+ Fix Vcs-* fields to point to the packaging repository.  (Closes: #867225)
* debian/copyright: fix copyright-format 1.0 syntax by adding missing
Copyright fields and appropriate stand-alone License paragraphs.
* dotlockfile.1: Fix groff syntax.
* Remove maintainer scripts calling ldconfig, debhelper does that
automatically through dpkg triggers nowadays.
2017-01-17 - Miquel van Smoorenburg <miquels@debian.org>
liblockfile (1.14-1) unstable; urgency=high
* new upstream version
2017-01-05 - Miquel van Smoorenburg <miquels@cistron.nl>
liblockfile (1.13-1) unstable; urgency=low
* new upstream version
2017-01-05 - Miquel van Smoorenburg <miquels@cistron.nl>
liblockfile (1.12-1) unstable; urgency=low
* new upstream version (closes: #638800)
* update upstream url in debian/control
2017-01-03 - Miquel van Smoorenburg <miquels@debian.org>
liblockfile (1.11-1) unstable; urgency=low
* new upstream version
* use geteuid() instead of getuid() to find out mailboxname
(closes: #736666)
* add dotlockfile <lockfile> cmd args... functionality
(closes: #41791)
2016-11-18 - Miquel van Smoorenburg <miquels@debian.org>
liblockfile (1.10-1) unstable; urgency=low
* new upstream version
* rewrite debian/rules to use debhelper
* update debian/copyright file (closes: #748387)
2013-06-02 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-6) unstable; urgency=low
* Merge 1.09-5ubuntu1
fix-buffer-overflows.patch: Fix buffer overflows when building strings
- Protect against overflows caused by long hostnames (LP: #941968)
- Protect against overflows caused by large PID numbers (LP: #1011477)
Closes: #677225
* In Makefile.in it compiles nfslock.so.$(NVER) but installs nfslock.so.$(VER)
Add 688074-Makefile.in-NVER.patch
Patch by Yao Zhao
Closes: #688074
* Standards Version is 3.9.4
2013-01-09 - Tyler Hicks <tyhicks@canonical.com>
liblockfile (1.09-5ubuntu1) raring; urgency=low
* debian/patches/fix-buffer-overflows.patch: Fix buffer overflows when
building strings
- Protect against overflows caused by long hostnames (LP: #941968)
- Protect against overflows caused by large PID numbers (LP: #1011477)
2012-12-11 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-5) unstable; urgency=low
[ Rob Browning ]
* Don't remove /usr/share/doc/liblockfile1 from the postrm anymore.
Doing so breaks multarch, and it appears that the code was originally
inserted to fix an upgrade problem (#339498) from 2005.
(closes: #695268)
2012-06-13 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-4) unstable; urgency=low
* Multiarch issues
- Move liblockfile.a to /usr/lib/$(DEB_HOST_MULTIARCH)
- Compress files with "gzip -n"
Patch by Sven Joachim
Closes: #637569
* Enable hardened build flags
Add Makefile.in.patch
* Standards version is 3.9.3

See Also

Package Description
liblouis-data_3.6.0-3ubuntu1_all.deb Braille translation library - data
liblouis-dev_3.6.0-3ubuntu1_i386.deb Braille translation library - static libs and headers
liblouis16_3.6.0-3ubuntu1_i386.deb Braille translation library - shared libs
liblouisutdml-bin_2.7.0-2build1_i386.deb Braille UTDML translation utilities
liblouisutdml-data_2.7.0-2build1_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.7.0-2build1_i386.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.7.0-2build1_all.deb Braille UTDML translation library - java bindings documentation
liblouisutdml8_2.7.0-2build1_i386.deb Braille UTDML translation library - shared libs
liblpsolve55-dev_5.5.0.15-4build1_i386.deb Solve (mixed integer) linear programming problems - library
liblqr-1-0-dev_0.4.2-2.1_i386.deb converts plain array images into multi-size representation (developments files)
liblqr-1-0_0.4.2-2.1_i386.deb converts plain array images into multi-size representation
liblrm2-dev_1.0.12-10_i386.deb Reusable cluster development files -- liblrm
liblrm2_1.0.12-10_i386.deb Reusable cluster libraries -- liblrm2
liblrmd-dev_1.1.18-2ubuntu1_i386.deb cluster resource manager LRMD library development
liblrmd1_1.1.18-2ubuntu1_i386.deb cluster resource manager LRMD library
Advertisement
Advertisement