emacs_25.2+1-11_all.deb


Advertisement

Description

emacs - GNU Emacs editor (metapackage)

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Main i386
Package filename emacs_25.2+1-11_all.deb
Package name emacs
Package version 25.2+1
Package release 11
Package architecture all
Package type deb
Category editors
Homepage http://www.gnu.org/software/emacs/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 11.79 KB
Installed size 66.00 KB
GNU Emacs is the extensible self-documenting text editor.
This is a metapackage that will always depend on the latest
recommended Emacs variant (currently emacs-gtk).

Alternatives

Package Version Architecture Repository
emacs_25.2+1-11_all.deb 25.2+1 all Ubuntu Main
emacs - - -

Requires

Name Value
emacs-gtk >= 1:25
emacs-lucid >= 1:25
emacs-nox >= 1:25

Download

Type URL
Mirror archive.ubuntu.com
Binary Package emacs_25.2+1-11_all.deb
Source Package emacs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emacs deb package:
    # sudo apt-get install emacs

Files

Path
/usr/share/doc/emacs/changelog.Debian.gz
/usr/share/doc/emacs/copyright

Changelog

2018-08-26 - Rob Browning <rlb@defaultvalue.org>
emacs (1:25.2+1-11) unstable; urgency=medium
* Add (>= 1:25) restriction to emacs metapackage dependencies.
Without this it was possible to end up with two empty metapackages
installed instead of the expected metapackage and actual package.
Thanks to Shin Yoshida for reporting the problem and Sven Joachim
for noting the solution. (Closes: 906534)
* Don't unexpectedly modify the byte order mark.  Add
0014-Emacs-should-no-longer-unexpectedly-alter-the-byte-o.patch to
fix the problem.  Thanks to Vincent Lefevre for reporting the
problem and Eli Zaretskii for the patch. (Closes: 883434)
2018-08-12 - Rob Browning <rlb@defaultvalue.org>
emacs (1:25.2+1-10) unstable; urgency=medium
* Handle the emacs-{gtk,lucid,nox} doc dir transition manually.
Before the unversioning, these packages were in a different source
package (emacs-defaults) and were arch all.  Since
dpkg-mainscript-helper can't hande "all to any" transitions
(https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813455), clean
up manually in the preinsts.  Thanks to Sven Joachim for reporting
the problem and indentifying the underlying cause.
(Closes: 905555)
2018-08-04 - Rob Browning <rlb@defaultvalue.org>
emacs (1:25.2+1-9) unstable; urgency=medium
* Disable the eieio-test-37-obsolete-name-in-constructor test.  Its
behavior is unpredictable, and it was causing some buildd builds
to fail (cf. https://debbugs.gnu.org/24503).  Add
0013-Disable-eieio-test-37-obsolete-name-in-constructor.patch to
fix the problem, and thanks to Aaron M. Ucko for reporting it, and
J. Smith for tracking down the upstream issue. (Closes: 879020)
* Ensure /usr/share/doc/emacs-{gtk,lucid,nox} symlink is
established.  Use dir_to_symlink to make sure the new symlink to
emacs-common is correctly established if we're upgrading from the
emacs-defaults packages that had a real directory.  Thanks to
Andreas Beckmann for reporting the problem. (Closes: 903779)
* Have emacs-{gtk,lucid,nox} replace all the related emacs25
packages.  Add "emacs-gtk (<< 1:25), emacs-lucid (<< 1:25),
emacs-nox (<< 1:25)" to the "Replaces:" for emacs-gtk,
emacs-lucid, and emacs-nox to avoid conflicts over
/usr/share/emacs/25.2/etc/DOC while unpacking.  Thanks to Axel
Beckert for reporting the problem and Adrian Bunk and Sven Joachim
for help with the solution. (Closes: 904957)
2018-07-29 - Rob Browning <rlb@defaultvalue.org>
emacs (1:25.2+1-8) unstable; urgency=medium
* Move unversioned emacs packages from experimental to unstable.
2018-05-27 - Rob Browning <rlb@defaultvalue.org>
emacs (1:25.2+1-7) experimental; urgency=medium
* Unversion the emacs packages.  Remove the major version from all
of the packages.  The flexibility provided no longer appears worth
the complexity given the more frequent upstream releases, and
backward-compatability across them.
* Update debian/patches for emacs25 to emacs migration.
* Rename emacsXY to emacsXY-gtk.
* Fix dbg package self-dependencies.
* Stop versioning packages; change emacs25 to emacs.
* Move mail-host-address and gnus-nntpserver-file to new
00debian.el.
* Move emacs binary metapackage to this package.  Add epoch so that
new versions of the metapackage will be higher than the last
standalone version (47.0).
* Handle local emacs/site-lisp here instead of in emacsen-common.
* Depend on emacsen-common (>= 3.0.0) This will complete the
transfer of the emacs metapackage namespace to the emacs source
package as a new concrete emacs flavor.
* Add emacs23, emacs24, and emacs25 transitional packages.
* debian/control: change priority extra to optional as per policy.
* Have binary flavor packages depend on emacs-common for doc
symlink.

See Also

Package Description
emacsen-common_3.0.4_all.deb Common facilities for all emacsen
enchant_1.6.0-11.1_i386.deb Wrapper for various spell checker engines (binary programs)
eog-dev_3.28.4-1_i386.deb Development files for the Eye of GNOME
eog_3.28.4-1_i386.deb Eye of GNOME graphics viewer program
erlang-asn1_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP modules for ASN.1 support
erlang-base_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP virtual machine and base applications
erlang-corba_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP applications for CORBA support
erlang-crypto_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP cryptographic modules
erlang-dev_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP development libraries and headers
erlang-diameter_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP implementation of RFC 6733 protocol
erlang-doc_20.3.8.5+dfsg-1build1_all.deb Erlang/OTP HTML/PDF documentation
erlang-edoc_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP module for generating documentation
erlang-eldap_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP LDAP library
erlang-erl-docgen_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP documentation stylesheets
erlang-eunit_20.3.8.5+dfsg-1build1_i386.deb Erlang/OTP module for unit testing
Advertisement
Advertisement