python3-louis_3.6.0-3ubuntu1_all.deb


Advertisement

Description

python3-louis - Python bindings for liblouis

Property Value
Distribution Ubuntu 18.10 (Cosmic Cuttlefish)
Repository Ubuntu Main amd64
Package filename python3-louis_3.6.0-3ubuntu1_all.deb
Package name python3-louis
Package version 3.6.0
Package release 3ubuntu1
Package architecture all
Package type deb
Category python
Homepage http://liblouis.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.34 KB
Installed size 37.00 KB
Liblouis is a braille translator and back-translator.  It features support for
computer and literary braille, supports contracted and uncontracted translation
for many languages and has support for hyphenation.  Liblouis also supports
math braille (Nemeth and Marburg).
This package contains Python bindings.

Alternatives

Package Version Architecture Repository
python3-louis_3.6.0-3ubuntu1_all.deb 3.6.0 all Ubuntu Main
python3-louis - - -

Requires

Name Value
liblouis16 >= 3.6.0-3ubuntu1
python3:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-louis_3.6.0-3ubuntu1_all.deb
Source Package liblouis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-louis deb package:
    # sudo apt-get install python3-louis

Files

Path
/usr/lib/python3/dist-packages/louis-3.6.0.egg-info
/usr/lib/python3/dist-packages/louis/__init__.py
/usr/share/doc/python3-louis/changelog.Debian.gz
/usr/share/doc/python3-louis/copyright

Changelog

2018-10-02 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
liblouis (3.6.0-3ubuntu1) cosmic; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-17294.patch: fix in
liblouis/lou_translateString.c
- CVE-2018-17294
2018-08-17 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-3) unstable; urgency=medium
* control: Bump Standards-Version to 4.2.0 (no changes).
* debian/tests/control: Add autopkgtest.
* patches/automake-1.16: Fix build against automake 1.16 (Closes: #906376).
2018-07-07 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-2) unstable; urgency=medium
* Upload to unstable.
2018-06-30 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-1) experimental; urgency=medium
* New upstream release.
- Rename liblibouis14 to liblouis16 according to soname bump.
- cve-2018-11410, cve-2018-11440, cve-2018-11577, 32bit-crash.diff,
cve-2018-11683, cve-2018-11684, cve-2018-11685: Remove patches merged
upstream.
- patches/da-dk: Fix testsuite failure.
* control: Drop ancien python version requirement.
2018-06-12 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-4) unstable; urgency=high
* patches/cve-2018-12085: Fix another buffer overflow for CVE 2018-12085
(Closes: Bug#901202).
2018-06-04 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-3) unstable; urgency=medium
* patches/32bit-crash.diff: Fix crash on 32bit execution.
* patches/cve-2018-11440: Fix another buffer overflow for CVE 2018-11440
(Closes: #900085).
* patches/cve-2018-11577: Fix another segfault for CVE 2018-11577
(Closes: #900607).
* patches/cve-2018-11683: Fix a buffer overflow for CVE 2018-11683.
* patches/cve-2018-11684: Fix a buffer overflow for CVE 2018-11684.
* patches/cve-2018-11685: Fix a buffer overflow for CVE 2018-11685.
2018-05-25 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-2) unstable; urgency=high
* Bump Standards-Version to 4.1.4 (no changes).
* patches/cve-2018-11410: Buffer overflow fix for CVE 2018-11410
(Closes: #899999).
2018-03-11 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-1) unstable; urgency=medium
* New upstream release.
2017-09-29 - Samuel Thibault <sthibault@debian.org>
liblouis (3.4.1-1) unstable; urgency=medium
* New upstream release.
* control: Bump Standards-Version to 4.1.1 (no changes).
2017-09-08 - Samuel Thibault <sthibault@debian.org>
liblouis (3.3.0-1) unstable; urgency=medium
* New upstream release (Closes: Bug#874302).
- rename liblouis12 to liblouis14 according to soname bump.
* Use canonical anonscm vcs URL.
* control: Update maintainer mailing list.
* control: Migrate priority to optional.
* control: Bump Standards-Version to 4.1.0.

See Also

Package Description
python3-lxml_4.2.5-1_amd64.deb pythonic binding for the libxml2 and libxslt libraries
python3-maas-client_2.5.0~beta2-7291-gd0345ced5-0ubuntu1_all.deb MAAS python API client (Python 3)
python3-maas-provisioningserver_2.5.0~beta2-7291-gd0345ced5-0ubuntu1_all.deb MAAS server provisioning libraries (Python 3)
python3-macaroonbakery_1.1.4-1_all.deb Higher-level macaroon operations for Python 3
python3-magic_0.4.15-2_all.deb python3 interface to the libmagic file type identification library
python3-mako_1.0.7+ds1-1_all.deb fast and lightweight templating for the Python 3 platform
python3-markdown_2.6.9-1_all.deb text-to-HTML conversion library/tool (Python 3 version)
python3-markupsafe_1.0-1build2_amd64.deb HTML/XHTML/XML string library for Python 3
python3-mimeparse_0.1.4-3.1_all.deb Parse mime-types and quality parameters - python 3.x
python3-minimal_3.6.6-1_amd64.deb minimal subset of the Python language (default python3 version)
python3-monotonic_1.1-2_all.deb implementation of time.monotonic() - Python 3.x
python3-msgpack_0.5.6-1build1_amd64.deb Python 3 implementation of MessagePack format
python3-munch_2.2.0-2_all.deb dot-accessible dictionary similar to JavaScript objects - Python 3.x
python3-mysqldb_1.3.10-1build2_amd64.deb Python interface to MySQL
python3-nacl_1.2.1-3build1_amd64.deb Python bindings to libsodium (Python 3)
Advertisement
Advertisement