ruby-rack-protection_1.5.3-2+deb9u1build0.18.04.1_all.deb


Advertisement

Description

ruby-rack-protection - Protects against typical web attacks for Rack apps

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe i386
Package name ruby-rack-protection
Package version 1.5.3
Package release 2+deb9u1build0.18.04.1
Package architecture all
Package type deb
Installed size 52 B
Download size 10.14 KB
Official Mirror archive.ubuntu.com
This library protects against typical web attacks. Should work for all
Rack apps, including Rails.

Alternatives

Package Version Architecture Repository
ruby-rack-protection_1.5.3-2+deb9u1build0.18.04.1_all.deb 1.5.3 all Ubuntu Updates Universe
ruby-rack-protection_1.5.3-2_all.deb 1.5.3 all Ubuntu Universe
ruby-rack-protection_1.5.3-2_all.deb 1.5.3 all Ubuntu Universe
ruby-rack-protection - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-rack -

Download

Type URL
Binary Package ruby-rack-protection_1.5.3-2+deb9u1build0.18.04.1_all.deb
Source Package ruby-rack-protection

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-rack-protection deb package:
    # sudo apt-get install ruby-rack-protection

Files

Path
/usr/lib/ruby/vendor_ruby/rack-protection.rb
/usr/lib/ruby/vendor_ruby/rack/protection.rb
/usr/lib/ruby/vendor_ruby/rack/protection/authenticity_token.rb
/usr/lib/ruby/vendor_ruby/rack/protection/base.rb
/usr/lib/ruby/vendor_ruby/rack/protection/escaped_params.rb
/usr/lib/ruby/vendor_ruby/rack/protection/form_token.rb
/usr/lib/ruby/vendor_ruby/rack/protection/frame_options.rb
/usr/lib/ruby/vendor_ruby/rack/protection/http_origin.rb
/usr/lib/ruby/vendor_ruby/rack/protection/ip_spoofing.rb
/usr/lib/ruby/vendor_ruby/rack/protection/json_csrf.rb
/usr/lib/ruby/vendor_ruby/rack/protection/path_traversal.rb
/usr/lib/ruby/vendor_ruby/rack/protection/remote_referrer.rb
/usr/lib/ruby/vendor_ruby/rack/protection/remote_token.rb
/usr/lib/ruby/vendor_ruby/rack/protection/session_hijacking.rb
/usr/lib/ruby/vendor_ruby/rack/protection/version.rb
/usr/lib/ruby/vendor_ruby/rack/protection/xss_header.rb
/usr/share/doc/ruby-rack-protection/README.md
/usr/share/doc/ruby-rack-protection/changelog.Debian.gz
/usr/share/doc/ruby-rack-protection/copyright
/usr/share/rubygems-integration/all/specifications/rack-protection-1.5.3.gemspec

Changelog

2018-11-09 - Mike Salvatore <mike.salvatore@canonical.com>
ruby-rack-protection (1.5.3-2+deb9u1build0.18.04.1) bionic-security; urgency=medium
* fake sync from Debian
2018-07-15 - Moritz Muehlenhoff <jmm@debian.org>
ruby-rack-protection (1.5.3-2+deb9u1) stretch-security; urgency=medium
* CVE-2018-1000119 (Closes: #892250)
2015-09-02 - Balasankar C <balasankarc@autistici.org>
ruby-rack-protection (1.5.3-2) unstable; urgency=medium
* Team upload.
* Port tests partially to RSpec3 and make them run (Closes: #797257)
2015-08-29 - Pirate Praveen <praveen@debian.org>
ruby-rack-protection (1.5.3-1) unstable; urgency=medium
* Team upload
* New upstream release
* Disable tests (needs rspec 2)
2014-03-23 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-rack-protection (1.5.2-1) unstable; urgency=medium
* Imported Upstream version 1.5.2
* Bump Standard Version: 3.9.5, Compat: 9
2013-10-31 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-rack-protection (1.5.1-1) unstable; urgency=low
* Imported Upstream version 1.5.1
2013-06-23 - Jérémy Bobbio <lunar@debian.org>
ruby-rack-protection (1.5.0-2) unstable; urgency=low
[ Jérémy Bobbio ]
* Team upload.
* Upload to unstable.
* Add git-buildpackage configuration.
* Bump gem2deb version in Build-Depends.
* Bump Standards-Version to 3.9.4, no changes required.
[ Cédric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag.
* Use canonical URI in Vcs-* fields.
* debian/copyright: use DEP5 copyright-format/1.0 official URL for Format
field.
2013-04-01 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-rack-protection (1.5.0-1) experimental; urgency=low
* Imported Upstream version 1.5.0
2013-01-07 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-rack-protection (1.3.2-1) experimental; urgency=low
* Imported Upstream version 1.3.2
2012-03-22 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-rack-protection (1.2.0-1) unstable; urgency=low
* Initial release (Closes: #665085)

See Also

Package Description
ruby-sprockets_3.7.0-1+deb9u1build0.18.04.1_all.deb Rack-based asset packaging system
rust-doc_1.25.0+dfsg1+llvm-0ubuntu1_all.deb Rust systems programming language - Documentation
rust-doc_1.28.0+dfsg1+llvm-0ubuntu1~18.04.1_all.deb Rust systems programming language - Documentation
rust-doc_1.30.0+dfsg1+llvm-2ubuntu1~18.04.1_all.deb Rust systems programming language - Documentation
rust-gdb_1.25.0+dfsg1+llvm-0ubuntu1_all.deb Rust debugger (gdb)
rust-gdb_1.28.0+dfsg1+llvm-0ubuntu1~18.04.1_all.deb Rust debugger (gdb)
rust-gdb_1.30.0+dfsg1+llvm-2ubuntu1~18.04.1_all.deb Rust debugger (gdb)
rust-lldb_1.25.0+dfsg1+llvm-0ubuntu1_all.deb Rust debugger (lldb)
rust-lldb_1.28.0+dfsg1+llvm-0ubuntu1~18.04.1_all.deb Rust debugger (lldb)
rust-lldb_1.30.0+dfsg1+llvm-2ubuntu1~18.04.1_all.deb Rust debugger (lldb)
rust-src_1.25.0+dfsg1+llvm-0ubuntu1_all.deb Rust systems programming language - source code
rust-src_1.28.0+dfsg1+llvm-0ubuntu1~18.04.1_all.deb Rust systems programming language - source code
rust-src_1.30.0+dfsg1+llvm-2ubuntu1~18.04.1_all.deb Rust systems programming language - source code
rustc_1.30.0+dfsg1+llvm-2ubuntu1~18.04.1_i386.deb Rust systems programming language
samba-testsuite_4.7.6+dfsg~ubuntu-0ubuntu2.5_i386.deb test suite from Samba
Advertisement
Advertisement