python3.7_3.7.1-1~18.04_i386.deb


Advertisement

Description

python3.7 - Interactive high-level object-oriented language (version 3.7)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe i386
Package name python3.7
Package version 3.7.1
Package release 1~18.04
Package architecture i386
Package type deb
Installed size 395 B
Download size 265.70 KB
Official Mirror archive.ubuntu.com
Python is a high-level, interactive, object-oriented language. Its 3.7 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.

Alternatives

Package Version Architecture Repository
python3.7_3.7.1-1~18.04_amd64.deb 3.7.1 amd64 Ubuntu Updates Universe
python3.7_3.7.0~b3-1_amd64.deb 3.7.0~b3 amd64 Ubuntu Universe
python3.7_3.7.0~b3-1_i386.deb 3.7.0~b3 i386 Ubuntu Universe
python3.7 - - -

Requires

Name Value
libpython3.7-stdlib = 3.7.1-1~18.04
mime support
python3.7-minimal = 3.7.1-1~18.04

Download

Type URL
Binary Package python3.7_3.7.1-1~18.04_i386.deb
Source Package python3.7

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3.7 deb package:
    # sudo apt-get install python3.7

Files

Path
/usr/bin/pdb3.7
/usr/bin/pydoc3.7
/usr/bin/pygettext3.7
/usr/share/applications/python3.7.desktop
/usr/share/doc/python3.7/ACKS.gz
/usr/share/doc/python3.7/NEWS.gz
/usr/share/doc/python3.7/README.Debian
/usr/share/doc/python3.7/README.rst.gz
/usr/share/doc/python3.7/changelog.Debian.gz
/usr/share/doc/python3.7/changelog.gz
/usr/share/doc/python3.7/copyright
/usr/share/lintian/overrides/python3.7
/usr/share/man/man1/pdb3.7.1.gz
/usr/share/man/man1/pydoc3.7.1.gz
/usr/share/man/man1/pygettext3.7.1.gz
/usr/share/man/man1/pysetup3.7.1.gz
/usr/share/pixmaps/python3.7.xpm

Changelog

2018-10-22 - Matthias Klose <doko@ubuntu.com>
python3.7 (3.7.1-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1799202.
2018-10-21 - Matthias Klose <doko@debian.org>
python3.7 (3.7.1-1) unstable; urgency=medium
* Python 3.7.1 release.
2018-10-15 - Matthias Klose <doko@debian.org>
python3.7 (3.7.1~rc2-1) unstable; urgency=medium
* Python 3.7.1 release candidate 2.
2018-09-27 - Matthias Klose <doko@debian.org>
python3.7 (3.7.1~rc1-1) unstable; urgency=medium
* Python 3.7.1 release candidate 1.
2018-09-25 - Matthias Klose <doko@debian.org>
python3.7 (3.7.0-7) unstable; urgency=medium
* Update to 20180925 from the 3.7 branch.
* Don't run OpenSSL related tests during the build. Hanging on
some buildds.
2018-09-01 - Matthias Klose <doko@debian.org>
python3.7 (3.7.0-6) unstable; urgency=medium
* Update to 20180901 from the 3.7 branch.
- Fixes the build with OpenSSL 1.1.1. Closes: #907031.
* Don't run the test_ftplib and test_ssl autopkg tests, not yet ready
for OpenSSL 1.1.1.
2018-08-20 - Matthias Klose <doko@debian.org>
python3.7 (3.7.0-5) unstable; urgency=medium
* Update to 20180820 from the 3.7 branch.
* Avoid usage of distutils in the platform module. See issue #26544.
* Fix some issues on architectures from the computer museum (Jason Duerstock).
Closes: #905536.
- Disable -O3 on ia64 (see PR rtl-optimization/85412).
- Remove the -O2 override on m68k (see Debian #326903).
- Remove the -mieee and -O2 overrides for DEC Alpha (see Debian #212912).
* Add more breaks for packages not compatible with Python 3.7:
- python3-aiomeasures. See #906159.
- python3-motor (updated). See #903527.
* Again close the RC issue about the syntax errors triggered by Python 3.7.
Closes: #902788.
* Update symbols files.
2018-08-02 - Matthias Klose <doko@debian.org>
python3.7 (3.7.0-4) unstable; urgency=medium
* Update to 20180802 from the 3.7 branch.
* Add more breaks for packages not compatible with Python 3.7:
- python3-pyatspi. See #902989.
* Move test/__main__.py into libpython3.7-stdlib.

See Also

Package Description
qemu-guest-agent_2.11+dfsg-1ubuntu7.9_i386.deb Guest-side qemu-system agent
qemu-system-mips_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (mips)
qemu-system-misc_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (miscellaneous)
qemu-system-sparc_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (sparc)
qemu-system_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries
qemu-user-binfmt_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode binfmt registration for qemu-user
qemu-user-static_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode emulation binaries (static version)
qemu-user_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode emulation binaries
qemu_2.11+dfsg-1ubuntu7.9_i386.deb fast processor emulator
qml-module-qt-labs-folderlistmodel_5.9.5-0ubuntu1.1_i386.deb Qt 5 folderlistmodel QML module
qml-module-qt-labs-settings_5.9.5-0ubuntu1.1_i386.deb Qt 5 settings QML module
qml-module-qt-labs-sharedimage_5.9.5-0ubuntu1.1_i386.deb Qt 5 SharedImage QML module
qml-module-qtqml-models2_5.9.5-0ubuntu1.1_i386.deb Qt 5 Models2 QML module
qml-module-qtqml-statemachine_5.9.5-0ubuntu1.1_i386.deb Qt 5 State Machine QML module
qml-module-qtquick-controls-styles-breeze_5.12.6-0ubuntu0.1_i386.deb QtQuick style for Qt and KDE Software
Advertisement
Advertisement