python3.6-venv_3.6.7-1~18.04_i386.deb


Advertisement

Description

python3.6-venv - Interactive high-level object-oriented language (pyvenv binary, version 3.6)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe i386
Package name python3.6-venv
Package version 3.6.7
Package release 1~18.04
Package architecture i386
Package type deb
Installed size 32 B
Download size 6.04 KB
Official Mirror archive.ubuntu.com
Python is a high-level, interactive, object-oriented language. Its 3.6 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
This package contains the pyvenv-3.6 binary.

Alternatives

Package Version Architecture Repository
python3.6-venv_3.6.7-1~18.04_amd64.deb 3.6.7 amd64 Ubuntu Updates Universe
python3.6-venv_3.6.5-3_amd64.deb 3.6.5 amd64 Ubuntu Universe
python3.6-venv_3.6.5-3_i386.deb 3.6.5 i386 Ubuntu Universe
python3.6-venv - - -

Requires

Name Value
python-pip-whl >= 8.1.0-2
python3.6 = 3.6.7-1~18.04

Download

Type URL
Binary Package python3.6-venv_3.6.7-1~18.04_i386.deb
Source Package python3.6

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3.6-venv deb package:
    # sudo apt-get install python3.6-venv

Files

Path
/usr/bin/pyvenv-3.6
/usr/lib/python3.6/ensurepip/__init__.py
/usr/lib/python3.6/ensurepip/__main__.py
/usr/lib/python3.6/ensurepip/_uninstall.py
/usr/share/doc/python3.6-venv
/usr/share/lintian/overrides/python3.6-venv
/usr/share/man/man1/pyvenv-3.6.1.gz

Changelog

2018-10-22 - Matthias Klose <doko@ubuntu.com>
python3.6 (3.6.7-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1799206.
2018-10-21 - Matthias Klose <doko@debian.org>
python3.6 (3.6.7-1) unstable; urgency=medium
* Python 3.6.7 release.
2018-10-15 - Matthias Klose <doko@debian.org>
python3.6 (3.6.7~rc2-1) unstable; urgency=medium
* Python 3.6.7 release candidate 2.
2018-09-27 - Matthias Klose <doko@debian.org>
python3.6 (3.6.7~rc1-1) unstable; urgency=medium
* Python 3.6.7 release candidate 1.
2018-09-01 - Matthias Klose <doko@debian.org>
python3.6 (3.6.6-4) unstable; urgency=medium
* Update to 20180901 from the 3.6 branch.
* Add idle-python3.6 to the autopkg test depends.
2018-08-28 - Matthias Klose <doko@debian.org>
python3.6 (3.6.6-3) unstable; urgency=medium
* Update to 20180828 from the 3.6 branch.
* Disable running some tests which are not ready for Debian's OpenSSL
defaults (test_{asyncio,ftplib,httplib,imaplib,nntplib,poplib,ssl}).
Closes: #907215.
2018-08-20 - Matthias Klose <doko@debian.org>
python3.6 (3.6.6-2) unstable; urgency=medium
* Update to 20180820 from the 3.6 branch.
* Avoid usage of distutils in the platform module. See issue #26544.
* Move test/__main__.py into libpython3.6-stdlib.
* Pass the list of the pyFPE breaks as a parameter into dpkg-gencontrol
instead of hard-coding them in the control file.
2018-09-12 - Matthias Klose <doko@ubuntu.com>
python3.6 (3.6.6-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1792143. Update Python 3.6 to the recent subminor release.
2018-06-27 - Matthias Klose <doko@debian.org>
python3.6 (3.6.6-1) unstable; urgency=medium
* Python 3.6.6 release.
2018-06-22 - Matthias Klose <doko@debian.org>
python3.6 (3.6.6~rc1-4) unstable; urgency=medium
* Update to 20180622 from the 3.6 branch.
- Fix installation of idlelib testsuite.

See Also

Package Description
python3.7-dev_3.7.1-1~18.04_i386.deb Header files and a static library for Python (v3.7)
python3.7-doc_3.7.1-1~18.04_all.deb Documentation for the high-level object-oriented language Python (v3.7)
python3.7-examples_3.7.1-1~18.04_all.deb Examples for the Python language (v3.7)
python3.7-minimal_3.7.1-1~18.04_i386.deb Minimal subset of the Python language (version 3.7)
python3.7-venv_3.7.1-1~18.04_i386.deb Interactive high-level object-oriented language (pyvenv binary, version 3.7)
python3.7_3.7.1-1~18.04_i386.deb Interactive high-level object-oriented language (version 3.7)
qemu-guest-agent_2.11+dfsg-1ubuntu7.9_i386.deb Guest-side qemu-system agent
qemu-system-mips_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (mips)
qemu-system-misc_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (miscellaneous)
qemu-system-sparc_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries (sparc)
qemu-system_2.11+dfsg-1ubuntu7.9_i386.deb QEMU full system emulation binaries
qemu-user-binfmt_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode binfmt registration for qemu-user
qemu-user-static_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode emulation binaries (static version)
qemu-user_2.11+dfsg-1ubuntu7.9_i386.deb QEMU user mode emulation binaries
qemu_2.11+dfsg-1ubuntu7.9_i386.deb fast processor emulator
Advertisement
Advertisement