vim-syntax-docker_18.09.7-0ubuntu1~18.04.4_all.deb


Advertisement

Description

vim-syntax-docker - Docker container engine - Vim highlighting syntax files

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename vim-syntax-docker_18.09.7-0ubuntu1~18.04.4_all.deb
Package name vim-syntax-docker
Package version 18.09.7
Package release 0ubuntu1~18.04.4
Package architecture all
Package type deb
Category universe/admin
Homepage https://www.docker.com/community-edition
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.75 KB
Installed size 72.00 KB
This package provides syntax files for the Vim editor for editing Dockerfiles
from the Docker container engine.

Alternatives

Package Version Architecture Repository
vim-syntax-docker_18.09.7-0ubuntu1~18.04.4_all.deb 18.09.7 all Ubuntu Updates Universe
vim-syntax-docker_17.12.1-0ubuntu1_all.deb 17.12.1 all Ubuntu Universe
vim-syntax-docker_17.12.1-0ubuntu1_all.deb 17.12.1 all Ubuntu Universe
vim-syntax-docker - - -

Requires

Name Value
vim -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package vim-syntax-docker_18.09.7-0ubuntu1~18.04.4_all.deb
Source Package docker.io

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install vim-syntax-docker deb package:
    # sudo apt-get install vim-syntax-docker

Files

Path
/usr/share/doc/vim-syntax-docker/changelog.Debian.gz
/usr/share/doc/vim-syntax-docker/copyright
/usr/share/vim/addons/doc/dockerfile.txt
/usr/share/vim/addons/ftdetect/dockerfile.vim
/usr/share/vim/addons/syntax/dockerfile.vim
/usr/share/vim/registry/vim-syntax-docker.yaml

Changelog

2019-08-14 - Mike Salvatore <mike.salvatore@canonical.com>
docker.io (18.09.7-0ubuntu1~18.04.4) bionic-security; urgency=medium
* SECURITY UPDATE: Double free in docker-credential-helpers library
- debian/patches/CVE-2019-1020014.patch: Fix a double free in the List
functions
- CVE-2019-1020014
2019-07-01 - Mike Salvatore <mike.salvatore@canonical.com>
docker.io (18.09.7-0ubuntu1~18.04.3) bionic-security; urgency=medium
* No change rebuild for the -security pocket
2019-06-28 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
docker.io (18.09.7-0ubuntu1~18.04.1) bionic; urgency=medium
* Backport to 18.04. (LP: #1834690)
* Version depedency on containerd.
2019-06-28 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
docker.io (18.09.7-0ubuntu1) eoan; urgency=medium
* Update to 18.09.7. (LP: #1834690)
- Includes fix for CVE-2018-15664.
2019-04-12 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
docker.io (18.09.5-0ubuntu1) disco; urgency=medium
* Update to 18.09.5.
2019-03-14 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
docker.io (18.09.3-0ubuntu1) disco; urgency=medium
* Update to 18.09.3.
- update d/upstream-version-commits
- refresh d/patches/docker-prefix.patch to maintain dependence on
docker-specific containerd daemon.
- remove d/patches/0001-nsenter-clone-proc-self-exe-to-avoid-exposing-host-b.patch,
now included upstream.
* Stop bundling containerd and runc and instead depend on the containerd
package from the archive.
2019-02-12 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
docker.io (18.09.2-0ubuntu1) disco; urgency=medium
* Update to 18.09.2, including fix for CVE-2019-5736.
- Convert components/engine/git-bundles/CVE-2019-5736.bundle into
d/patches/0001-nsenter-clone-proc-self-exe-to-avoid-exposing-host-b.patch.
- Hard code RUNC_COMMIT in d/rules for now.
2019-02-08 - Tianon Gravi <tianon@debian.org>
docker.io (18.09.1-0ubuntu2) disco; urgency=medium
* Update "docker-prefix.patch" to also fix "docker.service"
2019-01-17 - Tianon Gravi <tianon@debian.org>
docker.io (18.09.1-0~ubuntu1) disco; urgency=medium
[ Michael Hudson-Doyle ]
* d/tests/docker-in-lxd: Increase timeout passed to lxd waitready.
[ Tianon Gravi ]
* Update to 18.09.1 upstream release
[ Michael Hudson-Doyle ]
* d/rules: Empty XDG_RUNTIME_DIR when smoke testing runc to avoid it doing
silly things.
* d/golang-github-docker-docker-dev.install: install some more go packages
that other packages in the archive depend on.
2018-10-19 - Tianon Gravi <tianon@debian.org>
docker.io (18.06.1-0ubuntu2) disco; urgency=medium
* Fix containerd/runc embedded commit values
* Add "libsystemd-dev" to "Build-Depends" (LP: #1802979)

See Also

Package Description
virt-manager_1.5.1-0ubuntu1.2_all.deb desktop application for managing virtual machines
virtinst_1.5.1-0ubuntu1.2_all.deb Programs to create and clone virtual machines
visualvm_1.4.2-2~18.04.1_all.deb All-in-One Java Troubleshooting Tool
vlc-bin_3.0.8-0ubuntu18.04.1_amd64.deb binaries from VLC
vlc-data_3.0.8-0ubuntu18.04.1_all.deb common data for VLC
vlc-l10n_3.0.8-0ubuntu18.04.1_all.deb translations for VLC
vlc-plugin-access-extra_3.0.8-0ubuntu18.04.1_amd64.deb multimedia player and streamer (extra access plugins)
vlc-plugin-base_3.0.8-0ubuntu18.04.1_amd64.deb multimedia player and streamer (base plugins)
vlc-plugin-fluidsynth_3.0.8-0ubuntu18.04.1_amd64.deb FluidSynth plugin for VLC
vlc-plugin-jack_3.0.8-0ubuntu18.04.1_amd64.deb JACK audio plugins for VLC
vlc-plugin-notify_3.0.8-0ubuntu18.04.1_amd64.deb LibNotify plugin for VLC
vlc-plugin-qt_3.0.8-0ubuntu18.04.1_amd64.deb multimedia player and streamer (Qt plugin)
vlc-plugin-samba_3.0.8-0ubuntu18.04.1_amd64.deb Samba plugin for VLC
vlc-plugin-skins2_3.0.8-0ubuntu18.04.1_amd64.deb multimedia player and streamer (Skins2 plugin)
vlc-plugin-svg_3.0.8-0ubuntu18.04.1_amd64.deb SVG plugin for VLC
Advertisement
Advertisement