redis_4.0.9-1ubuntu0.2_all.deb


Advertisement

Description

redis - Persistent key-value database with network interface (metapackage)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename redis_4.0.9-1ubuntu0.2_all.deb
Package name redis
Package version 4.0.9
Package release 1ubuntu0.2
Package architecture all
Package type deb
Category universe/database
Homepage http://redis.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 3.01 KB
Installed size 70.00 KB
Redis is a key-value database in a similar vein to memcache but the dataset
is non-volatile. Redis additionally provides native support for atomically
manipulating and querying data structures such as lists and sets.
The dataset is stored entirely in memory and periodically flushed to disk.
This package depends on the redis-server package.

Alternatives

Package Version Architecture Repository
redis_4.0.9-1ubuntu0.2_all.deb 4.0.9 all Ubuntu Updates Universe
redis_4.0.9-1_all.deb 4.0.9 all Ubuntu Universe
redis_4.0.9-1_all.deb 4.0.9 all Ubuntu Universe
redis - - -

Requires

Name Value
redis-server << 5:4.0.9-1ubuntu0.2.1~
redis-server >= 5:4.0.9-1ubuntu0.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package redis_4.0.9-1ubuntu0.2_all.deb
Source Package redis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install redis deb package:
    # sudo apt-get install redis

Files

Path
/usr/share/doc/redis/00-RELEASENOTES.gz
/usr/share/doc/redis/NEWS.Debian.gz
/usr/share/doc/redis/changelog.Debian.gz
/usr/share/doc/redis/copyright

Changelog

2019-07-14 - Julian Andres Klode <juliank@ubuntu.com>
redis (5:4.0.9-1ubuntu0.2) bionic-security; urgency=medium
* SECURITY UPDATE: heap buffer overflows in Hyperloglog (Closes: #1836496)
- debian/patches/CVE-2019-10192.patch: Fix hyperloglog corruption
- CVE-2019-10192
2018-11-29 - Julian Andres Klode <juliank@ubuntu.com>
redis (5:4.0.9-1ubuntu0.1) bionic-security; urgency=medium
* SECURITY UPDATE: Memory corruption
- debian/patches/CVE-2018-11218.patch: fix in
deps/lua/src/lua_cmsgpack.c.
- CVE-2018-11218
* SECURITY UPDATE: Integer Overflow
- debian/patches/CVE-2018-11219-*.patch: fix in
deps/lua/src/lua_struct.c.
- CVE-2018-11219
* SECURITY UPDATE: Buffer overflow in the redis-cli
- debian/patches/CVE-2018-12326.patch: fix in
redis-cli.c.
- CVE-2018-12326
2018-04-02 - Chris Lamb <lamby@debian.org>
redis (5:4.0.9-1) unstable; urgency=medium
* New upstream release.
* Refresh all patches.
2018-02-25 - Chris Lamb <lamby@debian.org>
redis (5:4.0.8-2) unstable; urgency=medium
* Also listen on ::1 for IPv6 by default. (Closes: #891432)
2018-02-05 - Chris Lamb <lamby@debian.org>
redis (5:4.0.8-1) unstable; urgency=medium
* New upstream release.
<https://groups.google.com/forum/#!topic/redis-db/FGplxMEGEMo>
* Update lintian overrides after rename of
debian-watch-may-check-gpg-signature →
debian-watch-does-not-check-gpg-signature.
* Drop "recursive" argument to chown in postinst script to prevent hardlink
vulnerability.
2018-01-24 - Chris Lamb <lamby@debian.org>
redis (5:4.0.7-1) unstable; urgency=medium
* New upstream release.
<https://groups.google.com/forum/#!topic/redis-db/gngqHoh-kRM>
* Refresh patches.
2018-01-20 - Chris Lamb <lamby@debian.org>
redis (5:4.0.6-5) unstable; urgency=medium
* Update redis-sentinel's symlink to usr/bin/redis-check-rdb to match
redis-server. This avoids a dangling symlink (and thus a broken package) if
redis-server is not installed. (Closes: #884321)
* Move to debhelper compat level 11.
- Drop reference to --with=systemd - systemd-sequence is no longer provided
in compat >= 11.
* Use https URI for copyright format specification in debian/copyright.
2018-01-13 - Chris Lamb <lamby@debian.org>
redis (5:4.0.6-4) unstable; urgency=medium
* Re-add procps to Build-Depends. (Closes: #887075)
2018-01-13 - Chris Lamb <lamby@debian.org>
redis (5:4.0.6-3) unstable; urgency=medium
* Use --clients argument to runtest to force single-threaded operation over
using taskset.
* Bump Standards-Version to 4.1.3.
2017-12-14 - Chris Lamb <lamby@debian.org>
redis (5:4.0.6-2) unstable; urgency=medium
* Replace redis-sentinel's main dependency with redis-tools from
redis-server, necessarily moving the creating/deletion of the "redis" user
and associated data and log directories to redis-tools. (Closes: #884321)
* Add stub manpages for redis-sentinel, redis-check-aof and redis-check-rdb.
* Bump Standards-Version to 4.1.2.

See Also

Package Description
redmine-mysql_3.4.4-1ubuntu0.1_all.deb metapackage providing MySQL dependencies for Redmine
redmine-pgsql_3.4.4-1ubuntu0.1_all.deb metapackage providing PostgreSQL dependencies for Redmine
redmine-sqlite_3.4.4-1ubuntu0.1_all.deb metapackage providing sqlite dependencies for Redmine
redmine_3.4.4-1ubuntu0.1_all.deb flexible project management web application
registry-tools_4.7.6+dfsg~ubuntu-0ubuntu2.15_amd64.deb tools for viewing and manipulating the Windows registry
resolvconf_1.79ubuntu10.18.04.3_all.deb name server information handler
rkhunter_1.4.6-2~ubuntu18.04.1_all.deb rootkit, backdoor, sniffer and exploit scanner
rssh_2.3.4-7ubuntu0.1_amd64.deb Restricted shell allowing scp, sftp, cvs, svn, rsync or rdist
rtl8812au-dkms_4.3.8.12175.20140902+dfsg-0ubuntu12~ubuntu18.04.1_all.deb dkms source for the r8812au network driver
rtl8821ce-dkms_5.2.5.2.1.30816.20190425-0ubuntu1~18.04.1_all.deb DKMS source for the Realtek 8821C PCIe WiFi driver
ruby-guestfs_1.36.13-1ubuntu3.3_amd64.deb guest disk image management system - Ruby bindings
ruby-nokogiri_1.8.2-1ubuntu0.1_amd64.deb HTML, XML, SAX, and Reader parser for Ruby
ruby-openssl_2.0.9-0ubuntu1_amd64.deb Ruby bindings for OpenSSL
ruby-passenger-doc_5.0.30-1+deb9u1build0.18.04.1_all.deb transitional dummy package for passenger-doc
ruby-passenger_5.0.30-1+deb9u1build0.18.04.1_all.deb transitional dummy package for passenger
Advertisement
Advertisement