python3-pygraphviz_1.4~rc1-1build2.1_amd64.deb


Advertisement

Description

python3-pygraphviz - Python interface to the Graphviz graph layout and visualization package (Python 3)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename python3-pygraphviz_1.4~rc1-1build2.1_amd64.deb
Package name python3-pygraphviz
Package version 1.4~rc1
Package release 1build2.1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://pygraphviz.github.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 69.76 KB
Installed size 400.00 KB
Pygraphviz is a Python interface to the Graphviz graph layout and
visualization package.
With Pygraphviz you can create, edit, read, write, and draw graphs using
Python to access the Graphviz graph data structure and layout algorithms.
This package contains the Python 3 version of python-pygraphviz.

Alternatives

Package Version Architecture Repository
python3-pygraphviz_1.4~rc1-1build2.1_i386.deb 1.4~rc1 i386 Ubuntu Updates Universe
python3-pygraphviz_1.4~rc1-1build2_i386.deb 1.4~rc1 i386 Ubuntu Universe
python3-pygraphviz_1.4~rc1-1build2_amd64.deb 1.4~rc1 amd64 Ubuntu Universe
python3-pygraphviz - - -

Requires

Name Value
graphviz >= 2.16
libc6 >= 2.14
libcgraph6 -
python3 << 3.7
python3 >= 3.6~
python3:any >= 3.3.2-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-pygraphviz_1.4~rc1-1build2.1_amd64.deb
Source Package python-pygraphviz

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-pygraphviz deb package:
    # sudo apt-get install python3-pygraphviz

Changelog

2019-06-27 - Emerson Knapp (aubdsk) <eknapp@amazon.com>
python-pygraphviz (1.4~rc1-1build2.1) bionic; urgency=medium
* No change rebuild (LP: #1834379)
2017-08-05 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
python-pygraphviz (1.4~rc1-1build2) artful; urgency=medium
* No change rebuild to drop Python 3.5 support.
2017-05-12 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
python-pygraphviz (1.4~rc1-1build1) artful; urgency=medium
* No change rebuild to add Python 3.6 support.
2017-01-08 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.4~rc1-1) unstable; urgency=medium
* New upstream release candidate
* Acknowledge NMU, thanks!! Closes: #840845
* debian/copyright
- extend packaging copyright years
* debian/control
- add mock to b-d, needed by tests
- remove X-P-V fields, no longer needed
* compat level 10
* debian/rules
- remove doc/build in clean target, this allows the package to be built
twice in a row; Closes: #825922
- make tests errors fail the build; Closes: #842539
2016-10-30 - Cyril Brulebois <kibi@debian.org>
python-pygraphviz (1.3.1-1.1) unstable; urgency=high
* Non-maintainer upload.
* Remove “set -e; \” line in the dh_auto_test override, which was commented
out already. Test results are ignored entirely anyway. This fixes the
FTBFS with /bin/sh as bash, thanks to Chris Lamb (Closes: #840845).
2016-04-23 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.3.1-1) unstable; urgency=medium
[ Sandro Tosi ]
* New upstream release; Closes: #794444, #819739
* debian/copyright
- extend upstream copyright years
- extend packaging copyright years
- convert to DEP-5 format
- add files from new upstream release
* debian/rules
- don't install README.*, not very informative
- print for which python flavour we're running the tests
- increase test verbosity
- dont fail the build it tests fail
* debian/control
- update Homepage field
- bump Standards-Version to 3.9.8 (no changes needed)
[ Ondřej Nový ]
* Fixed VCS URL (https)
2015-06-29 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.3~rc2-3) unstable; urgency=medium
* debian/control
- suggests the -doc package
2015-02-14 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.3~rc2-2) experimental; urgency=medium
* debian/{control, rules}
- provide py3k packages
* debian/watch
- use PyPI redirector
* debian/{control, docs, rules}
- build documentation and provide a -doc package
2014-11-02 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.3~rc2-1) unstable; urgency=medium
* New upstream release candidate
* debian/patches/{2e27964ce86e8f49c496e5a549237ff6b1763e9a*.patch, 
ignore-decoding.patch}
- removed, merged upstream
* debian/rules
- run unittests at build time
* debian/patches/dont-import-tests.patch
- removed, no longer needed
* debian/control
- add python-nose to b-d, needed to run unittests
2014-10-10 - Sandro Tosi <morph@debian.org>
python-pygraphviz (1.3~rc1-1) unstable; urgency=medium
* New upstream release candidate
* Switch from CDBS + pysupport to dh sequencer and dh_python2; Closes: #759709
* debian/patches/*
- don't install data from setup.py, use dh_installexamples instead
* debian/control
- remove useless Provides
- fix typo in long description for -dbg package
- switch me to Maintainer (team to Uploaders)
- add graphviz to b-d, needed to run tests
- bump Standards-Version to 3.9.6 (no changes needed)
* debian/README.source
- removed, no longer needed
* Bump debhelper compat version to 9
* debian/copyright
- extend packaging and upstream copyright years
* debian/patches/ignore-decoding.patch
- remove locale & decoding in libgraphviz identification process
* debian/patches/dont-import-tests.patch
- disable load of tests submodule

See Also

Package Description
python3-pyldap_3.0.0-1ubuntu0.1_amd64.deb LDAP interface module for Python 3.x - transition package
python3-pylxd_2.2.6-0ubuntu1.1_all.deb Python library for interacting with LXD REST API
python3-pysaml2_4.0.2-0ubuntu3.1_all.deb SAML Version 2 to be used in a WSGI environment - Python 3.x
python3-rados_12.2.12-0ubuntu0.18.04.4_amd64.deb Python 3 libraries for the Ceph librados library
python3-rbd_12.2.12-0ubuntu0.18.04.4_amd64.deb Python 3 libraries for the Ceph librbd library
python3-rgw_12.2.12-0ubuntu0.18.04.4_amd64.deb Python 3 libraries for the Ceph librgw library
python3-tornado_4.5.3-1ubuntu0.1_amd64.deb scalable, non-blocking web server and tools - Python 3 package
python3-unbound_1.6.7-1ubuntu2.2_amd64.deb library implementing DNS resolution and validation (Python3 bindings)
python3-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb module of decorators for elegant access to uWSGI API (Python 3)
python3-venv_3.6.7-1~18.04_amd64.deb pyvenv-3 binary for python3 (default python3 version)
python3-wsme_0.9.2-0ubuntu2.18.04.1_all.deb Web Services Made Easy: implement multi-protocol webservices - Python 3.x
python3-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Python 3 extension for Ice
python3.6-venv_3.6.9-1~18.04_amd64.deb Interactive high-level object-oriented language (pyvenv binary, version 3.6)
python3.7-dev_3.7.5-2~18.04_amd64.deb Header files and a static library for Python (v3.7)
python3.7-doc_3.7.5-2~18.04_all.deb Documentation for the high-level object-oriented language Python (v3.7)
Advertisement
Advertisement