python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb


Advertisement

Description

python-wokkel - collection of enhancements for Twisted

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb
Package name python-wokkel
Package version 0.7.1
Package release 1ubuntu0.18.04.1
Package architecture all
Package type deb
Category universe/python
Homepage http://wokkel.ik.nu/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 91.86 KB
Installed size 792.00 KB
Wokkel is a collection of enhancements on top of the
Twisted networking framework, written in Python. It
mostly provides a testing ground for enhancements to
the Jabber/XMPP protocol implementation as found in
Twisted Words, that are meant to eventually move there.

Alternatives

Package Version Architecture Repository
python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb 0.7.1 all Ubuntu Updates Universe
python-wokkel_0.7.1-1_all.deb 0.7.1 all Ubuntu Universe
python-wokkel_0.7.1-1_all.deb 0.7.1 all Ubuntu Universe
python-wokkel - - -

Requires

Name Value
python >= 2.7
python << 2.8
python-dateutil -
python-twisted-core >= 10.0.0
python-twisted-names >= 10.0.0
python-twisted-words >= 10.0.0
python:any >= 2.6.6-7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb
Source Package wokkel

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-wokkel deb package:
    # sudo apt-get install python-wokkel

Files

Path
/usr/lib/python2.7/dist-packages/twisted/plugins/server.py
/usr/lib/python2.7/dist-packages/wokkel/__init__.py
/usr/lib/python2.7/dist-packages/wokkel/client.py
/usr/lib/python2.7/dist-packages/wokkel/compat.py
/usr/lib/python2.7/dist-packages/wokkel/component.py
/usr/lib/python2.7/dist-packages/wokkel/componentservertap.py
/usr/lib/python2.7/dist-packages/wokkel/data_form.py
/usr/lib/python2.7/dist-packages/wokkel/delay.py
/usr/lib/python2.7/dist-packages/wokkel/disco.py
/usr/lib/python2.7/dist-packages/wokkel/formats.py
/usr/lib/python2.7/dist-packages/wokkel/generic.py
/usr/lib/python2.7/dist-packages/wokkel/iwokkel.py
/usr/lib/python2.7/dist-packages/wokkel/muc.py
/usr/lib/python2.7/dist-packages/wokkel/ping.py
/usr/lib/python2.7/dist-packages/wokkel/pubsub.py
/usr/lib/python2.7/dist-packages/wokkel/server.py
/usr/lib/python2.7/dist-packages/wokkel/shim.py
/usr/lib/python2.7/dist-packages/wokkel/subprotocols.py
/usr/lib/python2.7/dist-packages/wokkel/xmppim.py
/usr/lib/python2.7/dist-packages/wokkel-0.7.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/wokkel-0.7.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/wokkel-0.7.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/wokkel-0.7.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/wokkel-0.7.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/wokkel/test/__init__.py
/usr/lib/python2.7/dist-packages/wokkel/test/helpers.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_client.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_compat.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_component.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_data_form.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_delay.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_disco.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_generic.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_iwokkel.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_muc.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_ping.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_pubsub.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_server.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_shim.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_subprotocols.py
/usr/lib/python2.7/dist-packages/wokkel/test/test_xmppim.py
/usr/share/doc/python-wokkel/changelog.Debian.gz
/usr/share/doc/python-wokkel/copyright
/usr/share/doc/python-wokkel/examples/echo_server.tac
/usr/share/doc/python-wokkel/examples/muc_client.tac
/usr/share/doc/python-wokkel/examples/ping_component.tac
/usr/share/doc/python-wokkel/examples/ping_s2s.tac
/usr/share/doc/python-wokkel/examples/ping_server.tac
/usr/share/doc/python-wokkel/examples/pinger.py
/usr/share/doc/python-wokkel/examples/pinger_client.tac
/usr/share/doc/python-wokkel/examples/pinger_component.tac
/usr/share/doc/python-wokkel/examples/pinger_s2s.tac
/usr/share/doc/python-wokkel/examples/router.tac

Changelog

2018-07-11 - Brian Murray <brian@ubuntu.com>
wokkel (0.7.1-1ubuntu0.18.04.1) bionic; urgency=medium
* Convert trigger to noawait (LP: #1780996)
2013-01-16 - Angel Abad <angel@debian.org>
wokkel (0.7.1-1) unstable; urgency=low
* Imported Upstream version 0.7.1
* debian/control: Update VCS fields for Git
* debian/rules:
- Don't remove egg-info dir
- Remove override_dh_auto_clean target
* debian/copyright: Update format to copyright-format 1.0
* Bump Standards-Version to 3.9.4
2012-01-31 - Angel Abad <angel@debian.org>
wokkel (0.7.0-1) unstable; urgency=low
* New upstream release
* debian/control:
- Switch python-twisted to python-twisted-core in Depends
- Bump python-twisted-core Depends to 10.0.0
- {Build-}Depends on python-dateutil
- Depends on python-twisted-words (>= 10.0.0)
- Depends on python-twisted-names (>= 10.0.0)
* debian/pydist-overrides:
- Override twisted with python-twisted-core
* debian/python-wokkel.triggers:
- Add trigger to update twisted plugins cache
2012-01-02 - Angel Abad <angel@debian.org>
wokkel (0.6.3-5) unstable; urgency=low
* debian/watch: Ignore upstream pre releases
* Update my email address -> angel@debian.org
* debian/copyright:
- Update debian/* years
- Update format specification
* debian/control: Remove DM-Upload-Allowed
2011-08-07 - Angel Abad <angelabad@gmail.com>
wokkel (0.6.3-4) unstable; urgency=low
* debian/control:
- Remove python:Breaks
- Fix typo in description, thanks Simon Kainz (Closes: #636585)
* Bump Standards-Version to 3.9.2 (no changes)
* Bump Debhelper compat level to 8
2011-05-08 - Piotr Oarowski <piotr@debian.org>
wokkel (0.6.3-3) unstable; urgency=low
* Team upload.
* Rebuild to add Python 2.7 support
2011-02-08 - Angel Abad <angelabad@gmail.com>
wokkel (0.6.3-2) unstable; urgency=low
* Switch to dh_python2
- debian/control:
+ Remove python-support from B-D-I
+ Bump minimun python-all version to 2.6.6-3
+ Add Breaks: python:Breaks
+ Add X-Python-Version: >= 2.4
- debian/rules
+ Add --with python2 to rules
- debian/pyversions: Remove file
* Bump Standards-Version to 3.9.1 (no changes)
* Switch to dpkg-source format 3.0 (quilt)
2009-10-04 - Angel Abad <angelabad@gmail.com>
wokkel (0.6.3-1) unstable; urgency=low
* Initial release (Closes: #535829)

See Also

Package Description
python-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Python 2 extension for Ice
python3-acme_0.22.2-1ubuntu0.1_all.deb ACME protocol library for Python 3
python3-aptdaemon.test_1.1.1+bzr982-0ubuntu19.1_all.deb Test environment for aptdaemon clients
python3-boto_2.44.0-1ubuntu2.18.04.0_all.deb Python interface to Amazon's Web Services - Python 3.x
python3-brotli_1.0.3-1ubuntu1.2_amd64.deb lossless compression algorithm and format (Python 3 version)
python3-ceph-argparse_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 utility libraries for Ceph CLI
python3-cephfs_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 libraries for the Ceph libcephfs library
python3-django-openstack-auth_13.0.2-0ubuntu1_all.deb Django authentication backend for Openstack - Python 3.x
python3-gnocchi_4.2.5-0ubuntu1_all.deb Metric as a Service - Python 3.x
python3-gnupg_0.4.1-1ubuntu1.18.04.1_all.deb Python wrapper for the GNU Privacy Guard (Python 3.x)
python3-google-compute-engine_20190522-0ubuntu1~18.04.0_all.deb Python library for Google Compute Engine interaction (Python 3)
python3-gst-1.0_1.14.5-0ubuntu1~18.04.1_amd64.deb GStreamer GObject Introspection overrides for Python (Python 3)
python3-guestfs_1.36.13-1ubuntu3.3_amd64.deb guest disk image management system - Python 3 bindings
python3-imaplib2_2.57-1ubuntu0.1_all.deb Threaded Python IMAP4 client (Python 3)
python3-lasso_2.5.1-0ubuntu1.1_amd64.deb Library for Liberty Alliance and SAML protocols - Python bindings
Advertisement
Advertisement