python-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb


Advertisement

Description

python-uwsgidecorators - module of decorators for elegant access to uWSGI API (Python 2)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename python-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb
Package name python-uwsgidecorators
Package version 2.0.15
Package release 10.2ubuntu2.1
Package architecture all
Package type deb
Category universe/python
Homepage http://projects.unbit.it/uwsgi/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.38 KB
Installed size 60.00 KB
uwsgidecorators is a simple Python module that exports a bunch of decorators
to allow a more elegant approach to uWSGI API. Provided decorators helps with
creating of RPC functions, timers, filemonitors.
This package provides uwsgidecorators module
for Python 2.

Alternatives

Package Version Architecture Repository
python-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb 2.0.15 all Ubuntu Updates Universe
python-uwsgidecorators_2.0.15-10.2ubuntu2_all.deb 2.0.15 all Ubuntu Universe
python-uwsgidecorators_2.0.15-10.2ubuntu2_all.deb 2.0.15 all Ubuntu Universe
python-uwsgidecorators - - -

Requires

Name Value
python >= 2.7
python << 2.8
python:any >= 2.6.6-7~
uwsgi-core -
uwsgi-plugin-python -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb
Source Package uwsgi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-uwsgidecorators deb package:
    # sudo apt-get install python-uwsgidecorators

Files

Path
/usr/lib/python2.7/dist-packages/uwsgidecorators.py
/usr/share/doc/python-uwsgidecorators/CONTRIBUTORS
/usr/share/doc/python-uwsgidecorators/README
/usr/share/doc/python-uwsgidecorators/changelog.Debian.gz
/usr/share/doc/python-uwsgidecorators/copyright

Changelog

2018-09-27 - Mike Salvatore <mike.salvatore@canonical.com>
uwsgi (2.0.15-10.2ubuntu2.1) bionic-security; urgency=medium
* SECURITY UPDATE: Directory traversal
- debian/patches/CVE-2018-7490.patch: enforce php default document_root
behaviour, to not show external files
- CVE-2018-7490
* Add gccgo-7 as build-depends to avoid FTBFS
- This fix was taken from 2.0.15-11
2018-03-01 - Dimitri John Ledkov <xnox@ubuntu.com>
uwsgi (2.0.15-10.2ubuntu2) bionic; urgency=high
* No change rebuild against ruby-defaults without ruby2.3 support.
2018-02-28 - Steve Langasek <steve.langasek@ubuntu.com>
uwsgi (2.0.15-10.2ubuntu1) bionic; urgency=medium
* Migrate to ruby 2.5.
2018-02-28 - Steve Langasek <steve.langasek@ubuntu.com>
uwsgi (2.0.15-10.2build1) bionic; urgency=medium
* No-change rebuild against libcurl4
2018-02-09 - Salvatore Bonaccorso <carnil@debian.org>
uwsgi (2.0.15-10.2) unstable; urgency=medium
* Non-maintainer upload.
* Stack-based buffer overflow in uwsgi_expand_path function (CVE-2018-6758)
(Closes: #889753)
2018-01-24 - Thomas Goirand <zigo@debian.org>
uwsgi (2.0.15-10.1) unstable; urgency=medium
* Non-maintainer upload.
* Adds 2to3 as build-depends (Closes: #884671).
2017-10-20 - Jonas Smedegaard <dr@jones.dk>
uwsgi (2.0.15-10) unstable; urgency=medium
* Simplify packaging by offloading some parts to separate source:
+ Stop build plugins for PHP.
+ Drop binary package uwsgi-plugin-php.
+ Stop build-depend on php-dev libphp-embed.
* Fix debhelper snippet to skip (not fail) on non-uwsgi-plugin
packages.
* Fix have uwsgi-dev depend on libbsd-dev on kFreeBSD.
Closes: Bug#877801. Thanks to Aaron M. Ucko.
* Fix recent changelog entries coverage of changes to package
relations and provided binary packages.
* Use package priority optional (not extra: obsolete).
* Declare compliance with Debian Policy 4.1.1.
2017-09-29 - Jonas Smedegaard <dr@jones.dk>
uwsgi (2.0.15-9) unstable; urgency=medium
* Fix broken syntax in debhelper snippet.
2017-09-28 - Jonas Smedegaard <dr@jones.dk>
uwsgi (2.0.15-8) unstable; urgency=medium
* Fix simplify debhelper snippet to avoid non-core library.
2017-09-28 - Jonas Smedegaard <dr@jones.dk>
uwsgi (2.0.15-7) unstable; urgency=medium
* Simplify packaging by offloading some parts to separate source:
+ Stop build plugin for LuaJIT.
+ Drop binary package uwsgi-plugin-luajit.
+ Stop build-depend on libluajit-5.1-dev.

See Also

Package Description
python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb collection of enhancements for Twisted
python-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Python 2 extension for Ice
python3-acme_0.22.2-1ubuntu0.1_all.deb ACME protocol library for Python 3
python3-aptdaemon.test_1.1.1+bzr982-0ubuntu19.1_all.deb Test environment for aptdaemon clients
python3-boto_2.44.0-1ubuntu2.18.04.0_all.deb Python interface to Amazon's Web Services - Python 3.x
python3-brotli_1.0.3-1ubuntu1.2_amd64.deb lossless compression algorithm and format (Python 3 version)
python3-ceph-argparse_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 utility libraries for Ceph CLI
python3-cephfs_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 libraries for the Ceph libcephfs library
python3-django-openstack-auth_13.0.2-0ubuntu1_all.deb Django authentication backend for Openstack - Python 3.x
python3-gnocchi_4.2.5-0ubuntu1_all.deb Metric as a Service - Python 3.x
python3-gnupg_0.4.1-1ubuntu1.18.04.1_all.deb Python wrapper for the GNU Privacy Guard (Python 3.x)
python3-google-compute-engine_20190522-0ubuntu1~18.04.0_all.deb Python library for Google Compute Engine interaction (Python 3)
python3-gst-1.0_1.14.5-0ubuntu1~18.04.1_amd64.deb GStreamer GObject Introspection overrides for Python (Python 3)
python3-guestfs_1.36.13-1ubuntu3.3_amd64.deb guest disk image management system - Python 3 bindings
python3-imaplib2_2.57-1ubuntu0.1_all.deb Threaded Python IMAP4 client (Python 3)
Advertisement
Advertisement