python-tornado_4.5.3-1ubuntu0.1_amd64.deb


Advertisement

Description

python-tornado - scalable, non-blocking web server and tools

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename python-tornado_4.5.3-1ubuntu0.1_amd64.deb
Package name python-tornado
Package version 4.5.3
Package release 1ubuntu0.1
Package architecture amd64
Package type deb
Category universe/python
Homepage http://www.tornadoweb.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 277.54 KB
Installed size 1.58 MB
Tornado is a Python web framework and asynchronous networking library,
originally developed at FriendFeed. By using non-blocking network I/O,
Tornado can scale to tens of thousands of open connections, making it ideal
for long polling, WebSockets, and other applications that require a
long-lived connection to each user.
This is the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
python-tornado_4.5.3-1ubuntu0.1_i386.deb 4.5.3 i386 Ubuntu Updates Universe
python-tornado_4.5.3-1_i386.deb 4.5.3 i386 Ubuntu Universe
python-tornado_4.5.3-1_amd64.deb 4.5.3 amd64 Ubuntu Universe
python-tornado - - -

Requires

Name Value
ca-certificates -
libc6 >= 2.4
python >= 2.7~
python << 2.8
python-backports-abc -
python-singledispatch -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-tornado_4.5.3-1ubuntu0.1_amd64.deb
Source Package python-tornado

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-tornado deb package:
    # sudo apt-get install python-tornado

Changelog

2019-05-29 - Dimitri John Ledkov <xnox@ubuntu.com>
python-tornado (4.5.3-1ubuntu0.1) bionic; urgency=medium
* Cherrypick patches from python-tornado4 4.5.3-2 package, to
enable OpenSSL 1.1.1 support LP: #1797386:
- New_test_crt.patch regenerate stronger test certificates
- skip-failing-tests.patch skip some ssl tests failing with OpenSSL 1.1.1
2018-01-15 - Ondřej Nový <onovy@debian.org>
python-tornado (4.5.3-1) unstable; urgency=medium
* New upstream release
* Bump std-ver to 4.1.3 (no changes needed)
* Push dh compat to 11
* d/copyright: Bump my copyright year
* Move docs and examples into /usr/share/python-tornado
* Override wrong-section-according-to-package-name for python3-tornado too
2017-10-31 - Ondřej Nový <onovy@debian.org>
python-tornado (4.5.2-1) unstable; urgency=medium
[ Julien Puydt ]
* New upstream release.
* Bump d/watch to version 4.
* d/control: Remove Testsuite: autopkgtest, it's not needed
[ Ondřej Nový ]
* Bump std-ver to 4.1.1.
2017-06-20 - Ondřej Nový <onovy@debian.org>
python-tornado (4.5.1-2) unstable; urgency=medium
* Uploading to unstable
2017-05-12 - Ondřej Nový <onovy@debian.org>
python-tornado (4.5.1-1) experimental; urgency=medium
* New upstream release
* d/copyright
- Bump my copyright year
- Adjust for new upstream release
2017-04-13 - Ondřej Nový <onovy@debian.org>
python-tornado (4.4.3-1) unstable; urgency=medium
* New upstream bugfix release
* No longer disable PIE during build
2016-10-07 - Julien Puydt <julien.puydt@laposte.net>
python-tornado (4.4.2-1) unstable; urgency=medium
* New upstream release.
* Push dh compat to 10.
2016-08-05 - Ondřej Nový <onovy@debian.org>
python-tornado (4.4.1-2) unstable; urgency=medium
* Prevent internet access during build (Closes: #833351)
- Use local objects.inv for intersphinx mapping
- Skip domain resolving tests
2016-08-01 - Ondřej Nový <onovy@debian.org>
python-tornado (4.4.1-1) unstable; urgency=medium
* New upstream release (Closes: #830859)
* Rearranged lintian overrides for new release
* Added myself as uploader
* Removed python-simplejson and python-multiprocessing from B-D/R,
because Python < 2.6 is not supported anymore (Closes: #826455)
* Moved python-mysqldb from Recommends to Suggests, it's only used in demo
* Moved python{3,}-pycurl from Depends to Suggests, it's not strictly needed
and added to B-D to run related unit tests
* Added python-concurrent.futures to Build-Depends and Recommends
* Added python{3,}-twisted to Build-Depends and Suggests
* Added python{3,}-mock to Build-Depends
* d/copyright: Added myself to Debian part
* Package description changed to upstream (newer) version
* Rearranged Debian tests Depends to Build-Depends
* Run Py3 unit tests during build and enable verbose mode
* Bumped required Python version to 2.7 and 3.3
* Added python-tornado-doc package with docs and examples
* Enabled all but PIE hardening
* Generate upstream changelog file during build
* Added python3-backports-abc to B-D for older Python 3
2016-05-24 - Ondřej Nový <novy@ondrej.org>
python-tornado (4.3.0-2) unstable; urgency=medium
[ Ondřej Nový ]
* Team upload
* Added Build-Depends to dh-python and python-setuptools
* Added ${shlibs:Depends} and removed lintian override for libc
* Lintian tag rename:
privacy-breach-may-use-debian-package -> privacy-breach-uses-embedded-file
[ Gianfranco Costamagna, Ondřej Nový ]
* debian/patches/0007-Fix-testsuite-failure-when-sockets-is-not-defined.patch:
fix testsuite when sockets is not defined.
- https://github.com/tornadoweb/tornado/pull/1725

See Also

Package Description
python-ufw_0.36-0ubuntu0.18.04.1_all.deb Uncomplicated FireWall Python modules
python-unbound_1.6.7-1ubuntu2.2_amd64.deb library implementing DNS resolution and validation (Python bindings)
python-uwsgidecorators_2.0.15-10.2ubuntu2.1_all.deb module of decorators for elegant access to uWSGI API (Python 2)
python-wokkel_0.7.1-1ubuntu0.18.04.1_all.deb collection of enhancements for Twisted
python-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Python 2 extension for Ice
python3-acme_0.22.2-1ubuntu0.1_all.deb ACME protocol library for Python 3
python3-aptdaemon.test_1.1.1+bzr982-0ubuntu19.1_all.deb Test environment for aptdaemon clients
python3-boto_2.44.0-1ubuntu2.18.04.0_all.deb Python interface to Amazon's Web Services - Python 3.x
python3-brotli_1.0.3-1ubuntu1.2_amd64.deb lossless compression algorithm and format (Python 3 version)
python3-ceph-argparse_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 utility libraries for Ceph CLI
python3-cephfs_12.2.12-0ubuntu0.18.04.3_amd64.deb Python 3 libraries for the Ceph libcephfs library
python3-django-openstack-auth_13.0.2-0ubuntu1_all.deb Django authentication backend for Openstack - Python 3.x
python3-gnocchi_4.2.5-0ubuntu1_all.deb Metric as a Service - Python 3.x
python3-gnupg_0.4.1-1ubuntu1.18.04.1_all.deb Python wrapper for the GNU Privacy Guard (Python 3.x)
python3-google-compute-engine_20190522-0ubuntu1~18.04.0_all.deb Python library for Google Compute Engine interaction (Python 3)
Advertisement
Advertisement