python-gst-1.0_1.14.5-0ubuntu1~18.04.1_amd64.deb


Advertisement

Description

python-gst-1.0 - GStreamer GObject Introspection overrides for Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename python-gst-1.0_1.14.5-0ubuntu1~18.04.1_amd64.deb
Package name python-gst-1.0
Package version 1.14.5
Package release 0ubuntu1~18.04.1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://gstreamer.freedesktop.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.61 KB
Installed size 61.00 KB
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data.  Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related.  Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
This package contains GObject Introspection overrides for Python that
can be used by Python applications using GStreamer.

Alternatives

Package Version Architecture Repository
python-gst-1.0_1.14.5-0ubuntu1~18.04.1_i386.deb 1.14.5 i386 Ubuntu Updates Universe
python-gst-1.0_1.14.0-1_i386.deb 1.14.0 i386 Ubuntu Universe
python-gst-1.0_1.14.0-1_amd64.deb 1.14.0 amd64 Ubuntu Universe
python-gst-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
gir1.2-gst-plugins-base-1.0 >= 1.14.5
gir1.2-gstreamer-1.0 >= 1.14.5
libc6 >= 2.4
libglib2.0-0 >= 2.12.0
libgstreamer1.0-0 >= 1.14.5
python >= 2.7~
python << 2.8
python-gi >= 3.8
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-gst-1.0_1.14.5-0ubuntu1~18.04.1_amd64.deb
Source Package gst-python1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gst-1.0 deb package:
    # sudo apt-get install python-gst-1.0

Files

Path
/usr/lib/python2.7/dist-packages/gi/overrides/Gst.py
/usr/lib/python2.7/dist-packages/gi/overrides/GstPbutils.py
/usr/lib/python2.7/dist-packages/gi/overrides/_gi_gst.x86_64-linux-gnu.so
/usr/share/doc/python-gst-1.0/changelog.Debian.gz
/usr/share/doc/python-gst-1.0/copyright

Changelog

2019-07-04 - Iain Lane <iain.lane@canonical.com>
gst-python1.0 (1.14.5-0ubuntu1~18.04.1) bionic; urgency=medium
* New upstream bugfix release (LP: #1832123)
* Update references to 1.14.5
2019-05-16 - Iain Lane <iain.lane@canonical.com>
gst-python1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium
* No-change backport to bionic (LP: #1829366)
2018-10-03 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.4-1) unstable; urgency=medium
* New upstream bugfix release
2018-09-17 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.3-1) unstable; urgency=medium
* New upstream bugfix release.
2018-07-23 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.2-1) unstable; urgency=medium
* New upstream bugfix release
2018-05-18 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.1-1) unstable; urgency=medium
* New upstream bugfix release
2018-04-28 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.0-2) unstable; urgency=medium
* debian/patches/0001-overrides-use-get_introspection_module.patch,
debian/control:
+ Fix importing of GI overrides (Closes: #896241, #896222).
2018-03-20 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.14.0-1) unstable; urgency=medium
* New upstream stable release.
2018-03-14 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.13.91-1) experimental; urgency=medium
* New upstream release candidate.
2018-03-05 - Sebastian Dröge <slomo@debian.org>
gst-python1.0 (1.13.90-1) experimental; urgency=medium
* New upstream release candidate.

See Also

Package Description
python-guestfs_1.36.13-1ubuntu3.3_amd64.deb guest disk image management system - Python bindings
python-imaplib2_2.57-1ubuntu0.1_all.deb Threaded Python IMAP4 client
python-lasso_2.5.1-0ubuntu1.1_amd64.deb Library for Liberty Alliance and SAML protocols - Python bindings
python-libapparmor_2.12-4ubuntu5.1_amd64.deb AppArmor library Python bindings
python-libcec_4.0.2+dfsg1-2ubuntu1.1_amd64.deb Python bindings for USB CEC Adaptor
python-libipa-hbac_1.16.1-1ubuntu1.4_amd64.deb Python bindings for the FreeIPA HBAC Evaluator library
python-libsss-nss-idmap_1.16.1-1ubuntu1.4_amd64.deb Python bindings for the SID lookups library
python-lldb-7_7-3~ubuntu0.18.04.1_amd64.deb Next generation, high-performance debugger, python lib
python-lldb-8_8-3~ubuntu18.04.1_amd64.deb Next generation, high-performance debugger, python lib
python-louis_3.5.0-1ubuntu0.3_all.deb Python bindings for liblouis
python-mechanicalsoup_0.10.0-1.1_all.deb library for automating interaction with websites (Python 2)
python-mediainfodll_17.12-1ubuntu0.1_all.deb library for reading metadata from media files -- shared library
python-netsnmp_5.7.3+dfsg-1.8ubuntu3.3_amd64.deb SNMP (Simple Network Management Protocol) Python support
python-neutron-dynamic-routing_12.0.0-0ubuntu1.1_all.deb OpenStack Neutron Dynamic Routing - Python 2.7 library
python-neutron-fwaas-dashboard_1.3.0-0ubuntu1.1_all.deb OpenStack Firewall as a Service - dashboard plugin
Advertisement
Advertisement