libopencryptoki-dev_3.9.0+dfsg-0ubuntu1.2_amd64.deb


Advertisement

Description

libopencryptoki-dev - PKCS#11 implementation (development)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename libopencryptoki-dev_3.9.0+dfsg-0ubuntu1.2_amd64.deb
Package name libopencryptoki-dev
Package version 3.9.0+dfsg
Package release 0ubuntu1.2
Package architecture amd64
Package type deb
Category universe/libdevel
Homepage https://github.com/opencryptoki/opencryptoki
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 17.64 KB
Installed size 107.00 KB
openCryptoki is a PKCS#11 Cryptographic Token Interface Standard
implementation.  It includes drivers and libraries to enable IBM cryptographic
hardware such as Trusted Computing Platform (TPM) cryptographic devices as well
as a software token for testing.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libopencryptoki-dev_3.9.0+dfsg-0ubuntu1.2_i386.deb 3.9.0+dfsg i386 Ubuntu Updates Universe
libopencryptoki-dev_3.9.0+dfsg-0ubuntu1_i386.deb 3.9.0+dfsg i386 Ubuntu Universe
libopencryptoki-dev_3.9.0+dfsg-0ubuntu1_amd64.deb 3.9.0+dfsg amd64 Ubuntu Universe
libopencryptoki-dev - - -

Requires

Name Value
libopencryptoki0 = 3.9.0+dfsg-0ubuntu1.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libopencryptoki-dev_3.9.0+dfsg-0ubuntu1.2_amd64.deb
Source Package opencryptoki

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopencryptoki-dev deb package:
    # sudo apt-get install libopencryptoki-dev

Files

Path
/usr/include/opencryptoki/apiclient.h
/usr/include/opencryptoki/pkcs11.h
/usr/include/opencryptoki/pkcs11types.h
/usr/lib/x86_64-linux-gnu/libopencryptoki.so
/usr/lib/x86_64-linux-gnu/opencryptoki/PKCS11_API.so
/usr/lib/x86_64-linux-gnu/opencryptoki/libopencryptoki.so
/usr/share/doc/libopencryptoki-dev/changelog.Debian.gz
/usr/share/doc/libopencryptoki-dev/copyright

Changelog

2019-08-19 - Dimitri John Ledkov <xnox@ubuntu.com>
opencryptoki (3.9.0+dfsg-0ubuntu1.2) bionic; urgency=medium
* Fix CKR_SIGNATURE_INVALID, CKR_FUNCTION_FAILED when running the
rsa_tests from opencryptoki 3.9.0 on the ICA token LP: #1840419:
- Fix token_specific_rsa_x509_verify() function.
- Fix get_mgf_mech() to support SHA224.
* Fix hash verification error with SHA-512 HMAC LP: #1840420:
- Fix a bug in sha512_hmac_sign(), wrong size was in use.
2018-05-17 - Dimitri John Ledkov <xnox@ubuntu.com>
opencryptoki (3.9.0+dfsg-0ubuntu1.1) bionic; urgency=medium
* Build without symbolic-functions, as that makes opencryptoki fail to
load multiple tokens/plugins correctly. LP: #1725250
2018-02-26 - Dimitri John Ledkov <xnox@ubuntu.com>
opencryptoki (3.9.0+dfsg-0ubuntu1) bionic; urgency=medium
* New upstream release LP: #1751272
* Specify Format in debian/copyright
* Drop custom dfsg script, and list directories to exclude in the
debian/copyright file
* libitm is not available on armhf, drop build-depends, and disable
locks on armhf.
2018-02-08 - Dimitri John Ledkov <xnox@ubuntu.com>
opencryptoki (3.8.2+dfsg-0ubuntu1) bionic; urgency=medium
* New upstream release LP: #1742437
* Drop upstreamed patches
2018-02-05 - Dimitri John Ledkov <xnox@ubuntu.com>
opencryptoki (3.8.1+dfsg-3build1) bionic; urgency=high
* No change rebuild against openssl1.1.
2017-11-09 - Paulo Vital <pvital@gmail.com>
opencryptoki (3.8.1+dfsg-3) unstable; urgency=emergency
* Remove wrong tmpfiles.conf file present in systemd path. Closes: #881222
* Updated install files.
* Updated rules.
2017-11-03 - Paulo Vital <pvital@gmail.com>
opencryptoki (3.8.1+dfsg-2) unstable; urgency=medium
* Updated install files for s390x. Closes: #880657
2017-10-31 - Paulo Vital <pvital@gmail.com>
opencryptoki (3.8.1+dfsg-1) unstable; urgency=medium
* New upstream release
* Removed patch 08-reset-tpm-structures.patch
* Removed patch systemd-targets.patch
* Added patch tmpfiles-dir-creation.patch
* Added patch icsf-spelling.patch
* Fix Lintian error build-depends-on-obsolete-package:
Removed dh-systemd since used debhelper (>= 10)
* Fix Lintian wanring useless-autoreconf-build-depends:
removed autotools-dev
* Updated Standards-Version to 4.1.1
2017-06-27 - Paulo Vital <pvital@gmail.com>
opencryptoki (3.7.0+dfsg-4) unstable; urgency=medium
* Fix broken links for libopencryptoki0. Closes: #866152, 640812
* Change to compat level 10.
* Update debian/rules with compat level 10 changes.
2017-06-20 - Paulo Vital <pvital@gmail.com>
opencryptoki (3.7.0+dfsg-3) unstable; urgency=medium
* Add libitm1 as build dependency to restrict arch. Closes: #865315

See Also

Package Description
libopencryptoki0_3.9.0+dfsg-0ubuntu1.2_amd64.deb PKCS#11 implementation (library)
libopencv-calib3d-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-calib3d3.2
libopencv-calib3d3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision Camera Calibration library
libopencv-contrib-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-contrib3.2
libopencv-contrib3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision contrlib library
libopencv-core-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-core3.2
libopencv-core3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision core library
libopencv-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for opencv
libopencv-features2d-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-features2d3.2
libopencv-features2d3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision Feature Detection and Descriptor Extraction library
libopencv-flann-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-flann3.2
libopencv-flann3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision Clustering and Search in Multi-Dimensional spaces library
libopencv-highgui-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-highgui3.2
libopencv-highgui3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb computer vision High-level GUI and Media I/O library
libopencv-imgcodecs-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb development files for libopencv-imgcodecs3.2
Advertisement
Advertisement