libkdewebkit5_4.14.38-0ubuntu3.1_amd64.deb


Advertisement

Description

libkdewebkit5 - KDE WebKit Library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64 Official
Package filename libkdewebkit5_4.14.38-0ubuntu3.1_amd64.deb
Package name libkdewebkit5
Package version 4.14.38
Package release 0ubuntu3.1
Package architecture amd64
Package type deb
Homepage http://www.kde.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 60.78 KB
Installed size 340.00 KB
Category
This library provides KDE integration of the QtWebKit library.
This package is part of the KDE Development Platform libraries module.

Alternatives

Package Version Architecture Repository
libkdewebkit5_4.14.38-0ubuntu3_amd64.deb 4.14.38 amd64 Ubuntu Universe Official
libkdewebkit5 All All All

Requires

Name Value
libc6 >= 2.14
libkdecore5 = 4:4.14.38-0ubuntu3.1
libkdeui5 = 4:4.14.38-0ubuntu3.1
libkio5 = 4:4.14.38-0ubuntu3.1
libkparts4 = 4:4.14.38-0ubuntu3.1
libqt4-network >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libqtwebkit4 -
libstdc++6 >= 5

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libkdewebkit5_4.14.38-0ubuntu3.1_amd64.deb
Source Package kde4libs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkdewebkit5 deb package:
    # sudo apt-get install libkdewebkit5

Files

Path
/usr/lib/libkdewebkit.so.5
/usr/lib/libkdewebkit.so.5.14.38
/usr/share/doc/libkdewebkit5/NEWS.Debian.gz
/usr/share/doc/libkdewebkit5/changelog.Debian.gz
/usr/share/doc/libkdewebkit5/copyright

Changelog

2019-08-12 - Paulo Flabiano Smorigo <pfsmorigo@canonical.com>
kde4libs (4:4.14.38-0ubuntu3.1) bionic-security; urgency=medium
* SECURITY UPDATE: malicious .desktop files (and others) would execute
code (LP: #1839432).
- debian/patches/CVE-2019-14744.patch: remove support for $(...) in
config keys with [$e] marker.
- CVE-2019-14744
2018-02-10 - Dimitri John Ledkov <xnox@ubuntu.com>
kde4libs (4:4.14.38-0ubuntu3) bionic; urgency=medium
* Build against libssl1.0-dev, as otherwise autopkgtests fail.
2017-12-02 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu2) bionic; urgency=medium
* Drop kdelibs5-plugins depends on katepart as nothing uses this now
2017-12-01 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu1) bionic; urgency=medium
* New upstream release (4.14.38)
* Refresh all patches
* Drop upstream_fix_build_with_cmake_3.9.diff no longer required
2017-08-20 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.34-0ubuntu2) artful; urgency=medium
* We only support x86 and KDE4 is heading for the bin soon, so skip
tests on other archictectures
2017-08-18 - José Manuel Santamaría Lema <panfaust@gmail.com>
kde4libs (4:4.14.34-0ubuntu1) artful; urgency=medium
[ José Manuel Santamaría Lema ]
* New upstream release (4.14.32)
* New upstream release (4.14.33)
* Use the build-needed restriction for testsuite instead of rebuilding
the package in debian/tests/testsuite; this change needs pkg-kde-tools
0.15.24ubuntu2~ or higher
* Add kubuntu_disable_failing_tests.diff
* Update symbols files
* Improve the way the 'testsuite' autopkgtest is executed:
- create HOME directory
- set locale as 'C'
- add tzdata to Depends
* New upstream release (4.14.34)
[ Rik Mills ]
* debian/patches: add upstream_fix_build_with_cmake_3.9.diff to fix
FTBFS with cmake 3.9
* Update symbols from build logs for GCC7
2017-05-13 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.30-0ubuntu2) artful; urgency=medium
* SECURITY UPDATE: Local privilege escalation (LP: #1689759)
- debian/patches/kauth-local-privilege-esc-CVE-2017-8422.patch
- Thanks to Sebastian Krahmer for reporting this issue,
Albert Astals Cid for fixing this issue.
- CVE-2017-8422
2017-03-10 - José Manuel Santamaría Lema <panfaust@gmail.com>
kde4libs (4:4.14.30-0ubuntu1) zesty; urgency=low
[ Darin Miller ]
* New upstream release (4.14.29)
[ José Manuel Santamaría Lema ]
* New upstream release (4.14.30)
* Drop kio-sanitize-url-to-FindProxyForURL.patch, applied upstream.
2017-03-04 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.28-0ubuntu3) zesty; urgency=medium
* SECURITY UPDATE:Information Leak when accessing https when using a
malicious PAC file
- debian/patches/kio-sanitize-url-to-FindProxyForURL.patch
- Thanks to Safebreach Labs researchers Safebreach Labs researchers
Itzik Kotler, Yonatan Fridburg and Amit Klein for reporting this
issue, Albert Astals Cid for fixing this issue.
- No CVE number.
- fixes (LP: #1668871)
2017-02-08 - Clive Johnston <clivejo@kubuntu.org>
kde4libs (4:4.14.28-0ubuntu2) zesty; urgency=medium
* Removing libjasper-dev as per Debian lead
- Closes: 818205 & LP: 1612835

See Also

Package Description
libkdnssd4_4.14.38-0ubuntu3.1_amd64.deb DNS-SD Protocol Library for the KDE Platform
libkemoticons4_4.14.38-0ubuntu3.1_amd64.deb utility classes to deal with emoticon themes
libkf5config-bin-dev_5.44.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt -- binary package
libkf5config-bin_5.44.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5config-data_5.44.0-0ubuntu1.1_all.deb configuration settings framework for Qt
libkf5config-dev_5.44.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5configcore5_5.44.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5configgui5_5.44.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5screen-bin_5.12.8-0ubuntu0.1_amd64.deb library for screen management - helpers
libkf5screen-dev_5.12.8-0ubuntu0.1_amd64.deb library for screen management - development files
libkf5screen7_5.12.8-0ubuntu0.1_amd64.deb library for screen management - shared library
libkf5sysguard-bin_5.12.8-0ubuntu0.1_amd64.deb library for monitoring your system - shared library
libkf5sysguard-data_5.12.8-0ubuntu0.1_all.deb library for monitoring your system - shared library
libkf5sysguard-dev_5.12.8-0ubuntu0.1_amd64.deb library for monitoring your system - development files
libkf5sysguard5-data_5.12.8-0ubuntu0.1_all.deb transitional dummy package
Advertisement
Advertisement