gnome-flashback_3.28.0-1ubuntu1.4_amd64.deb


Advertisement

Description

gnome-flashback - helper application for the GNOME Flashback session

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Universe amd64
Package filename gnome-flashback_3.28.0-1ubuntu1.4_amd64.deb
Package name gnome-flashback
Package version 3.28.0
Package release 1ubuntu1.4
Package architecture amd64
Package type deb
Category universe/gnome
Homepage https://wiki.gnome.org/Projects/GnomeFlashback
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 232.20 KB
Installed size 817.00 KB
This package provides a helper application for the GNOME Flashback
desktop session. This application:
- provides the Logout, Reboot and Shutdown dialogs;
- provides the Sound, Bluetooth and Power tray applets;
- implements screenshot and screencast functionality;
- implements input source switching functionality;
- draws desktop background;
- implements other functionality which was previously handled by
gnome-settings-daemon.

Alternatives

Package Version Architecture Repository
gnome-flashback_3.28.0-1ubuntu1.4_i386.deb 3.28.0 i386 Ubuntu Updates Universe
gnome-flashback_3.28.0-1ubuntu1_i386.deb 3.28.0 i386 Ubuntu Universe
gnome-flashback_3.28.0-1ubuntu1_amd64.deb 3.28.0 amd64 Ubuntu Universe
gnome-flashback - - -

Requires

Name Value
gnome-flashback-common = 3.28.0-1ubuntu1.4
libatk1.0-0 >= 1.12.4
libc6 >= 2.14
libcairo2 >= 1.10.0
libcanberra-gtk3-0 >= 0.25
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.55.2
libgnome-bluetooth13 >= 3.12.0
libgnome-desktop-3-17 >= 3.17.92
libgtk-3-0 >= 3.22.0
libibus-1.0-5 >= 1.5.2
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpolkit-agent-1-0 >= 0.99
libpolkit-gobject-1-0 >= 0.99
libpulse-mainloop-glib0 >= 0.99.1
libpulse0 >= 0.99.1
libupower-glib3 >= 0.99.0
libx11-6 >= 2:1.2.99.901
libx11-xcb1 -
libxcb-randr0 >= 1.1
libxext6 -
libxfixes3 -
libxi6 >= 2:1.2.99.4
libxkbfile1 -
libxrandr2 >= 2:1.5.0

Provides

Name Value
notification-daemon -
polkit-1-auth-agent -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gnome-flashback_3.28.0-1ubuntu1.4_amd64.deb
Source Package gnome-flashback

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnome-flashback deb package:
    # sudo apt-get install gnome-flashback

Files

Path
/usr/bin/gnome-flashback
/usr/share/applications/gnome-flashback-init.desktop
/usr/share/applications/gnome-flashback.desktop
/usr/share/doc/gnome-flashback/changelog.Debian.gz
/usr/share/doc/gnome-flashback/copyright

Changelog

2019-07-23 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.28.0-1ubuntu1.4) bionic; urgency=medium
* Backport two upstream commits to fix ibus indicator flickering
(LP: #1836659).
2018-10-11 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.28.0-1ubuntu1.3) bionic; urgency=medium
* Backport Accessibility Keyboard plugin from upstream, adding support
for sticky keys and other accessibility features (a11y-keyboard.diff;
LP: #1790744).
* This also needs a small fix in Notifications module to correctly close
bubbles on API call (notifications-close-bubble.diff).
2018-09-13 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.28.0-1ubuntu1.2) bionic; urgency=medium
* Backport upstream patch to apply mouse speed and natural scroll
settings also to trackpoints (trackpoint-settings.diff; LP: #1790336).
* Backport upstream patch to implement per-window input sources
(per-window-input-sources.diff; LP: #1769838).
* Bump required metacity version to 1:3.28.0-1ubuntu0.1.
2018-08-31 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.28.0-1ubuntu1.1) bionic; urgency=medium
* Backport upstream patch to make GNOME Flashback respect keyboard
layout order from settings (assign-groups-in-order.diff; LP: #1790170).
2018-03-28 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.28.0-1ubuntu1) bionic; urgency=medium
* Merge with Debian unstable, remaining changes:
- debian/rules:
+ Add an epoch number to gnome-session-flashback package.
- debian/gnome-flashback-common.gsettings-override:
+ Disable some not needed gnome-flashback components.
+ Add the default settings for GNOME Flashback sessions.
- debian/gnome-session-flashback.target:
+ The target file for systemd, based on ubuntu-session.target.
+ Install this file into /usr/lib/systemd/user/ directory.
- debian/control.in:
+ Bump gnome-session-bin dependency to 3.18.1.2-1ubuntu5, to be able
to use run-systemd-session.
+ Add dependencies on dbus-user-session, indicator-common, nautilus
and systemd.
+ Use Ubuntu VCS fields.
- debian/patches/run-systemd-session.diff:
+ Use run-systemd-session script for running the session.
- debian/patches/support-indicator-keyboard.diff:
+ Support “org.gnome.desktop.input-sources current” key, to make
indicator-keyboard working.
* Revert removing nautilus-classic from required components.
Ubuntu 18.04 ships Nautilus 3.26, which still has desktop icons support.
* Update suggestion: gnome-user-guide → gnome-user-docs (LP: #1691867).
2018-03-26 - Dmitry Shachnev <mitya57@debian.org>
gnome-flashback (3.28.0-1) unstable; urgency=medium
* New upstream release.
* Drop gsd-no-a11ykeyboard.diff, included in the new release.
* Update to debhelper compat level 11.
* Drop dependency on nautilus.
2018-03-17 - Dmitry Shachnev <mitya57@debian.org>
gnome-flashback (3.26.0-3) unstable; urgency=medium
[ Jeremy Bicha ]
* Update Vcs fields for migration to https://salsa.debian.org/
[ Dmitry Shachnev ]
* Backport upstream patch to make the GNOME Flashback session work with
gnome-settings-daemon 3.28 (gsd-no-a11ykeyboard.diff).
* Bump Standards-Version to 4.1.3, no changes needed.
2017-10-15 - Dmitry Shachnev <mitya57@debian.org>
gnome-flashback (3.26.0-2) unstable; urgency=medium
* Upload to unstable.
2018-03-07 - Dmitry Shachnev <mitya57@ubuntu.com>
gnome-flashback (3.26.0-1ubuntu3) bionic; urgency=medium
* Backport upstream patch to fix login with g-s-d 3.28 (LP: #1753807).
2018-02-15 - Jeremy Bicha <jbicha@ubuntu.com>
gnome-flashback (3.26.0-1ubuntu2) bionic; urgency=medium
* No-change rebuild against latest gnome-desktop3

See Also

Package Description
gnome-games-app_3.28.0-1ubuntu1_amd64.deb Game browser and launcher for GNOME
gnome-packagekit-session_3.28.1-0ubuntu4.18.04.14_all.deb Transitional package (gnome-packagekit-session -> gnome-software)
gnome-panel-control_3.6.1-7ubuntu0.1_amd64.deb command line utility to invoke GNOME panel run dialog/menu
gnome-session-flashback_3.28.0-1ubuntu1.4_all.deb GNOME Session Manager - GNOME Flashback session
gnome-session-wayland_3.28.1-0ubuntu3_all.deb GNOME Session Manager - GNOME 3 session (transitional package)
gnome-session_3.28.1-0ubuntu3_amd64.deb GNOME Session Manager - GNOME 3 session
gnome-shell-extension-system-monitor_35-1ubuntu0.18.04.1_all.deb Display system information in GNOME Shell status bar
gnome-software-plugin-flatpak_3.28.1-0ubuntu4.18.04.14_amd64.deb Flatpak support for GNOME Software
gnome-software-plugin-limba_3.28.1-0ubuntu4.18.04.14_amd64.deb Limba support for GNOME Software
gnome-split_1.2-2build0.1_all.deb GNOME Split - File splitter for GNOME desktop
gnome-twitch-player-backend-gstreamer-cairo_0.4.1-2ubuntu0.18.04.1_amd64.deb Player backend for GNOME Twitch based on gstreamer+cairo
gnome-twitch-player-backend-gstreamer-clutter_0.4.1-2ubuntu0.18.04.1_amd64.deb Player backend for GNOME Twitch based on gstreamer+clutter
gnome-twitch-player-backend-gstreamer-opengl_0.4.1-2ubuntu0.18.04.1_amd64.deb Player backend for GNOME Twitch based on gstreamer+opengl
gnome-twitch-player-backend-mpv-opengl_0.4.1-2ubuntu0.18.04.1_amd64.deb Player backend for GNOME Twitch based on mpv
gnome-twitch_0.4.1-2ubuntu0.18.04.1_amd64.deb GNOME Twitch app for watching Twitch.tv streams without a browser or flash
Advertisement
Advertisement