squashfs-tools_4.3-6ubuntu0.18.04.1_i386.deb


Advertisement

Description

squashfs-tools - Tool to create and append to squashfs filesystems

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename squashfs-tools_4.3-6ubuntu0.18.04.1_i386.deb
Package name squashfs-tools
Package version 4.3
Package release 6ubuntu0.18.04.1
Package architecture i386
Package type deb
Category admin
Homepage http://squashfs.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 119.55 KB
Installed size 339.00 KB
Squashfs is a highly compressed read-only filesystem for Linux. It uses zlib
compression to compress both files, inodes and directories. Inodes in the
system are very small and all blocks are packed to minimise data overhead.
Block sizes greater than 4K are supported up to a maximum of 64K.
Squashfs is intended for general read-only filesystem use, for archival use
(i.e. in cases where a .tar.gz file may be used), and in constrained block
device/memory systems (e.g. embedded systems) where low overhead is needed.

Alternatives

Package Version Architecture Repository
squashfs-tools_4.3-6ubuntu0.18.04.1_amd64.deb 4.3 amd64 Ubuntu Updates Main
squashfs-tools_4.3-6_amd64.deb 4.3 amd64 Ubuntu Main
squashfs-tools_4.3-6_i386.deb 4.3 i386 Ubuntu Main
squashfs-tools - - -

Requires

Name Value
libc6 >= 2.8
liblz4-1 >= 0.0~r113
liblzma5 >= 5.1.1alpha+20120614
liblzo2-2 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package squashfs-tools_4.3-6ubuntu0.18.04.1_i386.deb
Source Package squashfs-tools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install squashfs-tools deb package:
    # sudo apt-get install squashfs-tools

Files

Path
/usr/bin/mksquashfs
/usr/bin/unsquashfs
/usr/share/doc/squashfs-tools/changelog.Debian.gz
/usr/share/doc/squashfs-tools/copyright
/usr/share/man/man1/mksquashfs.1.gz
/usr/share/man/man1/unsquashfs.1.gz

Changelog

2018-07-05 - Jamie Strandboge <jamie@ubuntu.com>
squashfs-tools (1:4.3-6ubuntu0.18.04.1) bionic; urgency=medium
* debian/patches/0010-use-macros-not-raw-octal-with-chmod.patch,
debian/patches/0011-also-set-stickybit-as-non-root.patch: apply stickybit
when run as non-root (LP: #1779914). Patches thanks to Tyler Hicks.
2018-03-11 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-6) unstable; urgency=medium
* Sync with Ubuntu.
[ Michael Vogt <michael.vogt@ubuntu.com> ]
* debian/patches/0005-add-fstime.patch: initializing the time_t variable
with (time_t)0 instead of (time_t)-1 to avoid creating all filesystems
on "Wed Dec 31 23:59:59 1969"
2018-03-04 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-5) unstable; urgency=medium
* Patch unsquashfs to preserve file capabilities (closes: #804194).
* Update debhelper level to 11:
- don't specify parallel to debhelper.
* Update Standards-Version to 4.1.3:
- remove squashfs-tools-dbg package and use the auto-generated one.
* Sync with Ubuntu.
[ Tyler Hicks <tyhicks@canonical.com> ]
* debian/patches/0005-add-fstime.patch: Fix -Wint-conversion warning by
initializing the time_t variable with (time_t)-1 instead of NULL
* debian/patches/0009-unsquashfs-preserve-symlink-times.patch: Preserve
atime and mtime of symlink inodes in unsquashfs rather than using the
current time (LP: #1555305)
2017-06-07 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-4) unstable; urgency=medium
* Backport patch to fix rare race in fragment waiting in filesystem
finalisation.
* Backport fix for 2GB-limit of the is_fragment(...) function
(closes: #788185).
2015-10-20 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-3) unstable; urgency=low
* Use patch from upstream BTS to support LZMA magics (closes: #802446).
2015-09-07 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-2) unstable; urgency=high
* Fix security issues:
- CVE-2015-4645 - stack overflow in read_fragment_table_4
(closes: #793467),
- CVE-2015-4646 - stack overflow in read_fragment_table_4 due to fix for
CVE-2015-4645 (closes: #793468).
* Fix phys mem calculation for 32-bit processes on PAE/64-bit kernels
(closes: #798268).
* Build with XZ Utils liblzma (closes: #754234, #749878).
* Update 0001-kfreebsd.patch to fix kFreeBSD FTBFS.
2015-09-06 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.3-1) unstable; urgency=low
* New upstream release.
* Build with LZ4 support.
* Put myself as the primary maintainer.
* Update Standards-Version to 3.9.6 .
2015-08-03 - gregor herrmann <gregoa@debian.org>
squashfs-tools (1:4.2+20130409-2.1) unstable; urgency=medium
* NMU.
* Apply changes from -2ubuntu1:
[ Matthias Klose ]
* Build using dpkg-buildflags.
* Remove the ARM workaround.
* Build with -fgnu89-inline.
Closes: #780206
2013-09-18 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
squashfs-tools (1:4.2+20130409-2) unstable; urgency=low
* New maintainer (closes: #723600).
* Minor packaging changes.
2013-05-09 - Luk Claes <luk@debian.org>
squashfs-tools (1:4.2+20130409-1) unstable; urgency=low
* Merging upstream version 4.2+20130409.

See Also

Package Description
squid-common_3.5.27-1ubuntu1.1_all.deb Full featured Web Proxy cache (HTTP proxy) - common files
squid3_3.5.27-1ubuntu1.1_all.deb Transitional package
squid_3.5.27-1ubuntu1.1_i386.deb Full featured Web Proxy cache (HTTP proxy)
ss-dev_2.0-1.44.1-1ubuntu1.1_i386.deb command-line interface parsing library - headers and static libraries
ssh-import-id_5.7-0ubuntu1.1_all.deb securely retrieve an SSH public key and install it locally
ssh_7.6p1-4ubuntu0.3_all.deb secure shell client and server (metapackage)
sssd-ad-common_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- PAC responder
sssd-ad_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- Active Directory back end
sssd-common_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- common files
sssd-dbus_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- D-Bus responder
sssd-ipa_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- IPA back end
sssd-krb5-common_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- Kerberos helpers
sssd-krb5_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- Kerberos back end
sssd-ldap_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- LDAP back end
sssd-proxy_1.16.1-1ubuntu1.2_i386.deb System Security Services Daemon -- proxy back end
Advertisement
Advertisement