python3-tk_3.6.8-1~18.04_i386.deb


Advertisement

Description

python3-tk - Tkinter - Writing Tk applications with Python 3.x

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename python3-tk_3.6.8-1~18.04_i386.deb
Package name python3-tk
Package version 3.6.8
Package release 1~18.04
Package architecture i386
Package type deb
Category python
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.30 KB
Installed size 858.00 KB
A module for writing portable GUI applications with Python 3.x using Tk.
Also known as Tkinter.

Alternatives

Package Version Architecture Repository
python3-tk_3.6.8-1~18.04_amd64.deb 3.6.8 amd64 Ubuntu Updates Main
python3-tk_3.6.5-3_i386.deb 3.6.5 i386 Ubuntu Main
python3-tk_3.6.5-3_amd64.deb 3.6.5 amd64 Ubuntu Main
python3-tk - - -

Requires

Name Value
blt >= 2.4z-9
libc6 >= 2.4
libtcl8.6 >= 8.6.0
libtk8.6 >= 8.6.0
python3 >= 3.6.6-1~
python3 << 3.8
tk8.6-blt2.5 >= 2.5.3

Provides

Name Value
python3.6-tk -
python3.7-tk -

Replaces

Name Value
libpython3.6-stdlib << 3.6.4~rc1-2
libpython3.7-stdlib << 3.7.0~a3-2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-tk_3.6.8-1~18.04_i386.deb
Source Package python3-stdlib-extensions

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-tk deb package:
    # sudo apt-get install python3-tk

Files

Path
/usr/lib/python3.6/lib-dynload/_tkinter.cpython-36m-i386-linux-gnu.so
/usr/lib/python3.6/tkinter/__init__.py
/usr/lib/python3.6/tkinter/__main__.py
/usr/lib/python3.6/tkinter/colorchooser.py
/usr/lib/python3.6/tkinter/commondialog.py
/usr/lib/python3.6/tkinter/constants.py
/usr/lib/python3.6/tkinter/dialog.py
/usr/lib/python3.6/tkinter/dnd.py
/usr/lib/python3.6/tkinter/filedialog.py
/usr/lib/python3.6/tkinter/font.py
/usr/lib/python3.6/tkinter/messagebox.py
/usr/lib/python3.6/tkinter/scrolledtext.py
/usr/lib/python3.6/tkinter/simpledialog.py
/usr/lib/python3.6/tkinter/tix.py
/usr/lib/python3.6/tkinter/ttk.py
/usr/lib/python3.7/lib-dynload/_tkinter.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/tkinter/__init__.py
/usr/lib/python3.7/tkinter/__main__.py
/usr/lib/python3.7/tkinter/colorchooser.py
/usr/lib/python3.7/tkinter/commondialog.py
/usr/lib/python3.7/tkinter/constants.py
/usr/lib/python3.7/tkinter/dialog.py
/usr/lib/python3.7/tkinter/dnd.py
/usr/lib/python3.7/tkinter/filedialog.py
/usr/lib/python3.7/tkinter/font.py
/usr/lib/python3.7/tkinter/messagebox.py
/usr/lib/python3.7/tkinter/scrolledtext.py
/usr/lib/python3.7/tkinter/simpledialog.py
/usr/lib/python3.7/tkinter/tix.py
/usr/lib/python3.7/tkinter/ttk.py
/usr/share/doc/python3-tk/README.Debian
/usr/share/doc/python3-tk/README.Tk
/usr/share/doc/python3-tk/changelog.Debian.gz
/usr/share/doc/python3-tk/copyright
/usr/share/lintian/overrides/python3-tk

Changelog

2019-04-09 - Matthias Klose <doko@ubuntu.com>
python3-stdlib-extensions (3.6.8-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1822993.
* Update 3.6 extensions and modules to 3.6.8.
* Update 3.7 extensions and modules to 3.7.3.
2018-10-22 - Matthias Klose <doko@ubuntu.com>
python3-stdlib-extensions (3.6.7-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1799202.
* Update 3.6 extensions and modules to 3.6.7.
* Update 3.7 extensions and modules to 3.7.1.
2018-06-27 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.6-1) unstable; urgency=medium
* Update 3.6 extensions and modules to 3.6.6.
* Update 3.7 extensions and modules to 3.7.0.
2018-06-16 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.6~rc1-3) unstable; urgency=medium
* Don't ship generated files. Closes: #901637.
2018-06-14 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.6~rc1-2) unstable; urgency=medium
* Use the distutils package from the source for the build.
2018-06-14 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.6~rc1-1) unstable; urgency=medium
* Update 3.6 extensions and modules to 3.6.6~rc1.
* Update 3.7 extensions and modules to 3.7.0~rc1.
* Avoid build dependencies on packages built from python3-defaults.
Addresses: #900535.
* Add Vcs attributes.
2018-06-06 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.5-4) unstable; urgency=medium
* Update 3.7 extensions and modules to 3.7.0~b5.
2018-04-04 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.5-3) unstable; urgency=medium
* Fix again the package removals (Simon McVittie). Closes: #894685.
2018-03-30 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.5-2) unstable; urgency=medium
* Re-Add the 3.6.5~rc1-2 and 3.6.5~rc1-3 uploads. Closes: #894456.
2018-03-30 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.6.5-1) unstable; urgency=medium
* Update 3.6 extensions to the 3.6.5 release.
* Update 3.7 extensions and modules to 3.7.0~b3.

See Also

Package Description
python3-ubuntu-image_1.7+18.04ubuntu1_all.deb toolkit for building Ubuntu images
python3-uno_6.0.7-0ubuntu0.18.04.10_i386.deb Python-UNO bridge
python3-update-manager_18.04.11.10_all.deb python 3.x module for update-manager
python3-urllib3_1.22-1ubuntu0.18.04.1_all.deb HTTP library with thread-safe connection pooling for Python3
python3-uvloop_0.8.1+ds1-1ubuntu0.1_i386.deb fast implementation of asyncio event loop on top of libuv
python3-wadllib_1.3.2-3ubuntu0.18.04.1_all.deb Python 3 library for navigating WADL files
python3.6-dev_3.6.8-1~18.04.3_i386.deb Header files and a static library for Python (v3.6)
python3.6-doc_3.6.8-1~18.04.3_all.deb Documentation for the high-level object-oriented language Python (v3.6)
python3.6-examples_3.6.8-1~18.04.3_all.deb Examples for the Python language (v3.6)
python3.6-minimal_3.6.8-1~18.04.3_i386.deb Minimal subset of the Python language (version 3.6)
python3.6_3.6.8-1~18.04.3_i386.deb Interactive high-level object-oriented language (version 3.6)
python3_3.6.7-1~18.04_i386.deb interactive high-level object-oriented language (default python3 version)
qemu-block-extra_2.11+dfsg-1ubuntu7.19_i386.deb extra block backend modules for qemu-system and qemu-utils
qemu-kvm_2.11+dfsg-1ubuntu7.19_i386.deb QEMU Full virtualization on x86 hardware
qemu-system-arm_2.11+dfsg-1ubuntu7.19_i386.deb QEMU full system emulation binaries (arm)
Advertisement
Advertisement