python-tk_2.7.16-2~18.04_i386.deb


Advertisement

Description

python-tk - Tkinter - Writing Tk applications with Python2

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename python-tk_2.7.16-2~18.04_i386.deb
Package name python-tk
Package version 2.7.16
Package release 2~18.04
Package architecture i386
Package type deb
Category python
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 26.59 KB
Installed size 92.00 KB
A module for writing portable GUI applications with Python2 using Tk.
Also known as Tkinter.

Alternatives

Package Version Architecture Repository
python-tk_2.7.16-2~18.04_amd64.deb 2.7.16 amd64 Ubuntu Updates Main
python-tk_2.7.15~rc1-1_i386.deb 2.7.15~rc1 i386 Ubuntu Main
python-tk_2.7.15~rc1-1_amd64.deb 2.7.15~rc1 amd64 Ubuntu Main
python-tk - - -

Requires

Name Value
blt >= 2.4z-9
libc6 >= 2.4
libtcl8.6 >= 8.6.0
libtk8.6 >= 8.6.0
python >= 2.7
python << 2.8
tk8.6-blt2.5 >= 2.5.3

Provides

Name Value
python2.7-tk -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-tk_2.7.16-2~18.04_i386.deb
Source Package python-stdlib-extensions

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-tk deb package:
    # sudo apt-get install python-tk

Changelog

2019-04-09 - Matthias Klose <doko@ubuntu.com>
python-stdlib-extensions (2.7.16-2~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1822993.
2019-03-18 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.16-2) unstable; urgency=medium
* Re-pack the orig tarball without the VCS repo.
2019-03-04 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.16-1) unstable; urgency=medium
* Python 2.7.16 release.
2019-02-22 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.16~rc1-1) unstable; urgency=medium
* Python 2.7.16 release candidate.
* Bump standards version.
* Fix FTCBFS (Helmut Grohne). Closes: #913417.
+ Multiarchify Build-Depends.
+ Set up PYTHONPATH for cross compilation.
+ cross.patch: Don't import built modules.
2018-05-02 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.15-1) unstable; urgency=medium
* Python 2.7.15 release.
2018-04-16 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.15~rc1-1) unstable; urgency=medium
* Python 2.7.15 release candidate 1.
2018-04-02 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.14-3) unstable; urgency=medium
* Update from the 2.7 branch.
2018-02-01 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.14-2) unstable; urgency=medium
* Bump standards version, do the extra/optional dance.
2017-09-17 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.14-1) unstable; urgency=medium
* Python 2.7.14 release.
* Bump standards version.
2017-09-05 - Matthias Klose <doko@debian.org>
python-stdlib-extensions (2.7.14~rc1-1) unstable; urgency=medium
* Python 2.7.14 release candidate 1.

See Also

Package Description
python-urllib3_1.22-1ubuntu0.18.04.1_all.deb HTTP library with thread-safe connection pooling for Python
python-wadllib_1.3.2-3ubuntu0.18.04.1_all.deb Python library for navigating WADL files
python-wsme_0.9.2-0ubuntu2.18.04.1_all.deb Web Services Made Easy: implement multi-protocol webservices - Python 2.x
python2.7-dev_2.7.15-4ubuntu4~18.04.2_i386.deb Header files and a static library for Python (v2.7)
python2.7-doc_2.7.15-4ubuntu4~18.04.2_all.deb Documentation for the high-level object-oriented language Python (v2.7)
python2.7-examples_2.7.15-4ubuntu4~18.04.2_all.deb Examples for the Python language (v2.7)
python2.7-minimal_2.7.15-4ubuntu4~18.04.2_i386.deb Minimal subset of the Python language (version 2.7)
python2.7_2.7.15-4ubuntu4~18.04.2_i386.deb Interactive high-level object-oriented language (version 2.7)
python3-all-dev_3.6.7-1~18.04_i386.deb package depending on all supported Python 3 development packages
python3-all_3.6.7-1~18.04_i386.deb package depending on all supported Python 3 runtime versions
python3-apparmor_2.12-4ubuntu5.1_i386.deb AppArmor Python3 utility library
python3-apport_2.20.9-0ubuntu7.7_all.deb Python 3 library for Apport crash report handling
python3-apt_1.6.4_i386.deb Python 3 interface to libapt-pkg
python3-aptdaemon.gtk3widgets_1.1.1+bzr982-0ubuntu19.1_all.deb Python 3 GTK+ 3 widgets to run an aptdaemon client
python3-aptdaemon_1.1.1+bzr982-0ubuntu19.1_all.deb Python 3 module for the server and client of aptdaemon
Advertisement
Advertisement