poppler-utils_0.62.0-2ubuntu2.10_i386.deb


Advertisement

Description

poppler-utils - PDF utilities (based on Poppler)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename poppler-utils_0.62.0-2ubuntu2.10_i386.deb
Package name poppler-utils
Package version 0.62.0
Package release 2ubuntu2.10
Package architecture i386
Package type deb
Category utils
Homepage http://poppler.freedesktop.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 154.81 KB
Installed size 543.00 KB
Poppler is a PDF rendering library based on Xpdf PDF viewer.
This package contains command line utilities (based on Poppler) for getting
information of PDF documents, convert them to other formats, or manipulate
them:
* pdfdetach -- lists or extracts embedded files (attachments)
* pdffonts -- font analyzer
* pdfimages -- image extractor
* pdfinfo -- document information
* pdfseparate -- page extraction tool
* pdfsig -- verifies digital signatures
* pdftocairo -- PDF to PNG/JPEG/PDF/PS/EPS/SVG converter using Cairo
* pdftohtml -- PDF to HTML converter
* pdftoppm -- PDF to PPM/PNG/JPEG image converter
* pdftops -- PDF to PostScript (PS) converter
* pdftotext -- text extraction
* pdfunite -- document merging tool

Alternatives

Package Version Architecture Repository
poppler-utils_0.62.0-2ubuntu2.10_amd64.deb 0.62.0 amd64 Ubuntu Updates Main
poppler-utils_0.62.0-2ubuntu2_i386.deb 0.62.0 i386 Ubuntu Main
poppler-utils_0.62.0-2ubuntu2_amd64.deb 0.62.0 amd64 Ubuntu Main
poppler-utils - - -

Requires

Name Value
libc6 >= 2.4
libcairo2 >= 1.12.0
libfreetype6 >= 2.2.1
libgcc1 >= 1:4.2
liblcms2-2 >= 2.2+git20110628
libpoppler73 = 0.62.0-2ubuntu2.10
libstdc++6 >= 5.2

Provides

Name Value
pdftohtml -
xpdf-utils -

Conflicts

Name Value
pdftohtml -

Replaces

Name Value
pdftohtml -
xpdf-reader -
xpdf-utils << 3.02-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package poppler-utils_0.62.0-2ubuntu2.10_i386.deb
Source Package poppler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install poppler-utils deb package:
    # sudo apt-get install poppler-utils

Files

Path
/usr/bin/pdfdetach
/usr/bin/pdffonts
/usr/bin/pdfimages
/usr/bin/pdfinfo
/usr/bin/pdfseparate
/usr/bin/pdfsig
/usr/bin/pdftocairo
/usr/bin/pdftohtml
/usr/bin/pdftoppm
/usr/bin/pdftops
/usr/bin/pdftotext
/usr/bin/pdfunite
/usr/share/doc/poppler-utils/changelog.Debian.gz
/usr/share/doc/poppler-utils/copyright
/usr/share/lintian/overrides/poppler-utils
/usr/share/man/man1/pdfdetach.1.gz
/usr/share/man/man1/pdffonts.1.gz
/usr/share/man/man1/pdfimages.1.gz
/usr/share/man/man1/pdfinfo.1.gz
/usr/share/man/man1/pdfseparate.1.gz
/usr/share/man/man1/pdfsig.1.gz
/usr/share/man/man1/pdftocairo.1.gz
/usr/share/man/man1/pdftohtml.1.gz
/usr/share/man/man1/pdftoppm.1.gz
/usr/share/man/man1/pdftops.1.gz
/usr/share/man/man1/pdftotext.1.gz
/usr/share/man/man1/pdfunite.1.gz

Changelog

2019-08-07 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.10) bionic-security; urgency=medium
* SECURITY UPDATE: Divide-by-zero error
- debian/patches/CVE-2019-14494.patch: Fix crash on broken file
in poppler/SplashOutputDev.cc.
- CVE-2019-14494
2019-06-26 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
poppler (0.62.0-2ubuntu2.9) bionic-security; urgency=medium
* SECURITY UPDATE: memory leak in GfxColorSpace::setDisplayProfile
- debian/patches/CVE-2018-18897.patch: enforcing single initialization
in poppler/GfxState.cc, qt5/src/poppler-qt5.h.
- CVE-2018-18897
* SECURITY UPDATE: DoS via crafted PDF file
- debian/patches/CVE-2018-20662.patch: check XRef's Catalog for being a
Dict in utils/pdfunite.cc.
- CVE-2018-20662
* SECURITY UPDATE: buffer over-read in downsample_row_box_filter
- debian/patches/CVE-2019-9631-1.patch: compute correct coverage values
for box filter in poppler/CairoRescaleBox.cc.
- debian/patches/CVE-2019-9631-2.patch: constrain number of cycles in
rescale filter in poppler/CairoRescaleBox.cc.
- CVE-2019-9631
* SECURITY UPDATE: dict marking mishandling
- debian/patches/CVE-2019-9903.patch: fix stack overflow on broken file
in poppler/PDFDoc.cc.
- CVE-2019-9903
* SECURITY UPDATE: heap-based buffer over-read
- debian/patches/CVE-2019-10872.patch: restrict filling of overlapping
boxes in splash/Splash.cc.
- CVE-2019-10872
* SECURITY UPDATE: buffer over-read in JPXStream::init
- debian/patches/CVE-2019-12293.patch: fail gracefully if not all
components have the same WxH in poppler/JPEG2000Stream.cc.
- CVE-2019-12293
2019-02-28 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.8) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2019-9200.patch: fix in
poppler/Stream.cc.
- CVE-2019-9200
2019-02-08 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.7) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-20551.patch: fix in
poppler/Annot.cc.
- CVE-2018-20551
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2019-7310.patch: fix in
poppler/XRef.cc.
- CVE-2019-7310
2019-01-21 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.6) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-20481.patch: fix in
poppler/XRef.cc.
- CVE-2018-20481
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-20650.patch: fix in
poppler/FileSpec.cc.
- CVE-2018-20650
2018-12-10 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.5) bionic-security; urgency=medium
* SECURITY REGRESSION: fixing regression in check entry
- debian/patches/CVE-2018-16646-fix-regression-p1.patch
- debian/patches/CVE-2018-16646-fix-regression-p2.patch
2018-11-30 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.62.0-2ubuntu2.4) bionic-security; urgency=medium
[ Marc Deslauriers ]
* SECURITY UPDATE: infinite recursion via crafted file
- debian/patches/CVE-2018-16646.patch: avoid cycles in PDF parsing in
poppler/Parser.cc, poppler/XRef.h.
- CVE-2018-16646
* SECURITY UPDATE: denial of service via reachable abort
- debian/patches/CVE-2018-19058.patch: check for stream before calling
stream methods when saving an embedded file in poppler/FileSpec.cc.
- CVE-2018-19058
* SECURITY UPDATE: denial of service via out-of-bounds read
- debian/patches/CVE-2018-19059.patch: check for valid embedded file
before trying to save it in utils/pdfdetach.cc.
- CVE-2018-19059
* SECURITY UPDATE: denial of service via NULL pointer dereference
- debian/patches/CVE-2018-19060.patch: check for valid file name of
embedded file in utils/pdfdetach.cc.
- CVE-2018-19060

See Also

Package Description
postfix-cdb_3.3.0-1ubuntu0.2_i386.deb CDB map support for Postfix
postfix-doc_3.3.0-1ubuntu0.2_all.deb Documentation for Postfix
postfix-ldap_3.3.0-1ubuntu0.2_i386.deb LDAP map support for Postfix
postfix-mysql_3.3.0-1ubuntu0.2_i386.deb MySQL map support for Postfix
postfix-pcre_3.3.0-1ubuntu0.2_i386.deb PCRE map support for Postfix
postfix-pgsql_3.3.0-1ubuntu0.2_i386.deb PostgreSQL map support for Postfix
postfix_3.3.0-1ubuntu0.2_i386.deb High-performance mail transport agent
postgresql-10_10.10-0ubuntu0.18.04.1_i386.deb object-relational SQL database, version 10 server
postgresql-client-10_10.10-0ubuntu0.18.04.1_i386.deb front-end programs for PostgreSQL 10
postgresql-doc-10_10.10-0ubuntu0.18.04.1_all.deb documentation for the PostgreSQL database management system
postgresql-plperl-10_10.10-0ubuntu0.18.04.1_i386.deb PL/Perl procedural language for PostgreSQL 10
postgresql-plpython-10_10.10-0ubuntu0.18.04.1_i386.deb PL/Python procedural language for PostgreSQL 10
postgresql-plpython3-10_10.10-0ubuntu0.18.04.1_i386.deb PL/Python 3 procedural language for PostgreSQL 10
postgresql-pltcl-10_10.10-0ubuntu0.18.04.1_i386.deb PL/Tcl procedural language for PostgreSQL 10
ppp-dev_2.4.7-2+2ubuntu1.1_all.deb Point-to-Point Protocol (PPP) - development files
Advertisement
Advertisement