linux-tools-4.18.0-22-generic_4.18.0-22.23~18.04.1_i386.deb


Advertisement

Description

linux-tools-4.18.0-22-generic - Linux kernel version specific tools for version 4.18.0-22

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename linux-tools-4.18.0-22-generic_4.18.0-22.23~18.04.1_i386.deb
Package name linux-tools-4.18.0-22-generic
Package version 4.18.0
Package release 22.23~18.04.1
Package architecture i386
Package type deb
Category devel
Homepage -
License -
Maintainer Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Download size 1.91 KB
Installed size 146.00 KB
This package provides the architecture dependant parts for kernel
version locked tools (such as perf and x86_energy_perf_policy) for
version 4.18.0-22 on
32 bit x86.

Alternatives

Package Version Architecture Repository
linux-tools-4.18.0-22-generic_4.18.0-22.23~18.04.1_amd64.deb 4.18.0 amd64 Ubuntu Updates Main
linux-tools-4.18.0-22-generic - - -

Requires

Name Value
linux-hwe-tools-4.18.0-22 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package linux-tools-4.18.0-22-generic_4.18.0-22.23~18.04.1_i386.deb
Source Package linux-hwe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linux-tools-4.18.0-22-generic deb package:
    # sudo apt-get install linux-tools-4.18.0-22-generic

Changelog

2019-06-06 - Stefan Bader <stefan.bader@canonical.com>
linux-hwe (4.18.0-22.23~18.04.1) bionic; urgency=medium
[ Ubuntu: 4.18.0-22.23 ]
* Remote denial of service (resource exhaustion) caused by TCP SACK scoreboard
manipulation (LP: #1831638)
- SAUCE: tcp: tcp_fragment() should apply sane memory limits
* Remote denial of service (system crash) caused by integer overflow in TCP
SACK handling (LP: #1831637)
- SAUCE: tcp: limit payload size of sacked skbs
2019-05-16 - Stefan Bader <stefan.bader@canonical.com>
linux-hwe (4.18.0-21.22~18.04.1) bionic; urgency=medium
* linux-hwe: 4.18.0-21.22~18.04.1 -proposed tracker (LP: #1829185)
[ Ubuntu: 4.18.0-21.22 ]
* linux: 4.18.0-21.22 -proposed tracker (LP: #1829186)
* disable a.out support (LP: #1818552)
- [Config] Turn off a.out support
* ftrace in ubuntu_kernel_selftests hang with Cosmic kernel (LP: #1826385)
- kprobes/x86: Fix instruction patching corruption when copying more than one
RIP-relative instruction
* touchpad not working on lenovo yoga 530 (LP: #1787775)
- Revert "UBUNTU: SAUCE: i2c:amd Depends on ACPI"
- Revert "UBUNTU: SAUCE: i2c:amd move out pointer in union i2c_event_base"
- Revert "UBUNTU: SAUCE: i2c:amd I2C Driver based on PCI Interface for
upcoming platform"
- i2c: add extra check to safe DMA buffer helper
- i2c: Add drivers for the AMD PCIe MP2 I2C controller
- [Config] Update config for AMD MP2 I2C driver
- [Config] Update I2C_AMD_MP2 annotations
* Geneve tunnels don't work when ipv6 is disabled (LP: #1794232)
- geneve: correctly handle ipv6.disable module parameter
* There are 4 HDMI/Displayport audio output listed in sound setting without
attach any HDMI/DP monitor (LP: #1827967)
- ALSA: hda/hdmi - Read the pin sense from register when repolling
- ALSA: hda/hdmi - Consider eld_valid when reporting jack event
* Headphone jack switch sense is inverted: plugging in headphones disables
headphone output (LP: #1824259)
- ASoC: rt5645: Headphone Jack sense inverts on the LattePanda board
* CTAUTO:DevOps:860.50:devops4fp1:Error occurred during LINUX Dmesg error
Checking for all LINUX clients for devops4p10 (LP: #1766201)
- SAUCE: integrity: downgrade error to warning
* potential memory corruption on arm64 on dev release (LP: #1827437)
- driver core: Postpone DMA tear-down until after devres release
* powerpc/pmu/ebb test in ubuntu_kernel_selftest failed with "error while
loading shared libraries" on Bionic/Cosmic PowerPC (LP: #1812805)
- selftests/powerpc/pmu: Link ebb tests with -no-pie
* unnecessary request_queue freeze (LP: #1815733)
- block: avoid setting nr_requests to current value
- block: avoid setting none scheduler if it's already none
* Kprobe event string type argument failed in ftrace from
ubuntu_kernel_selftests on B/C i386 (LP: #1825780)
- selftests/ftrace: Fix kprobe string testcase to not probe notrace function
* False positive test result in run_netsocktests from net in
ubuntu_kernel_selftest (LP: #1825777)
- selftests/net: correct the return value for run_netsocktests

See Also

Package Description
linux-tools-4.18.0-22-lowlatency_4.18.0-22.23~18.04.1_i386.deb Linux kernel version specific tools for version 4.18.0-22
linux-tools-4.18.0-24-generic_4.18.0-24.25~18.04.1_i386.deb Linux kernel version specific tools for version 4.18.0-24
linux-tools-4.18.0-24-lowlatency_4.18.0-24.25~18.04.1_i386.deb Linux kernel version specific tools for version 4.18.0-24
linux-tools-4.18.0-25-generic_4.18.0-25.26~18.04.1_i386.deb Linux kernel version specific tools for version 4.18.0-25
linux-tools-4.18.0-25-lowlatency_4.18.0-25.26~18.04.1_i386.deb Linux kernel version specific tools for version 4.18.0-25
linux-tools-5.0.0-15-generic_5.0.0-15.16~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-15
linux-tools-5.0.0-15-lowlatency_5.0.0-15.16~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-15
linux-tools-5.0.0-16-generic_5.0.0-16.17~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-16
linux-tools-5.0.0-16-lowlatency_5.0.0-16.17~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-16
linux-tools-5.0.0-17-generic_5.0.0-17.18~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-17
linux-tools-5.0.0-17-lowlatency_5.0.0-17.18~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-17
linux-tools-5.0.0-19-generic_5.0.0-19.20~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-19
linux-tools-5.0.0-19-lowlatency_5.0.0-19.20~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-19
linux-tools-5.0.0-20-generic_5.0.0-20.21~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-20
linux-tools-5.0.0-20-lowlatency_5.0.0-20.21~18.04.1_i386.deb Linux kernel version specific tools for version 5.0.0-20
Advertisement
Advertisement