libgd3_2.2.5-4ubuntu0.3_i386.deb


Advertisement

Description

libgd3 - GD Graphics Library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename libgd3_2.2.5-4ubuntu0.3_i386.deb
Package name libgd3
Package version 2.2.5
Package release 4ubuntu0.3
Package architecture i386
Package type deb
Category libs
Homepage http://www.libgd.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 119.77 KB
Installed size 445.00 KB
GD is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colours, cut and paste from
other images, flood fills, and write out the result as a PNG file.
This is particularly useful in World Wide Web applications, where PNG is
one of the formats accepted for inline images by most browsers.
This is the runtime package of the library.

Alternatives

Package Version Architecture Repository
libgd3_2.2.5-4ubuntu0.3_amd64.deb 2.2.5 amd64 Ubuntu Updates Main
libgd3_2.2.5-4_amd64.deb 2.2.5 amd64 Ubuntu Main
libgd3_2.2.5-4_i386.deb 2.2.5 i386 Ubuntu Main
libgd3 - - -

Requires

Name Value
libc6 >= 2.11
libfontconfig1 >= 2.12
libfreetype6 >= 2.2.1
libjpeg8 >= 8c
libpng16-16 >= 1.6.2-1
libtiff5 >= 4.0.3
libwebp6 >= 0.5.1
libxpm4 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgd3_2.2.5-4ubuntu0.3_i386.deb
Source Package libgd2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgd3 deb package:
    # sudo apt-get install libgd3

Files

Path
/usr/lib/i386-linux-gnu/libgd.so.3
/usr/lib/i386-linux-gnu/libgd.so.3.0.5
/usr/share/doc/libgd3/changelog.Debian.gz
/usr/share/doc/libgd3/copyright
/usr/share/lintian/overrides/libgd3

Changelog

2019-02-27 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libgd2 (2.2.5-4ubuntu0.3) bionic-security; urgency=medium
* SECURITY UPDATE: buffer overflow in gdImageColorMatch
- debian/patches/CVE-2019-6977.patch: use gdMaxColors in
src/gd_color_match.c.
- CVE-2019-6977
* SECURITY UPDATE: double-free in gdImage*Ptr() functions
- debian/patches/CVE-2019-6978.patch: properly handle failure in
src/gd_gif_out.c, src/gd_jpeg.c, src/gd_wbmp.c, add test to
tests/jpeg/CMakeLists.txt, tests/jpeg/Makemodule.am,
tests/jpeg/jpeg_ptr_double_free.c.
- CVE-2019-6978
2018-08-23 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libgd2 (2.2.5-4ubuntu0.2) bionic-security; urgency=medium
* SECURITY UPDATE: Double free
- debian/patches/CVE-2018-1000222.patch: fix in
src/gd_bmp.c.
- CVE-2018-1000222
* SECURITY UPDATE: Infinite loop
- debian/patches/CVE-2018-5711.patch: fix in
src/gd_gif_in.c.
- CVE-2018-5711
2017-10-22 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.5-4) unstable; urgency=medium
[ Jiří Paleček ]
* Disable the test during build and run the testsuite through autopkgtest
(Closes: #867003)
* Make --as-needed work again
[ Ondřej Surý ]
* Get rid of libgd2*-dev traces (Closes: #879254)
2017-09-05 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.5-3) unstable; urgency=medium
* Disable gdimagerotate/bug00067 because it FTBFS on i386
2017-09-04 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.5-2) unstable; urgency=medium
* Fix OOB read due to crafted GD/GD2 images
* Disable gdimagecopyresampled/bug00201 that makes some platforms to FTBFS
2017-08-30 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.5-1) unstable; urgency=high
* New upstream version 2.2.5
+ [CVE-2017-6362]: Double-free in gdImagePngPtr().
+ [CVE-2017-7890]: Buffer over-read into uninitialized memory.
* Update d/watch for the github releases
* Refresh patches for the 2.2.5 release
2017-01-18 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.4-2) unstable; urgency=medium
* Apply correct patch on tiff_invalid_read
2017-01-18 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.4-1) unstable; urgency=medium
* New upstream version 2.2.4
* Rebase patches on top of libgd-2.2.4 release
* Disable tiff/tiff_invalid_read test
2016-11-07 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.3-87-gd0fec80-3) unstable; urgency=medium
* Disable tests/gdimagegrayscale as it breaks the 32-bit builds
2016-11-06 - Ondřej Surý <ondrej@debian.org>
libgd2 (2.2.3-87-gd0fec80-2) unstable; urgency=medium
* [CVE-2016-6911]: Fix invalid read in gdImageCreateFromTiffPtr()
(Closes: #840806)

See Also

Package Description
libgdm-dev_3.28.3-0ubuntu18.04.4_i386.deb GNOME Display Manager (development files)
libgdm1_3.28.3-0ubuntu18.04.4_i386.deb GNOME Display Manager (shared library)
libgeocode-glib-dev_3.25.4.1-4ubuntu0.18.04.1_i386.deb development files for geocode-glib library
libgeocode-glib-doc_3.25.4.1-4ubuntu0.18.04.1_all.deb gtk-doc documentation for geocode-glib library
libgeocode-glib0_3.25.4.1-4ubuntu0.18.04.1_i386.deb geocoding and reverse geocoding GLib library using Nominatim
libgettextpo-dev_0.19.8.1-6ubuntu0.3_i386.deb GNU Internationalization library development files
libgettextpo0_0.19.8.1-6ubuntu0.3_i386.deb GNU Internationalization library
libgfortran-7-dev_7.4.0-1ubuntu1~18.04.1_i386.deb Runtime library for GNU Fortran applications (development files)
libgfortran4_7.4.0-1ubuntu1~18.04.1_i386.deb Runtime library for GNU Fortran applications
libgjs-dev_1.52.5-0ubuntu18.04.1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgjs0g_1.52.5-0ubuntu18.04.1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgl1-mesa-dev_19.0.2-1ubuntu1.1~18.04.2_i386.deb free implementation of the OpenGL API -- GLX development files
libgl1-mesa-dri_19.0.2-1ubuntu1.1~18.04.2_i386.deb free implementation of the OpenGL API -- DRI modules
libgl1-mesa-glx_19.0.2-1ubuntu1.1~18.04.2_i386.deb transitional dummy package
libgl1_1.0.0-2ubuntu2.3_i386.deb Vendor neutral GL dispatch library -- legacy GL support
Advertisement
Advertisement