gstreamer1.0-gl_1.14.5-0ubuntu1~18.04.1_i386.deb


Advertisement

Description

gstreamer1.0-gl - GStreamer plugins for GL

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main i386
Package filename gstreamer1.0-gl_1.14.5-0ubuntu1~18.04.1_i386.deb
Package name gstreamer1.0-gl
Package version 1.14.5
Package release 0ubuntu1~18.04.1
Package architecture i386
Package type deb
Category libs
Homepage https://gstreamer.freedesktop.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 86.91 KB
Installed size 379.00 KB
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data.  Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related.  Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
This package contains the GStreamer plugins for GL.

Alternatives

Package Version Architecture Repository
gstreamer1.0-gl_1.14.5-0ubuntu1~18.04.1_amd64.deb 1.14.5 amd64 Ubuntu Updates Main
gstreamer1.0-gl_1.14.0-2ubuntu1_i386.deb 1.14.0 i386 Ubuntu Main
gstreamer1.0-gl_1.14.0-2ubuntu1_amd64.deb 1.14.0 amd64 Ubuntu Main
gstreamer1.0-gl - - -

Requires

Name Value
libc6 >= 2.27
libglib2.0-0 >= 2.40
libgraphene-1.0-0 >= 1.5.4
libgstreamer-gl1.0-0 >= 1.14.5
libgstreamer-plugins-base1.0-0 >= 1.14.5
libgstreamer1.0-0 >= 1.14.5
libjpeg8 >= 8c
libpng16-16 >= 1.6.2-1
libx11-6 -

Provides

Name Value
gstreamer1.0-videosink -
gstreamer1.0-videosource -

Replaces

Name Value
gstreamer1.0-plugins-bad << 1.13.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gstreamer1.0-gl_1.14.5-0ubuntu1~18.04.1_i386.deb
Source Package gst-plugins-base1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gstreamer1.0-gl deb package:
    # sudo apt-get install gstreamer1.0-gl

Files

Path
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstopengl.so
/usr/share/doc/gstreamer1.0-gl/AUTHORS
/usr/share/doc/gstreamer1.0-gl/NEWS.gz
/usr/share/doc/gstreamer1.0-gl/README.Debian
/usr/share/doc/gstreamer1.0-gl/README.gz
/usr/share/doc/gstreamer1.0-gl/changelog.Debian.gz
/usr/share/doc/gstreamer1.0-gl/copyright

Changelog

2019-07-03 - Iain Lane <iain.lane@canonical.com>
gst-plugins-base1.0 (1.14.5-0ubuntu1~18.04.1) bionic; urgency=medium
* New upstream release (LP: #1832123)
- debian/patches/CVE-2019-9928.patch: drop - it's in this release
2019-05-16 - Iain Lane <iain.lane@canonical.com>
gst-plugins-base1.0 (1.14.4-1ubuntu1.1~ubuntu18.04.1) bionic; urgency=medium
* No-change backport to bionic (LP: #1829366)
2019-04-26 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-base1.0 (1.14.4-1ubuntu1.1) cosmic-security; urgency=medium
* SECURITY UPDATE: heap overflow in RTSP parser
- debian/patches/CVE-2019-9928.patch: limit length in
gst-libs/gst/rtsp/gstrtspconnection.c.
- CVE-2019-9928
2018-10-05 - Iain Lane <iain.lane@canonical.com>
gst-plugins-base1.0 (1.14.4-1ubuntu1) cosmic; urgency=medium
* Merge from Debian unstable.  Remaining changes:
+ debian/rules: Build for GLES only on arm. We build OpenGL support, which
conflicts with Qt's OpenGL support - used in gst-good - if built for a
different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
to conflicting typedefs being dragged in by gst and Qt. This might be a
bug in mesa - if the headers are supposed to be includable simultaneously.
See FDO #105328 for that.
2018-10-03 - Sebastian Dröge <slomo@debian.org>
gst-plugins-base1.0 (1.14.4-1) unstable; urgency=medium
* New upstream bugfix release
2018-09-19 - Sebastian Dröge <slomo@debian.org>
gst-plugins-base1.0 (1.14.3-2) unstable; urgency=medium
[ Hugh McMaster ]
* debian/control.in:
- Mark gir1.2-gst-plugins-base-1.0 Multi-Arch: same.
[ Sebastian Dröge ]
* Upload to unstable.
2018-09-17 - Sebastian Dröge <slomo@debian.org>
gst-plugins-base1.0 (1.14.3-1) unstable; urgency=medium
[ Hugh McMaster ]
* gir1.2-gst-plugins-base-1.0: Install the typelibs into a multi-arch library
directory (Closes: #907808).
* debian/control.in:
- Mark libgstreamer-plugins-base1.0-dev Multi-Arch: same (Closes: #862119).
[ Sebastian Dröge ]
* New upstream bugfix release.
2018-07-24 - Gianfranco Costamagna <locutusofborg@debian.org>
gst-plugins-base1.0 (1.14.2-1ubuntu1) cosmic; urgency=low
* Merge from Debian unstable.  Remaining changes:
+ debian/rules: Build for GLES only on arm. We build OpenGL support, which
conflicts with Qt's OpenGL support - used in gst-good - if built for a
different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
to conflicting typedefs being dragged in by gst and Qt. This might be a
bug in mesa - if the headers are supposed to be includable simultaneously.
See FDO #105328 for that.
2018-07-23 - Sebastian Dröge <slomo@debian.org>
gst-plugins-base1.0 (1.14.2-1) unstable; urgency=medium
* New upstream bugfix release
2018-05-23 - Iain Lane <iain.lane@canonical.com>
gst-plugins-base1.0 (1.14.1-1ubuntu1) cosmic; urgency=medium
* Merge with Debian (LP: #1772898). Remaining change:
+ debian/rules: Build for GLES only on arm. We build OpenGL support, which
conflicts with Qt's OpenGL support - used in gst-good - if built for a
different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
to conflicting typedefs being dragged in by gst and Qt. This might be a
bug in mesa - if the headers are supposed to be includable simultaneously.
See FDO #105328 for that.

See Also

Package Description
gstreamer1.0-gtk3_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer plugin for GTK+3
gstreamer1.0-packagekit_1.1.9-1ubuntu2.18.04.5_i386.deb GStreamer plugin to install codecs using PackageKit
gstreamer1.0-plugins-base-apps_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer helper programs from the "base" set
gstreamer1.0-plugins-base-doc_1.14.5-0ubuntu1~18.04.1_all.deb GStreamer documentation for plugins from the "base" set
gstreamer1.0-plugins-base_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer plugins from the "base" set
gstreamer1.0-plugins-good-doc_1.14.5-0ubuntu1~18.04.1_all.deb GStreamer documentation for plugins from the "good" set
gstreamer1.0-plugins-good_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer plugins from the "good" set
gstreamer1.0-pulseaudio_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer plugin for PulseAudio
gstreamer1.0-tools_1.14.5-0ubuntu1~18.04.1_i386.deb Tools for use with GStreamer
gstreamer1.0-x_1.14.5-0ubuntu1~18.04.1_i386.deb GStreamer plugins for X11 and Pango
gtk-3-examples_3.22.30-1ubuntu4_i386.deb example files for GTK+ 3
gtk-update-icon-cache_3.22.30-1ubuntu4_i386.deb icon theme caching utility
guile-2.0-dev_2.0.13+1-5ubuntu0.1_i386.deb Development files for Guile 2.0
guile-2.0-doc_2.0.13+1-5ubuntu0.1_all.deb Documentation for Guile 2.0
guile-2.0-libs_2.0.13+1-5ubuntu0.1_i386.deb Core Guile libraries
Advertisement
Advertisement