whoopsie_0.2.62ubuntu0.1_amd64.deb


Advertisement

Description

whoopsie - Ubuntu error tracker submission

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename whoopsie_0.2.62ubuntu0.1_amd64.deb
Package name whoopsie
Package version 0.2.62ubuntu0.1
Package release -
Package architecture amd64
Package type deb
Category utils
Homepage http://wiki.ubuntu.com/ErrorTracker
License -
Maintainer Evan Dandrea <ev@ubuntu.com>
Download size 22.58 KB
Installed size 98.00 KB
This program submits crash reports back to an Ubuntu server.

Alternatives

Package Version Architecture Repository
whoopsie_0.2.62ubuntu0.1_i386.deb 0.2.62ubuntu0.1 i386 Ubuntu Updates Main
whoopsie_0.2.62_i386.deb 0.2.62 i386 Ubuntu Main
whoopsie_0.2.62_amd64.deb 0.2.62 amd64 Ubuntu Main
whoopsie - - -

Requires

Name Value
adduser -
libc6 >= 2.14
libcurl3-gnutls >= 7.16.2
libglib2.0-0 >= 2.32
libwhoopsie0 = 0.2.62ubuntu0.1
sysvinit-utils >= 2.88dsf-50

Download

Type URL
Mirror archive.ubuntu.com
Binary Package whoopsie_0.2.62ubuntu0.1_amd64.deb
Source Package whoopsie

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install whoopsie deb package:
    # sudo apt-get install whoopsie

Changelog

2019-07-05 - Alex Murray <alex.murray@canonical.com>
whoopsie (0.2.62ubuntu0.1) bionic-security; urgency=medium
* SECURITY UPDATE: Integer overflow when handling large crash dumps (LP:
#1830863)
- src/whoopsie.c: Don't use signed integer types for lengths to ensure
large crash dumps do not cause signed integer overflow
- CVE-2019-11476
2018-04-06 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.62) bionic; urgency=medium
* Remove /etc/whoopsie file as its contents are not read by whoopsie.
(LP: #1756937)
2018-04-06 - Steve Langasek <steve.langasek@ubuntu.com>
whoopsie (0.2.61) bionic; urgency=medium
* Build-depend on libcurl4-gnutls-dev, not libcurl4-openssl-dev, to drop
the redundant curl implementation from the desktop seeds and also fix a
GPL violation.
2018-03-30 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.60) bionic; urgency=medium
* Include JournalErrors in information uploaded to the Error Tracker.
(LP: #1756446)
2018-01-31 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.59) bionic; urgency=medium
* Set CURLOPT_SSL_VERIFYPEER to 0 if env CRASH_DB_NOVERIFYPEER is set for
testing daisy servers with self-signed certs.
2017-07-24 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.58) artful; urgency=medium
* Modify the whoopsie service file to wants=networking-online.target too.
2017-07-17 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.57) artful; urgency=medium
* src/connectivity.c: query the correct property when trying to
network-manager's state. (LP: #1697375)
* Modify the whoopsie service file to start after networking is on-line.
2017-06-08 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.56) artful; urgency=medium
* src/whoopsie.c: Add HotspotError from the openjdk-8 package hook which can
be larger than 1KB to the list of accepted fields. (LP: #1696814)
2017-03-29 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.55) zesty; urgency=medium
* src/whoopsie.c: Add ProcCpuinfoMinimal which can be larger than 1KB to the
list of accepted fields. (LP: #1673557)
2016-09-09 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.54) yakkety; urgency=medium
* src/whoopsie.c: Add fields from package management applications that can
be larger than 1KB to the list of accepted fields. (LP: #1616517)

See Also

Package Description
winbind_4.7.6+dfsg~ubuntu-0ubuntu2.11_amd64.deb service to resolve user and group information from Windows NT servers
winpr-utils_2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1_amd64.deb Windows Portable Runtime library command line utilities
wireless-regdb_2018.05.09-0ubuntu1~18.04.1_all.deb wireless regulatory database
wpasupplicant_2.6-15ubuntu2.5_amd64.deb client support for WPA and WPA2 (IEEE 802.11i)
wslu_2.0.0-0ubuntu2~18.04.1_all.deb collection of utilities for the Windows 10 Linux Subsystem
x11-common_7.7+19ubuntu7.1_all.deb X Window System (X.Org) infrastructure
x11-xkb-utils_7.7+3ubuntu0.18.04.1_amd64.deb X11 XKB utilities
xapian-doc_1.4.5-1ubuntu0.1_all.deb Core Xapian documentation
xapian-examples_1.4.5-1ubuntu0.1_amd64.deb Xapian simple example programs
xbrlapi_5.5-4ubuntu2.0.1_amd64.deb Access software for a blind person using a braille display - xbrlapi
xdg-desktop-portal-dev_1.0.3-0ubuntu0.2_all.deb desktop integration portal - development files
xdg-desktop-portal-gtk_1.0.2-0ubuntu1.1_amd64.deb GTK+/GNOME portal backend for xdg-desktop-portal
xdg-desktop-portal-tests_1.0.3-0ubuntu0.2_amd64.deb desktop integration portal - automated tests
xdg-desktop-portal_1.0.3-0ubuntu0.2_amd64.deb desktop integration portal for Flatpak and Snap
xdg-utils_1.1.2-1ubuntu2.3_all.deb desktop integration utilities from freedesktop.org
Advertisement
Advertisement