python3-louis_3.5.0-1ubuntu0.3_all.deb


Advertisement

Description

python3-louis - Python bindings for liblouis

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename python3-louis_3.5.0-1ubuntu0.3_all.deb
Package name python3-louis
Package version 3.5.0
Package release 1ubuntu0.3
Package architecture all
Package type deb
Category python
Homepage http://liblouis.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.36 KB
Installed size 37.00 KB
Liblouis is a braille translator and back-translator.  It features support for
computer and literary braille, supports contracted and uncontracted translation
for many languages and has support for hyphenation.  Liblouis also supports
math braille (Nemeth and Marburg).
This package contains Python bindings.

Alternatives

Package Version Architecture Repository
python3-louis_3.5.0-1ubuntu0.3_all.deb 3.5.0 all Ubuntu Updates Main
python3-louis_3.5.0-1_all.deb 3.5.0 all Ubuntu Main
python3-louis_3.5.0-1_all.deb 3.5.0 all Ubuntu Main
python3-louis - - -

Requires

Name Value
liblouis14 >= 3.5.0-1ubuntu0.3
python3:any >= 3.3.2-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-louis_3.5.0-1ubuntu0.3_all.deb
Source Package liblouis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-louis deb package:
    # sudo apt-get install python3-louis

Files

Path
/usr/lib/python3/dist-packages/louis-3.5.0.egg-info
/usr/lib/python3/dist-packages/louis/__init__.py
/usr/share/doc/python3-louis/changelog.Debian.gz
/usr/share/doc/python3-louis/copyright

Changelog

2018-10-02 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
liblouis (3.5.0-1ubuntu0.3) bionic-security; urgency=medium
* SECURITY UPDATE: Stack-based buffer overflow
- debian/patches/CVE-2018-12085.patch: fix in
liblouis/compileTranslationTable.c.
- CVE-2018-12085
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-17294.patch: fix in
liblouis/lou_translateString.c
- CVE-2018-17294
2018-06-05 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
liblouis (3.5.0-1ubuntu0.2) bionic-security; urgency=medium
* SECURITY UPDATE: Stack-based buffer overflow
- debian/patches/CVE-2018-11683.patch: fix in
liblouis/compileTranslationTable.c, tools/lou_translate.c.
- CVE-2018-11683
* SECURITY UPDATE: Stack-based buffer overflow
- debian/patches/CVE-2018-11684.patch: fix in
liblouis/compileTranslationTable.c.
- CVE-2018-11684
* SECURITY UPDATE: Stack-based buffer overflow
- debian/patches/CVE-2018-11685.patch: fix in
liblouis/compileTranslationTable.c.
- CVE-2018-11685
2018-06-04 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
liblouis (3.5.0-1ubuntu0.1) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-11410.patch: fix in liblouis/pattern.c.
- CVE-2018-11410
* SECURITY UPDATE: Stack-based buffer overflow
- debian/patches/CVE-2018-11440.patch: fix in table parsing
liblouis/compileTranslationTable.c.
- CVE-2018-11440
* SECURITY UPDATE: Buffer overflow in braille table parser
- debian/patches/CVE-2018-11577.patch: fix in
liblouis/compileTranslationTable.c.
- CVE-2018-11577
2018-03-11 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-1) unstable; urgency=medium
* New upstream release.
2017-09-29 - Samuel Thibault <sthibault@debian.org>
liblouis (3.4.1-1) unstable; urgency=medium
* New upstream release.
* control: Bump Standards-Version to 4.1.1 (no changes).
2017-09-08 - Samuel Thibault <sthibault@debian.org>
liblouis (3.3.0-1) unstable; urgency=medium
* New upstream release (Closes: Bug#874302).
- rename liblouis12 to liblouis14 according to soname bump.
* Use canonical anonscm vcs URL.
* control: Update maintainer mailing list.
* control: Migrate priority to optional.
* control: Bump Standards-Version to 4.1.0.
2016-09-14 - Samuel Thibault <sthibault@debian.org>
liblouis (3.0.0-3) unstable; urgency=medium
* Upload to unstable.
2016-09-10 - Samuel Thibault <sthibault@debian.org>
liblouis (3.0.0-2) experimental; urgency=medium
* control: Make sure to have a recent-enough automake to run yaml tests.
2016-09-05 - Samuel Thibault <sthibault@debian.org>
liblouis (3.0.0-1) experimental; urgency=medium
* New upstream release.
- patches/check_yaml: Remove, merged upstream.
- control, liblouis10.install: Rename liblouis10 package to liblouis12
according to upstream soname bump.
2016-07-15 - Samuel Thibault <sthibault@debian.org>
liblouis (2.6.5-1) unstable; urgency=medium
* New upstream release.
- rename liblouis9 package to liblouis10 according to upstream soname
bump.
* compat: Bump to 9.
* rules: Clear.
* control:
- add dh-python build-dep.
- Bump Standards-Version to 3.9.8 (no change).
- Update upstream URL.
* watch: Update.
* patches/check_yaml: Backport upstream patch to fix crashes in testsuite.
* rules: Make testsuite failure fatal again.

See Also

Package Description
python3-lxml_4.2.1-1ubuntu0.1_amd64.deb pythonic binding for the libxml2 and libxslt libraries
python3-maas-client_2.4.2-7034-g2f5deb8b8-0ubuntu1_all.deb MAAS python API client (Python 3)
python3-maas-provisioningserver_2.4.2-7034-g2f5deb8b8-0ubuntu1_all.deb MAAS server provisioning libraries (Python 3)
python3-minimal_3.6.7-1~18.04_amd64.deb minimal subset of the Python language (default python3 version)
python3-novaagent_2.1.18-0ubuntu1~18.04.0_all.deb Python 3 module for Rackspace Public Cloud Guest Agent
python3-paramiko_2.0.0-1ubuntu1.2_all.deb Make ssh v2 connections (Python 3)
python3-problem-report_2.20.9-0ubuntu7.6_all.deb Python 3 library to handle problem reports
python3-requests_2.18.4-2ubuntu0.1_all.deb elegant and simple HTTP library for Python3, built for human beings
python3-software-properties_0.96.24.32.9_all.deb manage the repositories that you install software from
python3-sss_1.16.1-1ubuntu1.2_amd64.deb Python3 module for the System Security Services Daemon
python3-tk_3.6.8-1~18.04_amd64.deb Tkinter - Writing Tk applications with Python 3.x
python3-ubuntu-image_1.7+18.04ubuntu1_all.deb toolkit for building Ubuntu images
python3-uno_6.0.7-0ubuntu0.18.04.6_amd64.deb Python-UNO bridge
python3-update-manager_18.04.11.10_all.deb python 3.x module for update-manager
python3-urllib3_1.22-1ubuntu0.18.04.1_all.deb HTTP library with thread-safe connection pooling for Python3
Advertisement
Advertisement