postgresql-pltcl-10_10.10-0ubuntu0.18.04.1_amd64.deb


Advertisement

Description

postgresql-pltcl-10 - PL/Tcl procedural language for PostgreSQL 10

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename postgresql-pltcl-10_10.10-0ubuntu0.18.04.1_amd64.deb
Package name postgresql-pltcl-10
Package version 10.10
Package release 0ubuntu0.18.04.1
Package architecture amd64
Package type deb
Category database
Homepage http://www.postgresql.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 28.36 KB
Installed size 172.00 KB
PL/Tcl enables an SQL developer to write procedural language functions
for PostgreSQL 10 in Tcl.  You need this package if you have any
PostgreSQL 10 functions that use the languages pltcl or pltclu.
PostgreSQL is an object-relational SQL database management system.

Alternatives

Package Version Architecture Repository
postgresql-pltcl-10_10.10-0ubuntu0.18.04.1_i386.deb 10.10 i386 Ubuntu Updates Main
postgresql-pltcl-10_10.3-1_i386.deb 10.3 i386 Ubuntu Main
postgresql-pltcl-10_10.3-1_amd64.deb 10.3 amd64 Ubuntu Main
postgresql-pltcl-10 - - -

Requires

Name Value
libc6 >= 2.4
libtcl8.6 >= 8.6.0
postgresql-10 = 10.10-0ubuntu0.18.04.1

Provides

Name Value
postgresql-pltcl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package postgresql-pltcl-10_10.10-0ubuntu0.18.04.1_amd64.deb
Source Package postgresql-10

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install postgresql-pltcl-10 deb package:
    # sudo apt-get install postgresql-pltcl-10

Files

Path
/usr/lib/postgresql/10/lib/pltcl.so
/usr/share/doc/postgresql-pltcl-10/changelog.Debian.gz
/usr/share/doc/postgresql-pltcl-10/copyright
/usr/share/postgresql/10/extension/pltcl--1.0.sql
/usr/share/postgresql/10/extension/pltcl--unpackaged--1.0.sql
/usr/share/postgresql/10/extension/pltcl.control
/usr/share/postgresql/10/extension/pltclu--1.0.sql
/usr/share/postgresql/10/extension/pltclu--unpackaged--1.0.sql
/usr/share/postgresql/10/extension/pltclu.control

Changelog

2019-08-06 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
postgresql-10 (10.10-0ubuntu0.18.04.1) bionic-security; urgency=medium
* SECURITY UPDATE: New upstream release (LP: #1839058)
- Require schema qualification to cast to a temporary type when using
functional cast syntax (CVE-2019-10208)
- Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when altering multiple
columns' types in one command. This fixes a regression introduced in the
most recent minor releases
- Details about these and many further changes can be found at:
https://www.postgresql.org/docs/10/static/release-10-10.html
2019-06-18 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
postgresql-10 (10.9-0ubuntu0.18.04.1) bionic-security; urgency=medium
* New upstream release (LP: #1828012)
- Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
CVE-2019-10164
- Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has
a partial exclusion constraint
- Fix failure of COMMENT command for comments on domain constraints
- Prevent possible memory clobber when there are duplicate columns in
a hash aggregate's hash key list
- Details about these and many further changes can be found at:
https://www.postgresql.org/docs/10/static/release-10-9.html
2019-05-07 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
postgresql-10 (10.8-0ubuntu0.18.04.1) bionic-security; urgency=medium
* New upstream release(s) (LP: #1828012)
- Prevent row-level security policies from being bypassed via
selectivity estimators.
CVE-2019-10130
- Details about these and many further changes can be found at:
https://www.postgresql.org/docs/10/static/release-10-8.html
2019-02-12 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
postgresql-10 (10.7-0ubuntu0.18.04.1) bionic; urgency=medium
* New upstream release (LP: #1815665)
- By default, panic instead of retrying after fsync() failure, to avoid
possible data corruption. A new server parameter "guc-data-sync-retry"
has been added to control this;
- d/p/pg-10-Disallow-setting-client_min_messages-higher-than-ERR.patch:
to retain SRU stability this patch reverts one of the changes which
disabled the error suppression by setting client_min_messages to
fatal or panic. Overall that means no change to the handling of
client_min_messages due to this upload.
- d/p/pg-10-Rename-rbtree.c-functions-to-use-rbt-prefix-not-rb-p.patch:
this change of 10.7 would break an external ABI/API exposed to
extensions. To avoid breaking those (especially those not in the Ubuntu
Archive that we can't control) this change of upstreams stable release
is reverted. Thereby the ABI/API is unchanged in regard to the rb_
function prefix by this new package upload to Ubuntu.
- Details about these and many further changes can be found at:
https://www.postgresql.org/docs/10/static/release-10-7.html
2018-11-13 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
postgresql-10 (10.6-0ubuntu0.18.04.1) bionic-security; urgency=medium
* SECURITY UPDATE: Updated to 10.6 to fix security issue.
- Details about the new release can be found at
https://www.postgresql.org/docs/10/release-10-6.html
- CVE-2018-16850

See Also

Package Description
ppp-dev_2.4.7-2+2ubuntu1.1_all.deb Point-to-Point Protocol (PPP) - development files
ppp_2.4.7-2+2ubuntu1.1_amd64.deb Point-to-Point Protocol (PPP) - daemon
procps_3.3.12-3ubuntu1.2_amd64.deb /proc file system utilities
psmisc_23.1-1ubuntu0.1_amd64.deb utilities that use the proc file system
pulseaudio-module-bluetooth_11.1-1ubuntu7.2_amd64.deb Bluetooth module for PulseAudio sound server
pulseaudio-utils_11.1-1ubuntu7.2_amd64.deb Command line tools for the PulseAudio sound server
pulseaudio_11.1-1ubuntu7.2_amd64.deb PulseAudio sound server
python-aodh_6.0.1-0ubuntu1.2_all.deb OpenStack Telemetry (Ceilometer) Alarming - Python libraries
python-apt-common_1.6.4_all.deb Python interface to libapt-pkg (locales)
python-apt-dev_1.6.4_all.deb Python interface to libapt-pkg (development files)
python-apt-doc_1.6.4_all.deb Python interface to libapt-pkg (API documentation)
python-apt_1.6.4_amd64.deb Python interface to libapt-pkg
python-barbican_6.0.1-0ubuntu1_all.deb OpenStack Key Management Service - Python files
python-ceilometer_10.0.1-0ubuntu0.18.04.2_all.deb ceilometer python libraries
python-ceph_12.2.12-0ubuntu0.18.04.3_all.deb Meta-package for python libraries for the Ceph libraries
Advertisement
Advertisement