linux-kvm-tools-4.15.0-1038_4.15.0-1038.38_amd64.deb


Advertisement

Description

linux-kvm-tools-4.15.0-1038 - Linux kernel version specific tools for version 4.15.0-1038

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename linux-kvm-tools-4.15.0-1038_4.15.0-1038.38_amd64.deb
Package name linux-kvm-tools-4.15.0-1038
Package version 4.15.0
Package release 1038.38
Package architecture amd64
Package type deb
Category devel
Homepage -
License -
Maintainer Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Download size 4.16 MB
Installed size 19.15 MB
This package provides the architecture dependant parts for kernel
version locked tools (such as perf and x86_energy_perf_policy) for
version 4.15.0-1038 on
64 bit x86.
You probably want to install linux-tools-4.15.0-1038-<flavour>.

Alternatives

Package Version Architecture Repository
linux-kvm-tools-4.15.0-1038 - - -

Requires

Name Value
libaudit1 >= 1:2.2.1
libc6 >= 2.14
libdw1 >= 0.157
libelf1 >= 0.144
liblzma5 >= 5.1.1alpha+20120614
libnuma1 >= 2.0.11
libpci3 >= 1:3.5.2-1
libslang2 >= 2.2.4
libudev1 >= 183
libunwind8 -
linux-tools-common -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package linux-kvm-tools-4.15.0-1038_4.15.0-1038.38_amd64.deb
Source Package linux-kvm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linux-kvm-tools-4.15.0-1038 deb package:
    # sudo apt-get install linux-kvm-tools-4.15.0-1038

Files

Path
/usr/lib/libcpupower.so.4.15.0-1038
/usr/lib/linux-kvm-tools-4.15.0-1038/cpupower
/usr/lib/linux-kvm-tools-4.15.0-1038/perf
/usr/lib/linux-kvm-tools-4.15.0-1038/turbostat
/usr/lib/linux-kvm-tools-4.15.0-1038/usbip
/usr/lib/linux-kvm-tools-4.15.0-1038/usbipd
/usr/lib/linux-kvm-tools-4.15.0-1038/x86_energy_perf_policy
/usr/share/doc/linux-kvm-tools-4.15.0-1038/changelog.Debian.gz
/usr/share/doc/linux-kvm-tools-4.15.0-1038/copyright

Changelog

2019-06-24 - Kleber Sacilotto de Souza <kleber.souza@canonical.com>
linux-kvm (4.15.0-1038.38) bionic; urgency=medium
* linux-kvm: 4.15.0-1038.38 -proposed tracker (LP: #1833976)
[ Ubuntu: 4.15.0-54.58 ]
* linux: 4.15.0-54.58 -proposed tracker (LP: #1833987)
* Remote denial of service (resource exhaustion) caused by TCP SACK scoreboard
manipulation (LP: #1831638) // CVE-2019-11478
- tcp: refine memory limit test in tcp_fragment()
* CVE-2019-11479
- SAUCE: tcp: add tcp_min_snd_mss sysctl
- SAUCE: tcp: enforce tcp_min_snd_mss in tcp_mtu_probing()
2019-06-06 - Stefan Bader <stefan.bader@canonical.com>
linux-kvm (4.15.0-1036.36) bionic; urgency=medium
[ Ubuntu: 4.15.0-52.56 ]
* Remote denial of service (resource exhaustion) caused by TCP SACK scoreboard
manipulation (LP: #1831638)
- SAUCE: tcp: tcp_fragment() should apply sane memory limits
* Remote denial of service (system crash) caused by integer overflow in TCP
SACK handling (LP: #1831637)
- SAUCE: tcp: limit payload size of sacked skbs

See Also

Package Description
linux-kvm-tools-4.15.0-1039_4.15.0-1039.39_amd64.deb Linux kernel version specific tools for version 4.15.0-1039
linux-kvm-tools-4.15.0-1042_4.15.0-1042.42_amd64.deb Linux kernel version specific tools for version 4.15.0-1042
linux-kvm-tools-4.15.0-1043_4.15.0-1043.43_amd64.deb Linux kernel version specific tools for version 4.15.0-1043
linux-kvm-tools-4.15.0-1044_4.15.0-1044.44_amd64.deb Linux kernel version specific tools for version 4.15.0-1044
linux-kvm-tools-4.15.0-1046_4.15.0-1046.46_amd64.deb Linux kernel version specific tools for version 4.15.0-1046
linux-kvm-tools-4.15.0-1047_4.15.0-1047.47_amd64.deb Linux kernel version specific tools for version 4.15.0-1047
linux-kvm-tools-4.15.0-1048_4.15.0-1048.48_amd64.deb Linux kernel version specific tools for version 4.15.0-1048
linux-kvm-tools-4.15.0-1050_4.15.0-1050.50_amd64.deb Linux kernel version specific tools for version 4.15.0-1050
linux-kvm-tools-4.15.0-1051_4.15.0-1051.51_amd64.deb Linux kernel version specific tools for version 4.15.0-1051
linux-kvm-tools-4.15.0-1052_4.15.0-1052.52_amd64.deb Linux kernel version specific tools for version 4.15.0-1052
linux-kvm-tools-4.15.0-1053_4.15.0-1053.53_amd64.deb Linux kernel version specific tools for version 4.15.0-1053
linux-kvm_4.15.0.1053.53_amd64.deb Complete Linux kernel for virtual systems
linux-libc-dev-arm64-cross_4.15.0-35.38cross1.1_all.deb Linux Kernel Headers for development (for cross-compiling)
linux-libc-dev-armhf-cross_4.15.0-35.38cross1.1_all.deb Linux Kernel Headers for development (for cross-compiling)
linux-libc-dev-powerpc-cross_4.15.0-35.38cross1.1_all.deb Linux Kernel Headers for development (for cross-compiling)
Advertisement
Advertisement