librte-eal17.11_17.11.6-0~ubuntu18.04.1_amd64.deb


Advertisement

Description

librte-eal17.11 - Data Plane Development Kit (librte-eal runtime library)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename librte-eal17.11_17.11.6-0~ubuntu18.04.1_amd64.deb
Package name librte-eal17.11
Package version 17.11.6
Package release 0~ubuntu18.04.1
Package architecture amd64
Package type deb
Category libs
Homepage https://dpdk.org/doc/api/rte__eal_8h.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 65.57 KB
Installed size 202.00 KB
DPDK is a set of libraries for fast packet processing. Applications run
in user-space and communicate directly with dedicated network interfaces.
This package contains the runtime libraries for librte_eal.

Alternatives

Package Version Architecture Repository
librte-eal17.11_17.11.6-0~ubuntu18.04.1_i386.deb 17.11.6 i386 Ubuntu Updates Main
librte-eal17.11_17.11.1-6_i386.deb 17.11.1 i386 Ubuntu Main
librte-eal17.11_17.11.1-6_amd64.deb 17.11.1 amd64 Ubuntu Main
librte-eal17.11 - - -

Requires

Name Value
libc6 >= 2.14
libnuma1 >= 2.0.11

Conflicts

Name Value
libdpdk0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package librte-eal17.11_17.11.6-0~ubuntu18.04.1_amd64.deb
Source Package dpdk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librte-eal17.11 deb package:
    # sudo apt-get install librte-eal17.11

Files

Path
/usr/lib/x86_64-linux-gnu/librte_eal.so.17.11
/usr/share/doc/librte-eal17.11/changelog.Debian.gz
/usr/share/doc/librte-eal17.11/copyright

Changelog

2019-07-12 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (17.11.6-0~ubuntu18.04.1) bionic; urgency=medium
* New upstream release 17.11.6 (LP: #1836365)
For a full list of changes see:
https://doc.dpdk.org/guides-17.11/rel_notes/release_17_11.html#id6
- drop patches upstream in 17.11.6:
d/p/0001-kni-fix-build-for-dev_open-in-Linux-5.0.patch
d/p/0002-kni-fix-build-for-igb_ndo_bridge_setlink-in-Linux-5..patch
* d/p/lp-1827102-kni-fix-build-with-Linux-5.1.patch fix kni DKMS build with
Linux 5.1 kernels (LP: #1827102)
2019-02-26 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (17.11.5-0~ubuntu18.04.1) bionic; urgency=medium
* New upstream release 17.11.5; for a full list of changes see:
https://doc.dpdk.org/guides-17.11/rel_notes/release_17_11.html#id4
https://doc.dpdk.org/guides-17.11/rel_notes/release_17_11.html#id5
Among many other fixes this closes the following bugs:
- request to merge 17.11.5 (LP: #1817675)
- issues with -mavx512f on recent Skylake chips (LP: #1799397)
- Drop d/p/net-mlx5-fix-build-with-rdma-core-v19.patch which is part of
17.11.4
* d/p/*kni-fix-build*: fix build with kernel 5.0 (LP: #1814919)
as preparation for a HWE kernel based on the 5.0 version of 19.04
2018-08-01 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (17.11.3-3~ubuntu0.18.04) bionic; urgency=medium
* Make DPDK LTS release available in Bionic (LP: #1784816)
2018-07-30 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.3-3) unstable; urgency=medium
* d/p/net-mlx5-fix-build-with-rdma-core-v19.patch: fix Build against
rdma-core v19 which is in Debian unstable now. (This will most likely be
in 17.11.4 and can then be dropped)
2018-07-03 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.3-2) unstable; urgency=medium
* Temporarily disable ML4 and MLX5 again to fix FTBS due to
incompatibility with rdma-core 19.0.
2018-06-20 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.3-1) unstable; urgency=medium
[ Christian Ehrhardt ]
* New upstream release 17.11.3; for a full list of changes see:
https://dpdk.org/doc/guides-17.11/rel_notes/release_17_11.html
* d/control: binary package and build-dependency for MLX4 and MLX5 PMDs.
- d/librte-pmd-mlx*.symbols: symbol files for mlx PMDs
- d/p/app-testpmd-add-ethernet-peer-command.patch: ensure MLX PMDs are
well testable
2018-04-24 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
dpdk (17.11.2-1ubuntu0.1) bionic-security; urgency=medium
* Release as bionic security update.
2018-04-23 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.2-1) unstable; urgency=high
* New upstream release 17.11.2; for a full list of changes see:
https://dpdk.org/doc/guides-17.11/rel_notes/release_17_11.html
* Fixes CVE-2018-1059 (Closes: #896688).
2018-03-14 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-6) unstable; urgency=medium
* test-linkage: drop brittle test for secondary library dependencies
2018-03-13 - Luca Boccassi <bluca@debian.org>
dpdk (17.11.1-5) unstable; urgency=medium
[ Christian Ehrhardt ]
* d/t/control: depend on dpdk-dev to be able to use dpdk-sdk-env.sh
* d/t/testlinkage: improvements and fixes for current debci issues
- Use RTE_SDK to build the binary
- verbose execution for better debugging
- check for librt instead of libpthread as second level lib
- use a valid prototype for main
[ Luca Boccassi ]

See Also

Package Description
librte-efd17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte_efd runtime library)
librte-ethdev17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (libethdev runtime library)
librte-eventdev17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte_eventdev runtime library)
librte-flow-classify17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-flow-classify runtime library)
librte-gro17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-gro runtime library)
librte-gso17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-gso runtime library)
librte-hash17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-hash runtime library)
librte-ip-frag17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-ip-frag runtime library)
librte-jobstats17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-jobstats runtime library)
librte-kni17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-kni runtime library)
librte-kvargs17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-kvargs runtime library)
librte-latencystats17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte_latencystats runtime library)
librte-lpm17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-lpm runtime library)
librte-mbuf17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-mbuf2 runtime library)
librte-member17.11_17.11.6-0~ubuntu18.04.1_amd64.deb Data Plane Development Kit (librte-member runtime library)
Advertisement
Advertisement