libpython3-all-dev_3.6.7-1~18.04_amd64.deb


Advertisement

Description

libpython3-all-dev - package depending on all supported Python 3 development packages

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package name libpython3-all-dev
Package version 3.6.7
Package release 1~18.04
Package architecture amd64
Package type deb
Installed size 6 B
Download size 1.07 KB
Official Mirror archive.ubuntu.com
The package currently depends on libpython3.6-dev, in the
future, dependencies on jython (Python for a JVM) and ironpython (Python
for Mono) may be added.
This package is a dependency package used as a build dependency for other
packages to avoid hardcoded dependencies on specific Python 3 development
packages.

Alternatives

Package Version Architecture Repository
libpython3-all-dev_3.6.7-1~18.04_i386.deb 3.6.7 i386 Ubuntu Updates Main
libpython3-all-dev_3.6.5-3_amd64.deb 3.6.5 amd64 Ubuntu Main
libpython3-all-dev_3.6.5-3_i386.deb 3.6.5 i386 Ubuntu Main
libpython3-all-dev - - -

Requires

Name Value
libpython3-dev = 3.6.7-1~18.04
libpython3.6-dev -

Download

Type URL
Binary Package libpython3-all-dev_3.6.7-1~18.04_amd64.deb
Source Package python3-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpython3-all-dev deb package:
    # sudo apt-get install libpython3-all-dev

Files

Path
/usr/share/doc/libpython3-all-dev

Changelog

2018-10-25 - Matthias Klose <doko@ubuntu.com>
python3-defaults (3.6.7-1~18.04) bionic-proposed; urgency=medium
* SRU: LP: #1799206.
* Drop python3.7 as a supported python3 version for the bionic SRU.
2018-10-21 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.7-1) unstable; urgency=high
* Really ship the policy in the python3 package, and update from the last
version found in the python package. Closes: #910113.
* Bump version to 3.6.7.
2018-06-27 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.6-1) unstable; urgency=medium
[ Matthias Klose ]
* Fix the idle desktop file. Closes: #901096.
* Install the policy files in the python3 package. Closes: #901486.
* python3-minimal: Pre-Depend on python3.6-minimal. Closes: #901001.
* Bump version to 3.6.6.
[ Scott Kitterman ]
* Remove myself from uploaders
2018-06-21 - Brian Murray <brian@ubuntu.com>
python3-defaults (3.6.5-3ubuntu1) bionic; urgency=medium
* Switch python3.x-minimal to a pre-dependency for python3-minimal so that
release upgrades will be more smooth. (LP: #1768379)
2018-06-07 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-5) experimental; urgency=medium
* Fix typo in the defaults file. Closes: #900937, #900949.
2018-06-06 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-4) experimental; urgency=medium
* Update Vcs attributes.
* Add Python 3.7 to the list of supported Python3 versions.
2018-04-10 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-3) unstable; urgency=medium
* Update valgrind support file. LP: #1513364.
* debian/control.in (Michael Vogt):
- add Cnf-Visible-Pkgname hint to ensure command-not-found recommends
installing "python3" instead of "python3-minimal" when it is missing.
2018-04-02 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-2) unstable; urgency=medium
* Distinguish between python3.6 and python3-stdlib-extensions versions.
Closes: #894168.
* python3-venv: Depend on python3-distutils.
2018-03-31 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5-1) unstable; urgency=medium
[ Matthias Klose ]
* Bump version to 3.6.5.
[ Michael Vogt ]
* debian/control.in: LP: #1752415
- add "XB-Cnf-Extra-Commands: python" to ensure command-not-found
outputs the python3 package when searching for "python"
- add XB-Cnf-Priority-Bonus to ensure python3 is listed on the
top when typing "python"
2018-03-25 - Matthias Klose <doko@debian.org>
python3-defaults (3.6.5~rc1-1) unstable; urgency=medium
* Bump version to 3.6.5~rc1.
* Remove dh-python dependency from python3.
* Add dh-python and python3-distutils dependencies to python3-all and
python3-dev.

See Also

Package Description
libpython3-dev_3.6.7-1~18.04_amd64.deb header files and a static library for Python (default)
libpython3-stdlib_3.6.7-1~18.04_amd64.deb interactive high-level object-oriented language (default python3 version)
libpython3.6-dev_3.6.7-1~18.04_amd64.deb Header files and a static library for Python (v3.6)
libpython3.6-minimal_3.6.7-1~18.04_amd64.deb Minimal subset of the Python language (version 3.6)
libpython3.6-stdlib_3.6.7-1~18.04_amd64.deb Interactive high-level object-oriented language (standard library, version 3.6)
libpython3.6-testsuite_3.6.7-1~18.04_all.deb Testsuite for the Python standard library (v3.6)
libpython3.6_3.6.7-1~18.04_amd64.deb Shared Python runtime library (version 3.6)
libqgpgme7_1.10.0-1ubuntu2_amd64.deb library for GPGME integration with Qt
libquadmath0_8.2.0-1ubuntu2~18.04_amd64.deb GCC Quad-Precision Math Library
librados-dev_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS distributed object store client library (development files)
librados2_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS distributed object store client library
libradosstriper-dev_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS striping interface (development files)
libradosstriper1_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS striping interface
libraw-dev_0.18.8-1ubuntu0.2_amd64.deb raw image decoder library (development files)
libraw-doc_0.18.8-1ubuntu0.2_all.deb raw image decoder library (documentation)
Advertisement
Advertisement