libpython2.7_2.7.15~rc1-1ubuntu0.1_amd64.deb


Advertisement

Description

libpython2.7 - Shared Python runtime library (version 2.7)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package name libpython2.7
Package version 2.7.15~rc1
Package release 1ubuntu0.1
Package architecture amd64
Package type deb
Installed size 3.40 KB
Download size 1.00 MB
Official Mirror archive.ubuntu.com
Python is a high-level, interactive, object-oriented language. Its 2.7 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
This package contains the shared runtime library, normally not needed
for programs using the statically linked interpreter.

Alternatives

Package Version Architecture Repository
libpython2.7_2.7.15~rc1-1ubuntu0.1_i386.deb 2.7.15~rc1 i386 Ubuntu Updates Main
libpython2.7_2.7.15~rc1-1_amd64.deb 2.7.15~rc1 amd64 Ubuntu Main
libpython2.7_2.7.15~rc1-1_i386.deb 2.7.15~rc1 i386 Ubuntu Main
libpython2.7 - - -

Requires

Name Value
libc6 >= 2.15
libpython2.7-stdlib = 2.7.15~rc1-1ubuntu0.1
zlib1g >= 1:1.2.0

Replaces

Name Value
python2.7 << 2.6

Download

Type URL
Binary Package libpython2.7_2.7.15~rc1-1ubuntu0.1_amd64.deb
Source Package python2.7

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpython2.7 deb package:
    # sudo apt-get install libpython2.7

Files

Path
/usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.so
/usr/lib/x86_64-linux-gnu/libpython2.7.so.1
/usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
/usr/share/doc/libpython2.7
/usr/share/lintian/overrides/libpython2.7

Changelog

See python2.7_2.7.15~rc1-1ubuntu0.1_amd64.deb changelog.

See Also

Package Description
libpython3-all-dev_3.6.7-1~18.04_amd64.deb package depending on all supported Python 3 development packages
libpython3-dev_3.6.7-1~18.04_amd64.deb header files and a static library for Python (default)
libpython3-stdlib_3.6.7-1~18.04_amd64.deb interactive high-level object-oriented language (default python3 version)
libpython3.6-dev_3.6.7-1~18.04_amd64.deb Header files and a static library for Python (v3.6)
libpython3.6-minimal_3.6.7-1~18.04_amd64.deb Minimal subset of the Python language (version 3.6)
libpython3.6-stdlib_3.6.7-1~18.04_amd64.deb Interactive high-level object-oriented language (standard library, version 3.6)
libpython3.6-testsuite_3.6.7-1~18.04_all.deb Testsuite for the Python standard library (v3.6)
libpython3.6_3.6.7-1~18.04_amd64.deb Shared Python runtime library (version 3.6)
libqgpgme7_1.10.0-1ubuntu2_amd64.deb library for GPGME integration with Qt
libquadmath0_8.2.0-1ubuntu2~18.04_amd64.deb GCC Quad-Precision Math Library
librados-dev_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS distributed object store client library (development files)
librados2_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS distributed object store client library
libradosstriper-dev_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS striping interface (development files)
libradosstriper1_12.2.7-0ubuntu0.18.04.1_amd64.deb RADOS striping interface
libraw-dev_0.18.8-1ubuntu0.2_amd64.deb raw image decoder library (development files)
Advertisement
Advertisement