libprocps6_3.3.12-3ubuntu1.2_amd64.deb


Advertisement

Description

libprocps6 - library for accessing process information from /proc

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename libprocps6_3.3.12-3ubuntu1.2_amd64.deb
Package name libprocps6
Package version 3.3.12
Package release 3ubuntu1.2
Package architecture amd64
Package type deb
Category libs
Homepage https://gitlab.com/procps-ng/procps
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 31.07 KB
Installed size 118.00 KB
The libprocps library is a way of accessing information out of the /proc
filesystem.
This package contains the shared libraries necessary to run programs
compiled with libprocps.

Alternatives

Package Version Architecture Repository
libprocps6_3.3.12-3ubuntu1.2_i386.deb 3.3.12 i386 Ubuntu Updates Main
libprocps6_3.3.12-3ubuntu1_i386.deb 3.3.12 i386 Ubuntu Main
libprocps6_3.3.12-3ubuntu1_amd64.deb 3.3.12 amd64 Ubuntu Main
libprocps6 - - -

Requires

Name Value
libc6 >= 2.14
libsystemd0 >= 209

Replaces

Name Value
procps << 1:3.3.2-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libprocps6_3.3.12-3ubuntu1.2_amd64.deb
Source Package procps

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libprocps6 deb package:
    # sudo apt-get install libprocps6

Files

Path
/lib/x86_64-linux-gnu/libprocps.so.6
/lib/x86_64-linux-gnu/libprocps.so.6.0.0
/usr/share/doc/libprocps6/NEWS.Debian.gz
/usr/share/doc/libprocps6/changelog.Debian.gz
/usr/share/doc/libprocps6/copyright

Changelog

2019-08-09 - Eric Desrochers  <eric.desrochers@canonical.com>
procps (2:3.3.12-3ubuntu1.2) bionic; urgency=medium
* d/p/pgrep-increase-CMDSTRSIZE.patch:
- Allows long command lines to be searched.
eg: Java process with a long classpath. (LP: #1839329)
2018-05-14 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
procps (2:3.3.12-3ubuntu1.1) bionic-security; urgency=medium
* SECURITY UPDATE: top configuration file read from current directory
- debian/patches/CVE-2018-1122.patch: do not default to the cwd in
top/top.c.
- CVE-2018-1122
* SECURITY UPDATE: ps output buffer overflow
- debian/patches/CVE-2018-1123.patch: check sizes in ps/output.c.
- CVE-2018-1123
* SECURITY UPDATE: integer overflow in file2strvec()
- debian/patches/CVE-2018-1124.patch: prevent overflow in
proc/readproc.c.
- CVE-2018-1124
* SECURITY UPDATE: stack overflow in pgrep
- debian/patches/CVE-2018-1125.patch: check length in pgrep.c.
- CVE-2018-1125
* SECURITY UPDATE: truncated sizes and possible integer overflow
- debian/patches/CVE-2018-1126.patch: use size_t, not unsigned int in
proc/alloc.*.
- CVE-2018-1126
2018-01-17 - Balint Reczey <rbalint@ubuntu.com>
procps (2:3.3.12-3ubuntu1) bionic; urgency=medium
* Merge from Debian unstable.  Remaining changes:
- debian/sysctl.d (Ubuntu-specific):
+ 10-console-messages.conf: stop low-level kernel messages on console.
+ 10-kernel-hardening.conf: add the kptr_restrict setting
+ 10-keyboard.conf.powerpc: mouse button emulation on PowerPC.
+ 10-ipv6-privacy.conf: add a file to sysctl.d to apply the defaults
for IPv6 privacy extensions for interfaces. (LP: #176125, #841353)
+ 10-link-restrictions.conf: even though the Ubuntu
kernel is built with these defaults in place, we want to make sure
that people running stock kernels don't miss out.
+ 10-magic-sysrq.conf: Disable most magic sysrq by default, allowing
critical sync, remount, reboot functions. (LP: #194676, LP: #1025467)
+ 10-network-security.conf: enable rp_filter and SYN-flood protection.
+ 10-ptrace.conf: describe new PTRACE setting.
+ 10-zeropage.conf: safe mmap_min_addr value for graceful fall-back.
for armhf, and arm64.
+ 10-qemu.conf.s390x for qemu.
+ README: describe how this directory is supposed to work.
- debian/rules: Fix cross build
- ignore_eaccess.patch: If we get eaccess when opening a sysctl file for
writing, don't error out.  Otherwise package upgrades can fail,
especially in containers.
- ignore_erofs.patch: Same as ignore_eaccess but for the case where
part of /proc is read/only.
2016-11-22 - Craig Small <csmall@debian.org>
procps (2:3.3.12-3) unstable; urgency=medium
[ Sven Joachim <svenjoac@gmx.de> ]
* fix install on Hurd. Closes: #831004
* Fix path for kill on kfreebsd. Closes: #831348
[ Craig Small ]
* One additional hurd path change. Thanks to Svante Signell for patch
Closes: #835624
* Remove SIGPWR warning for FreeBSD. Thanks to Jon Boden for patch
Closes: #832148
2016-07-13 - Craig Small <csmall@debian.org>
procps (2:3.3.12-2) unstable; urgency=medium
* Only have one installinit override, thanks Sven! Closes: #827423
* Define HOST_NAME_MAX when not defined Closes: #830734
* Remove strtod_nol tests Closes: #830733
2016-07-12 - Martin Pitt <martin.pitt@ubuntu.com>
procps (2:3.3.12-1ubuntu2) yakkety; urgency=medium
* Remove strtod_nol tests Closes: #830733
(Cherry-picked from Debian packaging git).
* Only have one installinit override, thanks Sven! Closes: #827423
(Cherry-picked from Debian packaging git).

See Also

Package Description
libptexenc-dev_2017.20170613.44572-8ubuntu0.1_amd64.deb TeX Live: ptex encoding library (development part)
libptexenc1_2017.20170613.44572-8ubuntu0.1_amd64.deb TeX Live: pTeX encoding library
libpulse-dev_11.1-1ubuntu7.2_amd64.deb PulseAudio client development headers and libraries
libpulse-mainloop-glib0_11.1-1ubuntu7.2_amd64.deb PulseAudio client libraries (glib support)
libpulse0_11.1-1ubuntu7.2_amd64.deb PulseAudio client libraries
libpulsedsp_11.1-1ubuntu7.2_amd64.deb PulseAudio OSS pre-load library
libpython2.7-dev_2.7.15-4ubuntu4~18.04.1_amd64.deb Header files and a static library for Python (v2.7)
libpython2.7-minimal_2.7.15-4ubuntu4~18.04.1_amd64.deb Minimal subset of the Python language (version 2.7)
libpython2.7-stdlib_2.7.15-4ubuntu4~18.04.1_amd64.deb Interactive high-level object-oriented language (standard library, version 2.7)
libpython2.7_2.7.15-4ubuntu4~18.04.1_amd64.deb Shared Python runtime library (version 2.7)
libpython3-all-dev_3.6.7-1~18.04_amd64.deb package depending on all supported Python 3 development packages
libpython3-dev_3.6.7-1~18.04_amd64.deb header files and a static library for Python (default)
libpython3-stdlib_3.6.7-1~18.04_amd64.deb interactive high-level object-oriented language (default python3 version)
libpython3.6-dev_3.6.8-1~18.04.2_amd64.deb Header files and a static library for Python (v3.6)
libpython3.6-minimal_3.6.8-1~18.04.2_amd64.deb Minimal subset of the Python language (version 3.6)
Advertisement
Advertisement