libpq-dev_10.6-0ubuntu0.18.04.1_amd64.deb


Advertisement

Description

libpq-dev - header files for libpq5 (PostgreSQL library)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package name libpq-dev
Package version 10.6
Package release 0ubuntu0.18.04.1
Package architecture amd64
Package type deb
Installed size 1.03 KB
Download size 211.94 KB
Official Mirror archive.ubuntu.com
Header files and static library for compiling C programs to link
with the libpq library in order to communicate with a PostgreSQL
database backend.
PostgreSQL is an object-relational SQL database management system.

Alternatives

Package Version Architecture Repository
libpq-dev_10.6-0ubuntu0.18.04.1_i386.deb 10.6 i386 Ubuntu Updates Main
libpq-dev_10.3-1_amd64.deb 10.3 amd64 Ubuntu Main
libpq-dev_10.3-1_i386.deb 10.3 i386 Ubuntu Main
libpq-dev - - -

Requires

Name Value
libpq5 = 10.6-0ubuntu0.18.04.1

Download

Type URL
Binary Package libpq-dev_10.6-0ubuntu0.18.04.1_amd64.deb
Source Package postgresql-10

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpq-dev deb package:
    # sudo apt-get install libpq-dev

Files

Path
/usr/bin/pg_config
/usr/include/postgresql/libpq-events.h
/usr/include/postgresql/libpq-fe.h
/usr/include/postgresql/pg_config.h
/usr/include/postgresql/pg_config_ext.h
/usr/include/postgresql/pg_config_manual.h
/usr/include/postgresql/pg_config_os.h
/usr/include/postgresql/postgres_ext.h
/usr/include/postgresql/internal/c.h
/usr/include/postgresql/internal/libpq-int.h
/usr/include/postgresql/internal/port.h
/usr/include/postgresql/internal/postgres_fe.h
/usr/include/postgresql/internal/pqexpbuffer.h
/usr/include/postgresql/internal/libpq/pqcomm.h
/usr/include/postgresql/libpq/libpq-fs.h
/usr/lib/x86_64-linux-gnu/libpgcommon.a
/usr/lib/x86_64-linux-gnu/libpgfeutils.a
/usr/lib/x86_64-linux-gnu/libpgport.a
/usr/lib/x86_64-linux-gnu/libpq.a
/usr/lib/x86_64-linux-gnu/libpq.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libpq.pc
/usr/share/doc/libpq-dev/changelog.Debian.gz
/usr/share/doc/libpq-dev/copyright
/usr/share/man/man1/pg_config.1.gz

Changelog

See postgresql-10_10.6-0ubuntu0.18.04.1_amd64.deb changelog.

See Also

Package Description
libpq5_10.6-0ubuntu0.18.04.1_amd64.deb PostgreSQL C client library
libprocps-dev_3.3.12-3ubuntu1.1_amd64.deb library for accessing process information from /proc
libprocps6_3.3.12-3ubuntu1.1_amd64.deb library for accessing process information from /proc
libptexenc-dev_2017.20170613.44572-8ubuntu0.1_amd64.deb TeX Live: ptex encoding library (development part)
libptexenc1_2017.20170613.44572-8ubuntu0.1_amd64.deb TeX Live: pTeX encoding library
libpulse-dev_11.1-1ubuntu7.1_amd64.deb PulseAudio client development headers and libraries
libpulse-mainloop-glib0_11.1-1ubuntu7.1_amd64.deb PulseAudio client libraries (glib support)
libpulse0_11.1-1ubuntu7.1_amd64.deb PulseAudio client libraries
libpulsedsp_11.1-1ubuntu7.1_amd64.deb PulseAudio OSS pre-load library
libpython2.7-dev_2.7.15~rc1-1ubuntu0.1_amd64.deb Header files and a static library for Python (v2.7)
libpython2.7-minimal_2.7.15~rc1-1ubuntu0.1_amd64.deb Minimal subset of the Python language (version 2.7)
libpython2.7-stdlib_2.7.15~rc1-1ubuntu0.1_amd64.deb Interactive high-level object-oriented language (standard library, version 2.7)
libpython2.7_2.7.15~rc1-1ubuntu0.1_amd64.deb Shared Python runtime library (version 2.7)
libpython3-all-dev_3.6.7-1~18.04_amd64.deb package depending on all supported Python 3 development packages
libpython3-dev_3.6.7-1~18.04_amd64.deb header files and a static library for Python (default)
Advertisement
Advertisement