libmspack-dev_0.6-3ubuntu0.3_amd64.deb


Advertisement

Description

libmspack-dev - library for Microsoft compression formats (development files)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename libmspack-dev_0.6-3ubuntu0.3_amd64.deb
Package name libmspack-dev
Package version 0.6
Package release 3ubuntu0.3
Package architecture amd64
Package type deb
Category libdevel
Homepage https://www.cabextract.org.uk/libmspack/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 52.93 KB
Installed size 207.00 KB
The purpose of libmspack is to provide both compression and decompression of
some loosely related file formats used by Microsoft. The intention is to
support all of the following formats: COMPRESS.EXE [SZDD],
Microsoft Help (.HLP), COMPRESS.EXE [KWAJ], Microsoft Cabinet (.CAB),
HTML Help (.CHM), Microsoft eBook (.LIT), Windows Imaging Format (.WIM),
Exchange Offline Address Book (.LZX).

Alternatives

Package Version Architecture Repository
libmspack-dev_0.6-3ubuntu0.3_i386.deb 0.6 i386 Ubuntu Updates Main
libmspack-dev_0.6-3_i386.deb 0.6 i386 Ubuntu Main
libmspack-dev_0.6-3_amd64.deb 0.6 amd64 Ubuntu Main
libmspack-dev - - -

Requires

Name Value
libmspack0 = 0.6-3ubuntu0.3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libmspack-dev_0.6-3ubuntu0.3_amd64.deb
Source Package libmspack

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmspack-dev deb package:
    # sudo apt-get install libmspack-dev

Files

Path
/usr/include/mspack.h
/usr/lib/x86_64-linux-gnu/libmspack.a
/usr/lib/x86_64-linux-gnu/libmspack.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libmspack.pc
/usr/share/doc/libmspack-dev/changelog.Debian.gz
/usr/share/doc/libmspack-dev/copyright

Changelog

2019-07-17 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libmspack (0.6-3ubuntu0.3) bionic-security; urgency=medium
* SECURITY UPDATE: Buffer overflow
- debian/patches/CVE-2019-1010305.patch: length checks when looking
for control files in mspack/chmd.c.
- CVE-2019-1010305
2018-11-08 - Alex Murray <alex.murray@canonical.com>
libmspack (0.6-3ubuntu0.2) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-18585.patch: Ensure file names are valid in chmd.c
- CVE-2018-18585
* SECURITY UPDATE: One byte buffer overflow -
- debian/patches/CVE-2018-18584.patch: Ensure input buffer is large
enough in cab.h
- CVE-2018-18584
2018-08-01 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libmspack (0.6-3ubuntu0.1) bionic-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-14679-and-CVE-2018-14680.patch:
fix in chmd.c.
- CVE-2018-14679
- CVE-2018-14680
* SECURITY UPDATE: Bytes overwire with bad KWAJ file extension
- debian/patches/CVE-2018-14681.patch: fix in Makefile.am,
mspack/kwajd.c, test/kwajd_test.c and add some files
for test propose in test_files/kwajd/f*.kwj.
- CVE-2018-14681
* SECURITY UPDATE: Off-by-one error
- debian/patches/CVE-2018-14682.patch: fix in mspack/chmd.c.
- CVE-2018-14682
2017-08-17 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.6-3) unstable; urgency=medium
* Move doc generation in dh's indep rules to fix FTBFS
2017-08-17 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.6-2) unstable; urgency=medium
* Missing dependency on 'doxygen' for doc creation (Closes: #872193)
* Fixed lintian useless-autoreconf-build-depends.
2017-08-15 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.6-1) unstable; urgency=medium
* New upstream release:
+ Fix CVE-2017-6419 (Closes: #871263)
+ Fix CVE-2017-11423 (Closes: #868956)
* Fix building documentation.
* Use HTTPS in package metadata.
* Transition to automatic debug packages.
* Package now conforms to Standards-Version 4.0.0.
* Switch to compat level 10.
2015-02-02 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.5-1) unstable; urgency=medium
* New upstream fix-only release:
+ Fix previously reported bugs with an upstream approved patch
(#773041, #774725, #774726)
+ Fixes many security-sensitive bugs (Closes: #775687, #775498,
#774665, #775499).
2015-01-13 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.4-3) unstable; urgency=medium
* Added (slightly modified/split) patches from Jakub Wilk to fix
programmation errors causing segfaults and security issues:
- fix-division-by-zero.patch
- fix-pointer-arithmetic-overflow.patch
- fix-name-field-boundaries.patch
(Closes: #774725, #774726)
2014-12-30 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.4-2) unstable; urgency=medium
* Added patch 'qtmd-fix-frame_end-overflow.patch' to fix an overflow
causing an infinite loop in some situation (Closes: #773041).
2013-08-16 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
libmspack (0.4-1) unstable; urgency=low
* Initial release. (Closes: #711232)

See Also

Package Description
libmspack-doc_0.6-3ubuntu0.3_all.deb library for Microsoft compression formats (documentation)
libmspack0_0.6-3ubuntu0.3_amd64.deb library for Microsoft compression formats (shared library)
libmutter-2-0_3.28.4-0ubuntu18.04.2_amd64.deb window manager library from the Mutter window manager
libmutter-2-dev_3.28.4-0ubuntu18.04.2_amd64.deb Development files for the Mutter window manager
libmysqlclient-dev_5.7.29-0ubuntu0.18.04.1_amd64.deb MySQL database development files
libmysqlclient20_5.7.29-0ubuntu0.18.04.1_amd64.deb MySQL database client library
libmysqld-dev_5.7.29-0ubuntu0.18.04.1_amd64.deb MySQL embedded database development files
libnautilus-extension-dev_3.26.4-0~ubuntu18.04.5_amd64.deb libraries for nautilus components - development version
libnautilus-extension1a_3.26.4-0~ubuntu18.04.5_amd64.deb libraries for nautilus components - runtime version
libncurses5-dev_6.1-1ubuntu1.18.04_amd64.deb developer's libraries for ncurses
libncurses5_6.1-1ubuntu1.18.04_amd64.deb shared libraries for terminal handling
libncursesw5-dev_6.1-1ubuntu1.18.04_amd64.deb developer's libraries for ncursesw
libncursesw5_6.1-1ubuntu1.18.04_amd64.deb shared libraries for terminal handling (wide character support)
libneon27-dev_0.30.2-3~ubuntu18.04.1_amd64.deb Header and static library files for libneon27
libneon27-gnutls-dev_0.30.2-3~ubuntu18.04.1_amd64.deb Header and static library files for libneon27 (GnuTLS enabled)
Advertisement
Advertisement