libbz2-dev_1.0.6-8.1ubuntu0.2_amd64.deb


Advertisement

Description

libbz2-dev - high-quality block-sorting file compressor library - development

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename libbz2-dev_1.0.6-8.1ubuntu0.2_amd64.deb
Package name libbz2-dev
Package version 1.0.6
Package release 8.1ubuntu0.2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.bzip.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.26 KB
Installed size 94.00 KB
Static libraries and include files for the bzip2 compressor library.
bzip2 is a freely available, patent free, high-quality data compressor.
It typically compresses files to within 10% to 15% of the best available
techniques, whilst being around twice as fast at compression and six
times faster at decompression.
bzip2 compresses files using the Burrows-Wheeler block-sorting text
compression algorithm, and Huffman coding.  Compression is generally
considerably better than that achieved by more conventional
LZ77/LZ78-based compressors, and approaches the performance of the PPM
family of statistical compressors.
The archive file format of bzip2 (.bz2) is incompatible with that of its
predecessor, bzip (.bz).

Alternatives

Package Version Architecture Repository
libbz2-dev_1.0.6-8.1ubuntu0.2_i386.deb 1.0.6 i386 Ubuntu Updates Main
libbz2-dev_1.0.6-8.1_i386.deb 1.0.6 i386 Ubuntu Main
libbz2-dev_1.0.6-8.1_amd64.deb 1.0.6 amd64 Ubuntu Main
libbz2-dev - - -

Requires

Name Value
libbz2-1.0 = 1.0.6-8.1ubuntu0.2
libc-dev -
libc6-dev -

Replaces

Name Value
bzip2 << 0.9.5d-3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libbz2-dev_1.0.6-8.1ubuntu0.2_amd64.deb
Source Package bzip2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbz2-dev deb package:
    # sudo apt-get install libbz2-dev

Files

Path
/usr/include/bzlib.h
/usr/lib/x86_64-linux-gnu/libbz2.a
/usr/lib/x86_64-linux-gnu/libbz2.so
/usr/share/doc/libbz2-dev

Changelog

2019-07-04 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
bzip2 (1.0.6-8.1ubuntu0.2) bionic-security; urgency=medium
* SECURITY REGRESSION: bzip2 update for CVE-2019-12900 causes some files raises
incorrect CRC error. (LP: #1834494)
- debian/patches/Accept-as-many-selectors-as-selectors*.patch
2019-06-24 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
bzip2 (1.0.6-8.1ubuntu0.1) bionic-security; urgency=medium
* SECURITY UPDATE: out-of-bounds write
- debian/patches/CVE-2019-12900.patch: make sure
nSelectors is not out of range in decompress.c.
- CVE-2019-12900
2017-01-29 - Ben Hutchings <ben@decadent.org.uk>
bzip2 (1.0.6-8.1) unstable; urgency=medium
* Non-maintainer upload.
* bzip2recover: Fix potential use-after-free, Closes: #827744 (CVE-2016-3189)
2015-05-19 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-8) unstable; urgency=medium
* Remove Jorge Ernesto Guevara Cuenca from Uploaders, as agreed with him.
* Drop unused Build-Depends: gcc-multilib. Thanks to Helmut Grohne
<helmut@subdivi.de>. Closes: #778640
* Bump Standards-Version to 3.9.6. No changes needed.
2014-07-31 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-7) unstable; urgency=medium
* d/control: Remove useless lib{32,64}bz2* transition fields
(Conflicts/Replaces/Provides).
2014-07-27 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-6) unstable; urgency=low
[ Steve Langasek ]
* Convert packaging to dh(1). Closes: #754337
* Drop obsolete maintainer script which hasn't been needed for a decade.
* Refactor the build targets so that we can move texinfo to
Build-Depends-Indep.
[ Santiago Ruano Rincón ]
* d/rules: override dh_auto_clean to call make clean.
* libbz2-dev recommends bzip2-doc to fulfill the lack of specific
development documentation. Closes: #149953
* Remove lib{32,64}bz2-{1.0,dev} packages. No longer needed, we rely on
multiarch now. 
libbz2-{1.0,dev} conflict/replace/provide the removed
packages Closes: #736815
* d/copyright.in: fix versionless GPL.
* Bump Standards-Version to 3.9.5. No changes needed.
* Add ${misc:Depends} to all binary packages' dependencies.
2013-08-13 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-5) unstable; urgency=low
* Adding watch file
* Updating rules clean rule.
* Updating Standards-Version to 3.9.4. No changes needed.
* Don't drink and upload release. Thanks to bubulle, habanero and 
all the Cheese and Wine orga team.
2012-07-27 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-4) unstable; urgency=low
* Updating 30-bzip2-harden.patch, hardening LDFLAGS was missing for
libbz2.so. Thanks to Simon Ruderich. Closes: #655164
2012-06-08 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-3) unstable; urgency=low
* Bumped bzip2 priority from optional to standard. Closes: #642657
2012-06-03 - Santiago Ruano Rincón <santiago@debian.org>
bzip2 (1.0.6-2) unstable; urgency=low
* Added 10-bzip2.1.patch to remove wrong black spaces in man page.
Thanks to Bjarni Ingi Gislason. Closes: #675380
* 30-bzip2-harden.patch to enable hardened build flags. Thanks to
Moritz Muehlenhoff. Closes: #655164

See Also

Package Description
libc6-arm64-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-dev-arm64-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-armhf-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-powerpc-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-ppc64el-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-powerpc-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-ppc64el-cross_2.27-3ubuntu1cross1.1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libcaca-dev_0.99.beta19-2ubuntu0.18.04.1_amd64.deb development files for libcaca
libcaca0_0.99.beta19-2ubuntu0.18.04.1_amd64.deb colour ASCII art library
libcairo-gobject2_1.15.10-2ubuntu0.1_amd64.deb Cairo 2D vector graphics library (GObject library)
libcairo-script-interpreter2_1.15.10-2ubuntu0.1_amd64.deb Cairo 2D vector graphics library (script interpreter)
libcairo2-dev_1.15.10-2ubuntu0.1_amd64.deb Development files for the Cairo 2D graphics library
libcairo2-doc_1.15.10-2ubuntu0.1_all.deb Documentation for the Cairo Multi-platform 2D graphics library
libcairo2_1.15.10-2ubuntu0.1_amd64.deb Cairo 2D vector graphics library
Advertisement
Advertisement